Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 AVC / H.264

Reply
 
Thread Tools Search this Thread Display Modes
Old 15th July 2012, 00:17   #1  |  Link
ramprasad85
Registered User
 
Join Date: Oct 2008
Location: Chennai India
Posts: 31
Corrupt frames when using lavf

Thanks for adding support for VFR video .

Here is an issue with the latest version of x264 (core:125 r2200 999b753)

First few frames are getting corrupted.

Here is the source video http://dl.dropbox.com/u/55917837/interview.avi

Here is the encoded video http://dl.dropbox.com/u/55917837/x264.flv

Here is the command used

x264.exe interview.avi -B 600 -o int.flv --demuxer lavf

Here is the output displayed
Code:
lavf [info]: 720x480p 0:1 @ 1000/1 fps (vfr)
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 FastShuffle SSE4.2
x264 [info]: profile High, level 5.2
flv [info]: initial delay 120 ms
x264 [info]: frame I:5     Avg QP:25.72  size: 24273
x264 [info]: frame P:53    Avg QP:21.52  size:  4809
x264 [info]: frame B:107   Avg QP:28.95  size:   593
x264 [info]: consecutive B-frames: 12.7%  2.4%  0.0% 84.8%
x264 [info]: mb I  I16..4: 35.2% 42.2% 22.7%
x264 [info]: mb P  I16..4:  3.6%  6.1%  1.2%  P16..4: 22.6%  7.0%  3.9%  0.0%  0.0%    skip:55.5%
x264 [info]: mb B  I16..4:  0.0%  0.1%  0.0%  B16..8: 22.5%  1.1%  0.2%  direct: 0.3%  skip:75.7%  L0:46.6% L1:47.7% BI: 5.7%
x264 [info]: final ratefactor: 22.40
x264 [info]: 8x8 transform intra:49.6% inter:60.6%
x264 [info]: coded y,uvDC,uvAC intra: 43.8% 62.8% 31.4% inter: 5.9% 5.8% 0.7%
x264 [info]: i16 v,h,dc,p: 57% 20% 18%  6%
x264 [info]: i8 v,h,dc,ddl,ddr,vr,hd,vl,hu: 25% 12% 43%  3%  3%  4%  3%  3%  3%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 34% 20% 17%  4%  6%  5%  6%  4%  4%
x264 [info]: i8c dc,h,v,p: 52% 18% 26%  3%
x264 [info]: Weighted P-Frames: Y:3.8% UV:3.8%
x264 [info]: ref P L0: 70.3% 13.0% 12.9%  3.6%  0.2%
x264 [info]: ref B L0: 89.1% 10.0%  0.9%
x264 [info]: ref B L1: 94.5%  5.5%
x264 [info]: kb/s:545.21

encoded 165 frames, 75.62 fps, 546.12 kb/s
Note: There is no such issue when ffms is used.

Thanks and Regards
ramprasad85 is offline   Reply With Quote
Old 15th July 2012, 04:36   #2  |  Link
Blue_MiSfit
Derek Prestegard IRL
 
Blue_MiSfit's Avatar
 
Join Date: Nov 2003
Location: Los Angeles
Posts: 5,957
I've moved this post to a new thread, as it certainly did not belong in the long-since dead lavf input testing thread.

Please do not bring threads back to life
__________________
These are all my personal statements, not those of my employer :)
Blue_MiSfit is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 04:03.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.