Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > Avisynth Usage

Reply
 
Thread Tools Search this Thread Display Modes
Old 29th March 2011, 21:13   #1  |  Link
Max_Cady
Registered User
 
Max_Cady's Avatar
 
Join Date: Apr 2008
Posts: 11
Final ratefactor problem

i'm getting low final ratefactor when i use filters(MCTemporalDenoise,LSFmod).No problem with usual way.Why is this happening?

Example avs:
Code:
,
,
MCTemporalDenoise(settings="medium")

Spline36Resize(1280,720)
Max_Cady is offline   Reply With Quote
Old 30th March 2011, 09:54   #2  |  Link
kypec
User of free A/V tools
 
kypec's Avatar
 
Join Date: Jul 2006
Location: SK
Posts: 826
What ratefactor are you referring to? Do you mean average QP values when encoding with x264 CRF mode? Anyway, explain better what is your question about and don't forget to post AVS scripts & command line parameters & output logs.
kypec is offline   Reply With Quote
Old 30th March 2011, 10:45   #3  |  Link
Groucho2004
 
Join Date: Mar 2006
Location: Barcelona
Posts: 5,034
I'm guessing that you're doing 2-pass encodes and the "Final Ratefactor" is what x264 uses as a starting value for the second pass. It will constantly adjust it to reach the desired target bitrate.

If you're using de-noising filters, the compressibility increases and therefore the quality (i.e. the rate factor) at a given bitrate.
Groucho2004 is offline   Reply With Quote
Old 30th March 2011, 15:08   #4  |  Link
Max_Cady
Registered User
 
Max_Cady's Avatar
 
Join Date: Apr 2008
Posts: 11
Quote:
[Information] Log
-[Information] Versions
--[Information] [28.03.2011 17:16:05] MeGUI Version : 2002 (svn)
--[Information] [28.03.2011 17:16:05] OS : Windows Seven Ultimate Edition x86 SP1 (6.1.65536.7601)
--[Information] [28.03.2011 17:16:05] Latest .Net Framework installed : 3.5 (3.5.30729.5420)
--[Information] [28.03.2011 17:16:05] Avisynth Version : 2.5.7.0 (01.03.2007 19:27:14)
-[Information] Update detection
--[Information] [28.03.2011 17:16:05] Connecting to server: http://megui.org/auto/
--[Information] [28.03.2011 17:16:08] All files are up to date
-[Information] Log for job1 (video, 1.avs -> )
--[Information] [28.03.2011 17:21:32] Started handling job
--[Information] [28.03.2011 17:21:32] Preprocessing
--[Information] [28.03.2011 17:21:32] Avisynth input script
---[NoImage] LoadPlugin("C:\Program Files\AviSynth 2.5\plugins\MT.dll")
---[NoImage] import("c:\program files\avisynth 2.5\plugins\MCTemporalDenoise.v1.4.20.avs")
---[NoImage] import("c:\program files\avisynth 2.5\plugins\LSFmod.v1.9.avs")
---[NoImage] LoadPlugin("C:\Program Files\MeGUI_1989_x86\tools\dgavcindex\DGAVCDecode.dll")
---[NoImage] AVCSource("C:\Users\Unforgiven\Desktop\xxx\1.dga")
---[NoImage] #deinterlace
---[NoImage] #crop
---[NoImage] Spline36Resize(848,360)
---[NoImage] MT(""" MCTemporalDenoise(settings="medium") """, threads=8, overlap=16)
--[Information] [28.03.2011 17:22:16] Job commandline: "C:\Program Files\MeGUI_1989_x86\tools\x264\x264.exe" --level 4.1 --pass 1 --bitrate 2278 --stats "C:\Users\Unforgiven\Desktop\xxx\1.stats" --deblock -2:-1 --keyint 60 --bframes 8 --b-pyramid strict --ref 16 --slices 4 --qpmin 10 --qpmax 51 --vbv-bufsize 30000 --vbv-maxrate 40000 --aq-strength 0.8 --merange 24 --me umh --direct auto --subme 10 --partitions all --trellis 2 --no-dct-decimate --no-fast-pskip --output NUL "C:\Users\Unforgiven\Desktop\xxx\1.avs"
--[Information] [28.03.2011 17:22:16] Encoding started
--[Information] [29.03.2011 07:52:30] Standard output stream
--[Information] [29.03.2011 07:52:30] Standard error stream
---[NoImage] avs [info]: 720x576p 64:45 @ 24000/1001 fps (cfr)
---[NoImage] x264 [info]: using cpu capabilities: MMX2 SSE2Fast FastShuffle SSEMisalign LZCNT
---[NoImage] x264 [info]: profile Main, level 4.1
---[NoImage]
---[NoImage] x264 [info]: frame I:6482 Avg QP:12.79 size: 64370
---[NoImage] x264 [info]: frame P:131852 Avg QP:15.81 size: 20731
---[NoImage] x264 [info]: frame B:191572 Avg QP:18.30 size: 4027
---[NoImage] x264 [info]: consecutive B-frames: 13.5% 27.2% 16.7% 19.0% 19.9% 2.7% 0.2% 0.0% 0.9%
---[NoImage] x264 [info]: mb I I16..4: 24.2% 0.0% 75.8%
---[NoImage] x264 [info]: mb P I16..4: 22.2% 0.0% 0.0% P16..4: 72.1% 0.0% 0.0% 0.0% 0.0% skip: 5.8%
---[NoImage] x264 [info]: mb B I16..4: 2.5% 0.0% 0.0% B16..8: 31.4% 0.0% 0.0% direct:16.9% skip:49.2% L0:28.4% L1:38.8% BI:32.8%
---[NoImage] x264 [info]: final ratefactor: 15.12
---[NoImage] x264 [info]: direct mvs spatial:99.5% temporal:0.5%
---[NoImage] x264 [info]: coded y,uvDC,uvAC intra: 58.5% 54.4% 24.3% inter: 33.0% 23.3% 10.5%
---[NoImage] x264 [info]: i16 v,h,dc,p: 50% 18% 23% 9%
---[NoImage] x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 28% 16% 16% 3% 9% 7% 5% 7% 7%
---[NoImage] x264 [info]: i8c dc,h,v,p: 56% 15% 24% 5%
---[NoImage] x264 [info]: Weighted P-Frames: Y:2.6% UV:0.7%
---[NoImage] x264 [info]: kb/s:2280.33
---[NoImage] encoded 329906 frames, 6.32 fps, 2280.33 kb/s
--[Information] [29.03.2011 07:52:30] Postprocessing
---[Information] Deleting intermediate files
--[Information] [29.03.2011 07:52:30] Job completed
-[Information] Log for job2 (video, 1.avs -> 1.mkv)
--[Information] [29.03.2011 07:52:30] Started handling job
--[Information] [29.03.2011 07:52:30] Preprocessing
--[Information] [29.03.2011 07:52:30] Avisynth input script
---[NoImage] LoadPlugin("C:\Program Files\AviSynth 2.5\plugins\MT.dll")
---[NoImage] import("c:\program files\avisynth 2.5\plugins\MCTemporalDenoise.v1.4.20.avs")
---[NoImage] import("c:\program files\avisynth 2.5\plugins\LSFmod.v1.9.avs")
---[NoImage] LoadPlugin("C:\Program Files\MeGUI_1989_x86\tools\dgavcindex\DGAVCDecode.dll")
---[NoImage] AVCSource("C:\Users\Unforgiven\Desktop\xxx\1.dga")
---[NoImage] #deinterlace
---[NoImage] #crop
---[NoImage] Spline36Resize(848,720)
---[NoImage] MT(""" MCTemporalDenoise(settings="medium") """, threads=8, overlap=16)
--[Information] [29.03.2011 07:53:11] Job commandline: "C:\Program Files\MeGUI_1989_x86\tools\x264\x264.exe" --level 4.1 --pass 2 --bitrate 2278 --stats "C:\Users\Unforgiven\Desktop\xxx\1.stats" --deblock -2:-1 --keyint 60 --bframes 8 --b-pyramid strict --ref 16 --slices 4 --qpmin 10 --qpmax 51 --vbv-bufsize 30000 --vbv-maxrate 40000 --aq-strength 0.8 --merange 24 --me umh --direct auto --subme 10 --partitions all --trellis 2 --no-dct-decimate --no-fast-pskip --output "C:\Users\Unforgiven\Desktop\xxx\1.mkv" "C:\Users\Unforgiven\Desktop\xxx\1.avs"
--[Information] [29.03.2011 07:53:11] Encoding started
--[Information] [30.03.2011 02:22:03] Standard output stream
--[Information] [30.03.2011 02:22:03] Standard error stream
---[NoImage] avs [info]: 720x576p 64:45 @ 24000/1001 fps (cfr)
---[NoImage] x264 [info]: using cpu capabilities: MMX2 SSE2Fast FastShuffle SSEMisalign LZCNT
---[NoImage] x264 [info]: profile High, level 4.1
---[NoImage]
---[NoImage] x264 [info]: frame I:6482 Avg QP:14.40 size: 57689
---[NoImage] x264 [info]: frame P:131852 Avg QP:16.07 size: 21454
---[NoImage] x264 [info]: frame B:191572 Avg QP:19.93 size: 3734
---[NoImage] x264 [info]: consecutive B-frames: 13.5% 27.2% 16.7% 19.0% 19.9% 2.7% 0.2% 0.0% 0.9%
---[NoImage] x264 [info]: mb I I16..4: 5.9% 70.1% 24.1%
---[NoImage] x264 [info]: mb P I16..4: 1.0% 5.6% 0.9% P16..4: 47.1% 30.6% 10.0% 1.3% 1.1% skip: 2.5%
---[NoImage] x264 [info]: mb B I16..4: 0.0% 0.1% 0.0% B16..8: 39.4% 11.4% 2.9% direct: 4.1% skip:41.9% L0:36.0% L1:45.0% BI:19.0%
---[NoImage] x264 [info]: 8x8 transform intra:72.7% inter:49.0%
---[NoImage] x264 [info]: direct mvs spatial:96.3% temporal:3.7%
---[NoImage] x264 [info]: coded y,uvDC,uvAC intra: 79.5% 74.0% 45.9% inter: 27.1% 23.2% 13.1%
---[NoImage] x264 [info]: i16 v,h,dc,p: 37% 11% 16% 36%
---[NoImage] x264 [info]: i8 v,h,dc,ddl,ddr,vr,hd,vl,hu: 15% 8% 8% 9% 12% 13% 10% 13% 12%
---[NoImage] x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 15% 6% 7% 11% 14% 14% 10% 12% 11%
---[NoImage] x264 [info]: i8c dc,h,v,p: 43% 23% 22% 11%
---[NoImage] x264 [info]: Weighted P-Frames: Y:2.8% UV:0.7%
---[NoImage] x264 [info]: ref P L0: 58.3% 10.8% 12.0% 5.2% 3.5% 2.6% 2.0% 1.2% 1.0% 0.8% 0.7% 0.5% 0.5% 0.4% 0.4% 0.2%
---[NoImage] x264 [info]: ref B L0: 87.2% 6.0% 2.7% 1.2% 0.8% 0.6% 0.5% 0.3% 0.2% 0.2% 0.1% 0.1% 0.1% 0.1%
---[NoImage] x264 [info]: ref B L1: 94.6% 5.4%
---[NoImage] x264 [info]: kb/s:2277.95
---[NoImage] encoded 329906 frames, 4.96 fps, 2277.95 kb/s
--[Information] Final statistics
---[Information] [30.03.2011 02:22:46] Video Bitrate Desired: 2278 kbit/s
---[Information] [30.03.2011 02:22:46] Video Bitrate Obtained (approximate): 2279 kbit/s
--[Information] [30.03.2011 02:22:46] Postprocessing
---[Information] Deleting intermediate files
----[Information] [30.03.2011 02:22:46] Successfully deleted C:\Users\Unforgiven\Desktop\xxx\1.stats
----[Information] [30.03.2011 02:22:46] Successfully deleted C:\Users\Unforgiven\Desktop\xxx\1.stats.mbtree
--[Information] [30.03.2011 02:22:46] Job completed
Quote:
LoadPlugin("C:\Program Files\AviSynth 2.5\plugins\MT.dll")
import("c:\program files\avisynth 2.5\plugins\MCTemporalDenoise.v1.4.20.avs")
import("c:\program files\avisynth 2.5\plugins\LSFmod.v1.9.avs")
LoadPlugin("C:\Program Files\MeGUI_1989_x86\tools\dgavcindex\DGAVCDecode.dll")
AVCSource("C:\Users\Unforgiven\Desktop\Once Upon A Time In America (1984)\1.dga")
#deinterlace
#crop

Spline36Resize(848,360)

MT(""" MCTemporalDenoise(settings="medium") """, threads=8, overlap=16)
if i dont use denoisers, i'm getting higher ratefactor(18-19) same final filesize that is the problem.
Max_Cady is offline   Reply With Quote
Old 30th March 2011, 15:16   #5  |  Link
Rumbah
Registered User
 
Join Date: Mar 2003
Posts: 473
The file size shouldn't change as you specified a bitrate (2278).
A lower ratefactor means better quality. So if you filter the noise it is easier to compress so x264 has to use a higher quality to hit the desired bitrate.
In exchange you could lower the bitrate if you filter the noise to get a similar ratefactor result.
Rumbah is offline   Reply With Quote
Old 30th March 2011, 16:07   #6  |  Link
Groucho2004
 
Join Date: Mar 2006
Location: Barcelona
Posts: 5,034
Quote:
Originally Posted by Max_Cady View Post
if i dont use denoisers, i'm getting higher ratefactor(18-19) same final filesize that is the problem.
OK, you don't understand the replies so let's try something different - What makes you believe you have a "problem" when the ratefactor is lower?
Groucho2004 is offline   Reply With Quote
Old 2nd April 2011, 23:38   #7  |  Link
ajp_anton
Registered User
 
ajp_anton's Avatar
 
Join Date: Aug 2006
Location: Stockholm/Helsinki
Posts: 797
Lower ratefactor = better quality.

When you denoise, the video is easier to compress.
Using the same bitrate on the denoised video, x264 will have an easier job making the encode look like the source (x264's source is the denoised video), which for x264 means a higher quality, and therefore a lower ratefactor. x264 has no idea what the video looked like before denoising.
ajp_anton is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 00:38.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.