Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 Encoder GUIs

Reply
 
Thread Tools Search this Thread Display Modes
Old 21st March 2011, 03:52   #1  |  Link
Mahonni
Registered User
 
Join Date: Oct 2006
Posts: 2
Sync problem

Hi all,

I'm trying to convert a MPEG2 file (Super8) to x264 using MeGUI. I'm not very experienced in that matter, since I've done it many times but everything went straightforward all the time and I stuck with the most common options.

Right now I have a problem with the sync. I know many people have problems with sync, but I couldn't find this answer in the forums :S (here it looks like the same problem, although my case it's not a cartoon). So, it's not something that can be solved with a delay, it's just that the audio tends to be delayed as long as the video reaches the end. In fact, after doing the DGIndex I checked the audio length and it looks a bit shorter than the video itself. I even tried to convert the audio to PCM and mux it there (the muxer didn't like the mp2 audio file), with no success.

Can anyone help me with that?

Oh, the source is PAL, 25.000 fps, encoded in MPEG2, and the audio is 48KHz, in MPEG Audio (version 1) (Layer 2). I'm not sure if it's VBR (or if it's possible in this format, media info doesn't say anything about that), since I read encoders have trouble with MP3 VBR.

Thanks!!
Mahonni is offline   Reply With Quote
Old 1st April 2011, 00:28   #2  |  Link
Mahonni
Registered User
 
Join Date: Oct 2006
Posts: 2
Please, can anyone help me with that? I'm getting crazy with this, trying all I can but with no luck.

Now I'm sure that my video is in VBR and that's what gives me trouble. I tried to demux en convert the audio in PCM, as well as the video to a lossless format but it still looses the synchronism. Trying to sync it manually is worthless, since when I sync one of the last scenes then I unsynchronize the rest of the video. I just can't capture in PCM or similar because my device doesn't allow me to do that.

I've seen many people with this problem but never any solution. Could it be that any video with VBR audio cannot be re-encoded because it looses sync forever?

Thanks again!
Mahonni is offline   Reply With Quote
Reply

Tags
megui dgindex audio delay, sync error, synchronization

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 16:29.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.