Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 Encoder GUIs

Reply
 
Thread Tools Search this Thread Display Modes
Old 8th April 2012, 09:37   #1  |  Link
Verminaard
Registered User
 
Join Date: Nov 2008
Posts: 18
File Indexer Problem (FFMSIndex and DGIndex)

Hello all,

I am having a strange problem with a friend's computer. I did search the forum but couldn't find the answer.

We have some MPG files that we want to convert to AVI. MPG files have MP2 audio, 352x288 resolution and 25 FPS.

I use one click encode on my computer and have no issues at all. But his computer does not encode the files, it fails at the beginning of the indexing process because it tries to use FFMSIndex instead of DGIndex. If we try to use the file indexer tool manually (CTRL+F2) it only allows the use of FFMSIndex and the other options are all grayed out. If we run the DGIndex manually from within the MeGUI folders and load the D2V file manually into MeGUI, it encodes fine.

Same MPG files work correctly on my computer. I have made a simple One Click profile. I am pasting it below. Just wondering if there is a way to add a line that will force the use of DGIndex in this profile or to another config file:

Code:
<?xml version="1.0"?>
<GenericProfileOfOneClickSettings xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  <Name>MPG Conversion</Name>
  <Settings>
    <VideoProfileName>XviD: *scratchpad*</VideoProfileName>
    <AudioProfileName>LAME MP3: *scratchpad*</AudioProfileName>
    <AvsProfileName>AviSynth: *scratchpad*</AvsProfileName>
    <PrerenderVideo>false</PrerenderVideo>
    <DontEncodeAudio>migrated</DontEncodeAudio>
    <AudioEncodingModeString>Never</AudioEncodingModeString>
    <DontEncodeVideo>false</DontEncodeVideo>
    <SignalAR>false</SignalAR>
    <AutomaticDeinterlacing>false</AutomaticDeinterlacing>
    <AutoCrop>true</AutoCrop>
    <KeepInputResolution>true</KeepInputResolution>
    <OutputResolution>720</OutputResolution>
    <Filesize xsi:nil="true" />
    <SplitSize xsi:nil="true" />
    <ContainerCandidates>
      <string>AVI</string>
      <string>MKV</string>
    </ContainerCandidates>
    <UseChaptersMarks>false</UseChaptersMarks>
  </Settings>
</GenericProfileOfOneClickSettings>
I am sorry if this question has answered before but I couldn't find the answer in the forums.

Thanks to all in advance.

Regards
Verminaard is offline   Reply With Quote
Old 8th April 2012, 14:00   #2  |  Link
Zathor
Registered User
 
Join Date: Nov 2009
Posts: 2,402
Please post the complete log of the MeGUI process and the MediaInfo of the file - or better upload a sample file.
Zathor is offline   Reply With Quote
Old 10th April 2012, 13:01   #3  |  Link
Zathor
Registered User
 
Join Date: Nov 2009
Posts: 2,402
The D2V indexer can only be used when the video type is "MPEG-1 VIDEO" or "MPEG-2 VIDEO" and the container format is "MPEG-TS", "MPEG-PS", "MPEG VIDEO" or "BDAV". Your file seems to be a different kind of video which can also be used with the indexer so please report the requested information and I can enable this kind of file as well.
Zathor is offline   Reply With Quote
Old 12th April 2012, 00:50   #4  |  Link
Verminaard
Registered User
 
Join Date: Nov 2008
Posts: 18
Hello,

Sorry for the delayed answer. I had to wait for my friend to send me the screenshots. Unfortunately, I can't upload a sample because it's copyrighted material.

Additionally, same files work fine on my computer with MeGUI. DGIndex works fine.

Here they are:

MeGUI Log:


Media Info:
Verminaard is offline   Reply With Quote
Old 12th April 2012, 11:11   #5  |  Link
Zathor
Registered User
 
Join Date: Nov 2009
Posts: 2,402
I cannot find the relevant information in the screenshots. Required is the "MediaInfo" part of your file in the MeGUI log. You can get this part e.g. when you open the file with the file indexer. Please upload it somewhere or post it here.
Zathor is offline   Reply With Quote
Old 12th April 2012, 13:03   #6  |  Link
Verminaard
Registered User
 
Join Date: Nov 2008
Posts: 18
Here you go:

Code:
[Information] FileIndexer
-[Information] [4/12/2012 15:01:01] MediaInfo
--[Information] File: XXXX
--[Information] General
---[Information] Format: MPEG-PS
---[Information] FormatString: MPEG-PS
---[Information] FileSize: 459980884
---[Information] PlayTime: 00:43:36.480
--[Information] Video
---[Information] ID: 224
---[Information] StreamOrder: 
---[Information] Width: 352
---[Information] Height: 288
---[Information] FrameCount: 66112
---[Information] FrameRate: 25.000
---[Information] ScanType: Progressive
---[Information] Codec: MPEG-1V
---[Information] CodecString: MPEG-1 Video
---[Information] Format: MPEG Video
---[Information] AspectRatio: 1.304
---[Information] AspectRatioString: 4:3
---[Information] Delay: 364.767
---[Information] Title: 
---[Information] Language: 
---[Information] LanguageString: 
--[Information] Audio
---[Information] ID: 192
---[Information] StreamOrder: 
---[Information] Format: MPEG Audio
---[Information] FormatProfile: Layer 2
---[Information] FormatSettingsSBR: 
---[Information] FormatSettingsPS: 
---[Information] SamplingRate: 44100
---[Information] SamplingRateString: 44.1 KHz
---[Information] Channels: 2
---[Information] ChannelsString: 2 channels
---[Information] ChannelPositionsString2: 
---[Information] BitRateMode: CBR
---[Information] Delay: 364.767
---[Information] Title: 
---[Information] Language: 
---[Information] LanguageString:
Verminaard is offline   Reply With Quote
Old 12th April 2012, 16:11   #7  |  Link
Zathor
Registered User
 
Join Date: Nov 2009
Posts: 2,402
That is quite strange. Your file has the proper settings and DGIndex should be available. I checked it with one of my files and it looks like this:



Does it look the same for you in the "File Information" block? And your DGIndex option is not available, correct?
Zathor is offline   Reply With Quote
Old 12th April 2012, 16:41   #8  |  Link
Verminaard
Registered User
 
Join Date: Nov 2008
Posts: 18
Yes indeed.

But for some reason it doesn't make the DGIndex available. Could this be somehow MeGUI can't find the DGIndex? Is there any config file that I can check for the default paths?
Verminaard is offline   Reply With Quote
Old 12th April 2012, 19:05   #9  |  Link
Zathor
Registered User
 
Join Date: Nov 2009
Posts: 2,402
Quote:
Originally Posted by Verminaard View Post
Could this be somehow MeGUI can't find the DGIndex? Is there any config file that I can check for the default paths?
MeGUI need this tool in \tools\dgindex\DGIndex.exe
But this will be checked also by the updater.

Is it possible that you upload a (short) sample file? You can send me the link in a PM if needed.
Zathor is offline   Reply With Quote
Old 12th April 2012, 23:33   #10  |  Link
ozok
TEncoder, TX264, TAC
 
ozok's Avatar
 
Join Date: Jun 2011
Location: Turkey
Posts: 540
This is probably stupid, but from the ss at 4th post i can say that files are at a directory containing Turkish letter "İ". Maybe this is the problem?
ozok is offline   Reply With Quote
Old 13th April 2012, 11:45   #11  |  Link
Verminaard
Registered User
 
Join Date: Nov 2008
Posts: 18
Ok. I will give you a sample. Could you please recommend me an application that could cut MPG files without reencoding? (Like VirtualDUB`s direct sream copy)

Thanks.
Verminaard is offline   Reply With Quote
Old 13th April 2012, 11:48   #12  |  Link
Verminaard
Registered User
 
Join Date: Nov 2008
Posts: 18
Quote:
Originally Posted by ozok View Post
This is probably stupid, but from the ss at 4th post i can say that files are at a directory containing Turkish letter "İ". Maybe this is the problem?
Nope, unfortunately it's not the problem. We've tried on several different paths and folders, from desktop. It always results the same way: MeGUI don't use DGIndex where it's supposed to use it.

Thanks for the input though.
Verminaard is offline   Reply With Quote
Old 13th April 2012, 16:26   #13  |  Link
Zathor
Registered User
 
Join Date: Nov 2009
Posts: 2,402
Quote:
Originally Posted by Verminaard View Post
Ok. I will give you a sample. Could you please recommend me an application that could cut MPG files without reencoding? (Like VirtualDUB`s direct sream copy)
With a tool like DGSplit you can split the file in several parts. The first part should be OK - the other ones very likely not. So please test the behavior with the first part (open in the File Indexer, open in DGIndex directly) and upload the segment.
Zathor is offline   Reply With Quote
Old 13th April 2012, 17:15   #14  |  Link
Verminaard
Registered User
 
Join Date: Nov 2008
Posts: 18
Ok. I've sent you the link for the sample.

Here's the breakdown for the sample:

On my computer:
One click -> Works fine and encodes it properly.
Regular MeGUI Method -> When loaded in the file indexer, DGIndex and FFMSindex are both available. DGIndex is selected by default. If I choose FFMSIndex it gives me a warning saying that I should use DGIndex.

On my friend's computer:
One click -> Generates the same error message from before.
Regular MeGUI Method -> When loaded in the file indexer, only FFMSindex is available. DGIndex is grayed out. And it doesn't work if we add to the queue and start the process (same error as above)
Old School Way -> Run the DGIndex separately from MeGUI folder, Index the file. Call the D2V from within MeGUI using AVS Script Creator, save the AVS file, encode. Works like a charm.

We have many MPG files with the same properties. All are doing the same thing on his computer.
Verminaard is offline   Reply With Quote
Old 14th April 2012, 10:18   #15  |  Link
Zathor
Registered User
 
Join Date: Nov 2009
Posts: 2,402
Mhm, I did not read your first posts very well. After your last post it is coming to my mind that only your friend's MeGUI build has this problem. Sorry. Btw your sample is working for me, too.

Please update both your MeGUI builds to 2138. Then compare the log information in the first block ("version"). Does all files have the same attributes?

And also please extract this file to a new directory on your friend's machine:
http://sourceforge.net/projects/megu...d?source=files

Try it with this installation. I only want to be sure that no other settings/files in the current installation is causing the problem.

As a last step - after you have reported back - I will create a special debug build of MeGUI in order to track down the problem.
Zathor is offline   Reply With Quote
Old 14th April 2012, 14:33   #16  |  Link
Verminaard
Registered User
 
Join Date: Nov 2008
Posts: 18
Thanks Zathor.

Where do we find the build 2138 (the link you've provided is still 2112)? It's the identical copy that we both have that is failing.

We've tried to run it on a different folder and let the updater download everything again. Still no go.

Quote:
Does all files have the same attributes?
Yes. Except the variable stuff like duration, video and audio bitrate. But main attributes (Codec, FPS, Resolution) all the same.

Last edited by Verminaard; 14th April 2012 at 14:35.
Verminaard is offline   Reply With Quote
Old 14th April 2012, 16:53   #17  |  Link
Zathor
Registered User
 
Join Date: Nov 2009
Posts: 2,402
Quote:
Originally Posted by Verminaard View Post
Where do we find the build 2138 (the link you've provided is still 2112)?
Switch in the MeGUI settings to the development update server and let the program update itself.

Quote:
Originally Posted by Verminaard View Post
It's the identical copy that we both have that is failing.
So you copied your MeGUI folder to his machine?
Zathor is offline   Reply With Quote
Old 14th April 2012, 17:29   #18  |  Link
Verminaard
Registered User
 
Join Date: Nov 2008
Posts: 18
He is not available at the moment. Once I talk to him, I'll tell him to update it this way.

Previously he was using the same files that are available from the link that you've provided. I have too, but I haven't copied my folder over his. He downloaded and updated himself.
Verminaard is offline   Reply With Quote
Old 14th April 2012, 19:16   #19  |  Link
Zathor
Registered User
 
Join Date: Nov 2009
Posts: 2,402
Please use this debug build:
http://www.mediafire.com/?w93f7mcqex6yp7k

Open the file with the File Indexer and send me the complete log file.
Zathor is offline   Reply With Quote
Old 17th April 2012, 12:25   #20  |  Link
Verminaard
Registered User
 
Join Date: Nov 2008
Posts: 18
Hello Zathor,

Sorry for the delayed answer, I just got a hold of my friend today. And I've got the log for you (attached). Actually, checking out the debug log gave me a pretty good idea about the cause. As you can see in the log :

Code:
--[Error] [17.04.2012 13:18:59] Unsupported codec found:_MPEG-1 VİDEO_
For some reason, MeGUI reads the codec information with İ which is a Turkish letter. He is using a Turkish copy of Windows. In the meantime he will switch to English Windows to see if it would solve the problem. I will report back on that one later.
Attached Files
File Type: txt MeGUI_LOG.txt (3.0 KB, 18 views)
Verminaard is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 16:26.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.