Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Programming and Hacking > Development

Reply
 
Thread Tools Search this Thread Display Modes
Old 6th September 2020, 17:01   #21  |  Link
qyot27
...?
 
qyot27's Avatar
 
Join Date: Nov 2005
Location: Florida
Posts: 1,428
Quote:
Originally Posted by Reino View Post
From the top of my head... libx265 doesn't support high bit-depth, but apart from that everything is the same.
It's not that it can't, it's that you have to use -DENABLE_ASSEMBLY:bool=off to enable 10 and 12 bit on i686 (which also means encoding to those bit depths will be slow as molasses, but it can be done). Nothing to do with XP.
qyot27 is offline   Reply With Quote
Old 6th September 2020, 17:37   #22  |  Link
Reino
Registered User
 
Reino's Avatar
 
Join Date: Nov 2005
Posts: 700
I know that libx265 supports high-bit-depth. I should've chosen my words more carefully. What I meant was: the libx265 that's part of my FFmpeg binary doesn't support high-bit-depth, because...

http://hg.videolan.org/x265/file/tip/source/CMakeLists.txt:
Code:
if(X64)
    # NOTE: We only officially support high-bit-depth compiles of x265
    # on 64bit architectures. [...]
    [...]
endif(X64)
__________________
My hobby website
Reino is offline   Reply With Quote
Old 30th April 2021, 19:40   #23  |  Link
Reino
Registered User
 
Reino's Avatar
 
Join Date: Nov 2005
Posts: 700
I've just uploaded new binaries. That is, only a static build for FFmpeg so far.

Running configure (while trying to compile a shared build) went just fine, but not with make. This is the short log:
Code:
GEN     libavutil/libavutil.version
GEN     libswscale/libswscale.version
GEN     libswresample/libswresample.version
GEN     libpostproc/libpostproc.version
GEN     libavcodec/libavcodec.version
GEN     libavformat/libavformat.version
GEN     libavfilter/libavfilter.version
GEN     libavdevice/libavdevice.version
CC      libavdevice/alldevices.o
CC      libavdevice/avdevice.o
CC      libavdevice/dshow.o
CC      libavdevice/dshow_common.o
CC      libavdevice/dshow_crossbar.o
CC      libavdevice/dshow_enummediatypes.o
CC      libavdevice/dshow_enumpins.o
CC      libavdevice/dshow_filter.o
CC      libavdevice/dshow_pin.o
CC      libavdevice/gdigrab.o
CC      libavdevice/lavfi.o
CC      libavdevice/reverse.o
CC      libavdevice/sdl2.o
CC      libavdevice/utils.o
CC      libavdevice/vfwcap.o
WINDRES libavdevice/avdeviceres.o
/bin/sh: /cygdrive/[...]/cross_compilers/mingw-w64-i686/bin/i686-w64-mingw32-gcc -E -xc-header 
-DRC_INVOKED -MMD -MF libavdevice/avdeviceres.d -MT libavdevice/avdeviceres.o: No such file or directory
/cygdrive/m/[...]/cross_compilers/mingw-w64-i686/bin/i686-w64-mingw32-windres: preprocessing failed.
make: *** [ffbuild/common.mak:93: libavdevice/avdeviceres.o] Error 1
If anyone knows what's going on and knows how to fix it, I'd really appreciate it.

About the static FFmpeg build; thanks to Stephen Douglas the x265 library is now multi-bit-depth:
Code:
ffmpeg.exe -hide_banner -h encoder=libx265
Encoder libx265 [libx265 H.265 / HEVC]:
    General capabilities: delay threads
    Threading capabilities: other
    Supported pixel formats: yuv420p yuvj420p yuv422p yuvj422p yuv444p yuvj444p gbrp
                             yuv420p10le yuv422p10le yuv444p10le gbrp10le yuv420p12le
                             yuv422p12le yuv444p12le gbrp12le gray gray10le gray12le
[...]
__________________
My hobby website
Reino is offline   Reply With Quote
Old 1st May 2021, 03:51   #24  |  Link
patul
Registered User
 
Join Date: Sep 2005
Posts: 130
Quote:
WINDRES libavdevice/avdeviceres.o
/bin/sh: /cygdrive/[...]/cross_compilers/mingw-w64-i686/bin/i686-w64-mingw32-gcc -E -xc-header
-DRC_INVOKED -MMD -MF libavdevice/avdeviceres.d -MT libavdevice/avdeviceres.o: No such file or directory
/cygdrive/m/[...]/cross_compilers/mingw-w64-i686/bin/i686-w64-mingw32-windres: preprocessing failed.
make: *** [ffbuild/common.mak:93: libavdevice/avdeviceres.o] Error 1
Perhaps windres.exe (part of binutils) was the problem, maybe you can try to use previous working version?
patul is offline   Reply With Quote
Old 1st May 2021, 05:46   #25  |  Link
manolito
Registered User
 
manolito's Avatar
 
Join Date: Sep 2003
Location: Berlin, Germany
Posts: 3,094
Quote:
Originally Posted by Reino View Post
I've just uploaded new binaries. That is, only a static build for FFmpeg so far.
Thanks...
Works here without any issues.
manolito is offline   Reply With Quote
Old 1st May 2021, 10:46   #26  |  Link
FranceBB
Broadcast Encoder
 
FranceBB's Avatar
 
Join Date: Nov 2013
Location: Royal Borough of Kensington & Chelsea, UK
Posts: 2,957
Thanks for the new build, hugely appreciated!
FranceBB is offline   Reply With Quote
Old 2nd May 2021, 15:18   #27  |  Link
Reino
Registered User
 
Reino's Avatar
 
Join Date: Nov 2005
Posts: 700
Quote:
Originally Posted by patul View Post
Perhaps windres.exe (part of binutils) was the problem, maybe you can try to use previous working version?
Too late I noticed "windres error with binutils 2.36.1" and the suggested fix, because I had already started a complete re-run with binutils 2.35.2.
Anyway, going back to 2.35.x proved successful. Thanks.

I've just uploaded new ffmpeg binaries and removed the "old" static one.
__________________
My hobby website
Reino is offline   Reply With Quote
Old 2nd May 2021, 16:00   #28  |  Link
FranceBB
Broadcast Encoder
 
FranceBB's Avatar
 
Join Date: Nov 2013
Location: Royal Borough of Kensington & Chelsea, UK
Posts: 2,957
Thanks!
Any plan for a new build of ffms2 as well?
(I'm not in a hurry, just saying. And by the way, thank you so much for keeping the project updated and XP compatible).
FranceBB is offline   Reply With Quote
Old 2nd May 2021, 16:54   #29  |  Link
Reino
Registered User
 
Reino's Avatar
 
Join Date: Nov 2005
Posts: 700
Seeing there are no new commits since my last build, I wasn't about to.
__________________
My hobby website
Reino is offline   Reply With Quote
Old 3rd May 2021, 13:12   #30  |  Link
FranceBB
Broadcast Encoder
 
FranceBB's Avatar
 
Join Date: Nov 2013
Location: Royal Borough of Kensington & Chelsea, UK
Posts: 2,957
Ah, right, so nothing changed, I see...
Well, that's fine then.
FranceBB is offline   Reply With Quote
Old 20th May 2021, 17:09   #31  |  Link
manolito
Registered User
 
manolito's Avatar
 
Join Date: Sep 2003
Location: Berlin, Germany
Posts: 3,094
@Reino

could you have a look at this post:
https://forum.doom9.org/showthread.p...04#post1943204
manolito is offline   Reply With Quote
Old 26th June 2021, 15:38   #32  |  Link
GMJCZP
Registered User
 
GMJCZP's Avatar
 
Join Date: Apr 2010
Location: I have a statue in Hakodate, Japan
Posts: 752
I'm testing version 4.5 static and it doesn't have the -preme argument (Estimation of previous movement) than if you have another videohelp build, the 4.2 static. Did they remove -preme?
__________________
By law and justice!

GMJCZP's Arsenal
GMJCZP is offline   Reply With Quote
Old 27th June 2021, 10:29   #33  |  Link
Reino
Registered User
 
Reino's Avatar
 
Join Date: Nov 2005
Posts: 700
I have no idea what you're talking about. Are you sure you posted in the right topic?
__________________
My hobby website
Reino is offline   Reply With Quote
Old 27th June 2021, 14:43   #34  |  Link
GMJCZP
Registered User
 
GMJCZP's Avatar
 
Join Date: Apr 2010
Location: I have a statue in Hakodate, Japan
Posts: 752
In my signature I have a script based on FFMpeg to encode files to DVD. I downloaded the latest version and noticed that the -preme argument does not recognize it, my doubt is that the folks at FFMpeg removed -preme from their compilations.

Reino, or could it be that when compiling you skipped -preme?
__________________
By law and justice!

GMJCZP's Arsenal

Last edited by GMJCZP; 27th June 2021 at 14:46.
GMJCZP is offline   Reply With Quote
Old 27th June 2021, 15:10   #35  |  Link
lvqcl
Registered User
 
Join Date: Aug 2015
Posts: 303
https://git.ffmpeg.org/gitweb/ffmpeg...e2c4287#patch3

avcodec: Remove private options from AVCodecContext

Code:
-#if FF_API_PRIVATE_OPT
-    /** @deprecated use encoder private options instead */
-    attribute_deprecated
-    int pre_me;
-#endif
lvqcl is online now   Reply With Quote
Old 27th June 2021, 15:19   #36  |  Link
GMJCZP
Registered User
 
GMJCZP's Avatar
 
Join Date: Apr 2010
Location: I have a statue in Hakodate, Japan
Posts: 752
Quote:
Originally Posted by lvqcl View Post
https://git.ffmpeg.org/gitweb/ffmpeg...e2c4287#patch3

avcodec: Remove private options from AVCodecContext

Code:
-#if FF_API_PRIVATE_OPT
-    /** @deprecated use encoder private options instead */
-    attribute_deprecated
-    int pre_me;
-#endif
Thanks, but I downloaded a version shared from Here and is present -preme.
__________________
By law and justice!

GMJCZP's Arsenal
GMJCZP is offline   Reply With Quote
Old 27th June 2021, 16:13   #37  |  Link
Reino
Registered User
 
Reino's Avatar
 
Join Date: Nov 2005
Posts: 700
Apart from a couple of patches to make ffmpeg WinXP compatible again, I haven't removed functionality. At least, not that I know of.
__________________
My hobby website
Reino is offline   Reply With Quote
Old 27th June 2021, 19:52   #38  |  Link
GMJCZP
Registered User
 
GMJCZP's Avatar
 
Join Date: Apr 2010
Location: I have a statue in Hakodate, Japan
Posts: 752
Don't worry Reino, I suspect that preme was removed due to optimizations in the same encoding. I did a quick test and did not notice practically any major difference, so an increase in speed has apparently been gained, I say apparently because this increase may also be due to general optimizations.
__________________
By law and justice!

GMJCZP's Arsenal
GMJCZP is offline   Reply With Quote
Old 29th June 2021, 09:56   #39  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 10,361
The option is still available in newer FFmpeg, it just changed its name - the global option was removed, and the codec-specific one for mpeg remains. So for this particular option, try "-mepre" instead
__________________
LAV Filters - open source ffmpeg based media splitter and decoders
nevcairiel is offline   Reply With Quote
Old 29th June 2021, 14:26   #40  |  Link
GMJCZP
Registered User
 
GMJCZP's Avatar
 
Join Date: Apr 2010
Location: I have a statue in Hakodate, Japan
Posts: 752
Quote:
Originally Posted by nevcairiel View Post
The option is still available in newer FFmpeg, it just changed its name - the global option was removed, and the codec-specific one for mpeg remains. So for this particular option, try "-mepre" instead
Thanks for the clarification, I have confirmed the information.
__________________
By law and justice!

GMJCZP's Arsenal
GMJCZP is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 13:12.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.