Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > VapourSynth

Reply
 
Thread Tools Search this Thread Display Modes
Old 4th September 2018, 04:24   #1  |  Link
Cary Knoop
Cary Knoop
 
Cary Knoop's Avatar
 
Join Date: Feb 2017
Location: Newark CA, USA
Posts: 156
Using Vapoursynth Editor with ffmpeg

Is it possible to use the Vapoursynth Editor with ffmpeg instead of x264 or x265 during encoding?
Cary Knoop is offline   Reply With Quote
Old 4th September 2018, 04:35   #2  |  Link
poisondeathray
Registered User
 
Join Date: Sep 2007
Posts: 3,813
Quote:
Originally Posted by Cary Knoop View Post
Is it possible to use the Vapoursynth Editor with ffmpeg instead of x264 or x265 during encoding?
Yes ;

You just change the executable path to your ffmpeg.exe in the encode dialog box settings , and enter your ffmpeg commandline (without calling ffmpeg) . Y4M header setting is easier because it passes all the script info parameters to ffmpeg , but not all pixel formats are supported by Y4M
poisondeathray is offline   Reply With Quote
Old 4th September 2018, 04:49   #3  |  Link
Cary Knoop
Cary Knoop
 
Cary Knoop's Avatar
 
Join Date: Feb 2017
Location: Newark CA, USA
Posts: 156
I seem to have trouble getting it work, I tried this:

-y
-i -
-c:v prores
-profile:v 3
"{sd}/test.mov"


Or added
-f yuv4mpegpipe

with and without Y4M

Could you make a small example command?


The bit-depth of the video stream is 10
Cary Knoop is offline   Reply With Quote
Old 4th September 2018, 05:03   #4  |  Link
poisondeathray
Registered User
 
Join Date: Sep 2007
Posts: 3,813
Was there an error message ?

Yes that works for me on Windows ; I tested with a YUV422P10 source.

But I used one line (with Y4M header setting) . It might have something to do with line breaks or escapes for you

Code:
-i - -c:v prores -profile:v 3 -an "PATH\test.mov"
poisondeathray is offline   Reply With Quote
Old 4th September 2018, 05:50   #5  |  Link
Cary Knoop
Cary Knoop
 
Cary Knoop's Avatar
 
Join Date: Feb 2017
Location: Newark CA, USA
Posts: 156
Oops, I found the problem, my FFmpeg path was incorrect.


Sorry and thanks for helping out!
Cary Knoop is offline   Reply With Quote
Old 5th September 2018, 18:14   #6  |  Link
Mystery Keeper
Beyond Kawaii
 
Mystery Keeper's Avatar
 
Join Date: Feb 2008
Location: Russia
Posts: 707
Code:
-y
-nostats
-i -
-c:v ffv1
"{sd}/{sn}.ffv1.mkv"
This is my FFV1 encoding preset for ffmpeg.
Used with Y4M header.
Note -nostats. It's important to keep encoding run smoothly!
__________________
...desu!
Mystery Keeper is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 03:13.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.