Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 AVC / H.264

Reply
 
Thread Tools Search this Thread Display Modes
Old 13th November 2009, 23:06   #21  |  Link
Dark Shikari
x264 developer
 
Dark Shikari's Avatar
 
Join Date: Sep 2005
Posts: 8,667
Quote:
Originally Posted by CpT View Post
Testing that now.

Edit: just tested, same results with --nf + weighted p
Upload it somewhere...
Dark Shikari is offline   Reply With Quote
Old 13th November 2009, 23:19   #22  |  Link
CpT
Registered User
 
Join Date: Aug 2009
Posts: 135
Here's a test page
http://vizmu.com/player/flash/test.html

Direct link,
http://vizmu.com/player/2012-yellostone.mp4
CpT is offline   Reply With Quote
Old 13th November 2009, 23:34   #23  |  Link
Chengbin
Registered User
 
Join Date: Oct 2007
Posts: 1,060
Quote:
Originally Posted by Dark Shikari View Post
What the heck are you on about?

We've tested dozens of software and hardware decoders. There are a grand total of two that fail: CoreAVC and the Apple TV. Basically everything else works.
Make that 5.

All Archos PMPs do not handle weightp properly.
Chengbin is offline   Reply With Quote
Old 13th November 2009, 23:37   #24  |  Link
Dark Shikari
x264 developer
 
Dark Shikari's Avatar
 
Join Date: Sep 2005
Posts: 8,667
Quote:
Originally Posted by Chengbin View Post
Make that 5.

All Archos PMPs do not handle weightp properly.
Are they broken with weightp, or with dupes? In other words, do they work with --weightp 2 --ref 1?
Dark Shikari is offline   Reply With Quote
Old 13th November 2009, 23:45   #25  |  Link
Dark Shikari
x264 developer
 
Dark Shikari's Avatar
 
Join Date: Sep 2005
Posts: 8,667
Quote:
Originally Posted by CpT View Post
More things to test:

--weightp 2 --nf --direct temporal
--weightp 2 --nf --direct none
--weightp 2 --nf --bframes 0
--weightp 2 --direct temporal
--weightp 2 --direct none
--weightp 2 --bframes 0

Which ones of those work?

I have a hunch that Flash's direct calculation is broken.
Dark Shikari is offline   Reply With Quote
Old 13th November 2009, 23:55   #26  |  Link
CpT
Registered User
 
Join Date: Aug 2009
Posts: 135
Just tried --weightp 2 --ref 1 and it works

see below, scrub to 50 seconds
http://vizmu.com/player/flash/test.html

direct download -sorry for speed cap.
http://vizmu.com/player/2012-yellostone2.mp4

Last edited by CpT; 13th November 2009 at 23:58.
CpT is offline   Reply With Quote
Old 13th November 2009, 23:56   #27  |  Link
Chengbin
Registered User
 
Join Date: Oct 2007
Posts: 1,060
Quote:
Originally Posted by Dark Shikari View Post
Are they broken with weightp, or with dupes? In other words, do they work with --weightp 2 --ref 1?
Anything other than ref 1 will not work.
Chengbin is offline   Reply With Quote
Old 14th November 2009, 00:02   #28  |  Link
Dark Shikari
x264 developer
 
Dark Shikari's Avatar
 
Join Date: Sep 2005
Posts: 8,667
Quote:
Originally Posted by Chengbin View Post
Anything other than ref 1 will not work.
Which means it's broken with dupes, not with weightp.
Dark Shikari is offline   Reply With Quote
Old 14th November 2009, 00:05   #29  |  Link
Chengbin
Registered User
 
Join Date: Oct 2007
Posts: 1,060
Quote:
Originally Posted by Dark Shikari View Post
Which means it's broken with dupes, not with weightp.
I thought 64bit wasn't broken.

Also, they play fine with ffmpeg-mt.

Is it still duped?
Chengbin is offline   Reply With Quote
Old 14th November 2009, 00:27   #30  |  Link
CpT
Registered User
 
Join Date: Aug 2009
Posts: 135
LOL,

I enabled mbtree and it works with 3 ref's + mixed ref's and weighted p @ 2.

So weighted p requires mbtree for flash usage?
CpT is offline   Reply With Quote
Old 14th November 2009, 00:31   #31  |  Link
Dark Shikari
x264 developer
 
Dark Shikari's Avatar
 
Join Date: Sep 2005
Posts: 8,667
Quote:
Originally Posted by CpT View Post
LOL,

I enabled mbtree and it works with 3 ref's + mixed ref's and weighted p @ 2.

So weighted p requires mbtree for flash usage?
I find that extraordinarily dubious... MB-tree doesn't change anything with regards to the features used on a bitstream level.
Dark Shikari is offline   Reply With Quote
Old 14th November 2009, 00:59   #32  |  Link
unschuldsengel
Registered User
 
Join Date: May 2009
Posts: 3
Quote:
Originally Posted by CpT View Post
I enabled mbtree and it works with 3 ref's + mixed ref's and weighted p @ 2.
I have mbtree always on and with weightedp=2 the problem occurs. also with 3 refs.
unschuldsengel is offline   Reply With Quote
Old 14th November 2009, 01:05   #33  |  Link
CpT
Registered User
 
Join Date: Aug 2009
Posts: 135
Quote:
Originally Posted by unschuldsengel View Post
I have mbtree always on and with weightedp=2 the problem occurs. also with 3 refs.
Are you talking about in flash or elseware.

I'm also running a longer test atm to see if I can reproduce it.

Edit: if I am able to reproduce it. mbtree on = no issue,
But mbtree off + same exact settings the issue occurs.

I'm done testing for for now.

Last edited by CpT; 14th November 2009 at 01:24.
CpT is offline   Reply With Quote
Old 14th November 2009, 01:12   #34  |  Link
unschuldsengel
Registered User
 
Join Date: May 2009
Posts: 3
Quote:
Originally Posted by CpT View Post
Are you talking about in flash or elseware
Just Flash, the videos worke fine in VLC etc.
unschuldsengel is offline   Reply With Quote
Old 14th November 2009, 01:43   #35  |  Link
prOnorama
Registered User
 
Join Date: Mar 2005
Posts: 249
Quote:
Originally Posted by CpT View Post
lol, Where do u live? We only allow viewing from a few countries.
403 Forbidden here also (Netherlands)

Maybe not use your site (wtf vizmu? lol it sounds like a rodent) but a site that's internationally accessible. Really Germany and The Netherlands aren't the bush-bush geographically or interwebz-wise also *cough* x264.nl should give a hint
prOnorama is offline   Reply With Quote
Old 14th November 2009, 02:05   #36  |  Link
CpT
Registered User
 
Join Date: Aug 2009
Posts: 135
Quote:
Originally Posted by prOnorama View Post
403 Forbidden here also (Netherlands)
(wtf vizmu? lol it sounds like a rodent)
This coming from a guy named prOnoram.

You should have access now btw, So should you Lord Mulder.
CpT is offline   Reply With Quote
Old 14th November 2009, 02:11   #37  |  Link
CruNcher
Registered User
 
CruNcher's Avatar
 
Join Date: Apr 2002
Location: Germany
Posts: 4,929
The Same black blocks on TIs Decoder (Archos 5IT Omap 3440) @ the 5th second like in Chengbins sample
__________________
all my compares are riddles so please try to decipher them yourselves :)

It is about Time

Join the Revolution NOW before it is to Late !

http://forum.doom9.org/showthread.php?t=168004
CruNcher is offline   Reply With Quote
Old 14th November 2009, 02:21   #38  |  Link
LoRd_MuldeR
Software Developer
 
LoRd_MuldeR's Avatar
 
Join Date: Jun 2005
Location: Last House on Slunk Street
Posts: 13,235
Quote:
Originally Posted by CpT View Post
It can be seen here http://vizmu.com/movie-trailers/724/129861/
Scrub to 50 seconds, it's shortly after that.
Quote:
Originally Posted by CpT View Post
You should have access now btw, So should you Lord Mulder.
Yes, it works now. Thanks. But I'm unable to spot the distortions around 0:50 in that sample
__________________
Go to https://standforukraine.com/ to find legitimate Ukrainian Charities 🇺🇦✊

Last edited by LoRd_MuldeR; 14th November 2009 at 02:26.
LoRd_MuldeR is offline   Reply With Quote
Old 14th November 2009, 02:26   #39  |  Link
CpT
Registered User
 
Join Date: Aug 2009
Posts: 135
Quote:
Originally Posted by LoRd_MuldeR View Post
Yes, it works now. Thanks. But I'm unable to spot the distortions around 0:50
I uploaded a working version to the actual site. Then updated the links in my first post about it.

It can be seen here http://vizmu.com/player/flash/test2.html
Scrub to 50 seconds, it's shortly after that @ 56-59

working version - scrub to 50 seconds.
http://vizmu.com/movie-trailers/724/129861/
CpT is offline   Reply With Quote
Old 14th November 2009, 02:28   #40  |  Link
LoRd_MuldeR
Software Developer
 
LoRd_MuldeR's Avatar
 
Join Date: Jun 2005
Location: Last House on Slunk Street
Posts: 13,235
Quote:
Originally Posted by CpT View Post
I uploaded a working version to the actual site. Then updated the links in my first post about it.

It can be seen here http://vizmu.com/player/flash/test2.html
Scrub to 50 seconds, it's shortly after that @ 56-59
Oh, yes. Now I can reproduce the distortions in the "explosion" scene
__________________
Go to https://standforukraine.com/ to find legitimate Ukrainian Charities 🇺🇦✊
LoRd_MuldeR is offline   Reply With Quote
Reply

Tags
artifacts, coreavc, corruption, weightp

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 16:16.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.