Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > Avisynth Usage

Reply
 
Thread Tools Search this Thread Display Modes
Old 30th May 2022, 06:01   #341  |  Link
VoodooFX
Banana User
 
VoodooFX's Avatar
 
Join Date: Sep 2008
Posts: 602
Code:
# Version 2.15 : 2022/05/29.  Spaces are allowed in "Loc".
The feature request:
Quote:
It would be nice if you could specify loc as "60, 500, -60, -40" for example.
VoodooFX is offline   Reply With Quote
Old 12th June 2022, 16:35   #342  |  Link
VoodooFX
Banana User
 
VoodooFX's Avatar
 
Join Date: Sep 2008
Posts: 602
Code:
# Version 2.16 : 2022/06/12.  Higher quality and faster "DynColor" mask when used with "DynLocUp".
#                             Faster "DynColor" alternative if parameter is string, and it supports multiple colors.
#                             TColorMask plugin is required.
VoodooFX is offline   Reply With Quote
Old 13th June 2022, 17:29   #343  |  Link
VoodooFX
Banana User
 
VoodooFX's Avatar
 
Join Date: Sep 2008
Posts: 602
Code:
# Version 2.17 : 2022/06/13.  Option for ranged luma mask with DynMask6.
Helps when "logo" is not so bright:



Activated by string: DynTune="140 - 200"
VoodooFX is offline   Reply With Quote
Old 20th July 2022, 20:24   #344  |  Link
Eserissen
Registered User
 
Eserissen's Avatar
 
Join Date: Jul 2022
Posts: 1
I don't understand those who remove the logo from images and videos.
Eserissen is offline   Reply With Quote
Old 21st July 2022, 08:15   #345  |  Link
Espinosa
Registered User
 
Join Date: Apr 2021
Posts: 23
I need help to remove the semi-transparent logo in the upper right corner of this video (neglect those black bars, they will be removed anyway). I used InpaintDelogo before to remove letters from logos in "Inpaint" mode and it usually gave good results, but this time I couldn't do anything in "Deblend" mode.

https://www.mediafire.com/file/kzzer...ample.mkv/file

Last edited by Espinosa; 21st July 2022 at 08:34.
Espinosa is offline   Reply With Quote
Old 21st July 2022, 15:53   #346  |  Link
VoodooFX
Banana User
 
VoodooFX's Avatar
 
Join Date: Sep 2008
Posts: 602
Quote:
Originally Posted by Espinosa View Post
I need help to remove the semi-transparent logo in the upper right corner of this video (neglect those black bars, they will be removed anyway). I used InpaintDelogo before to remove letters from logos in "Inpaint" mode and it usually gave good results, but this time I couldn't do anything in "Deblend" mode.

https://www.mediafire.com/file/kzzer...ample.mkv/file
First, deinterlace and crop video, encode it to lossless:

Code:
QTGMC(Preset="Medium", Sharpness=0.2)
Crop(264,6,-258,-2)
Then run InpaintDelogo on that lossless file:

Code:
InpaintDelogo( mask="D:\mask.bmp", Loc="1170,44,-0,-950", Mode="Both", Analyze=3, dPP=4, oTune=-5)
Spline36Resize(752,576)
Probably on this video "Analyze=3" is most suitable. Basemask can be easily done with Photoshop.
Actual footage is upscaled so we downscale it back to "sd" res.
"Both" because those black letters are not transparent.

With logo:


Logo gone:


PS:
Something is wrong with FPS, got 100fps and twice shorter clip, maybe it's issue with sample...

Last edited by VoodooFX; 21st July 2022 at 16:14.
VoodooFX is offline   Reply With Quote
Old 21st July 2022, 21:35   #347  |  Link
Espinosa
Registered User
 
Join Date: Apr 2021
Posts: 23
Of course I tried this but got this error:



My mask has a black background with a white rectangle at Loc position. I'm going to update the core files and plugins and then run the script again.
Espinosa is offline   Reply With Quote
Old 21st July 2022, 21:56   #348  |  Link
VoodooFX
Banana User
 
VoodooFX's Avatar
 
Join Date: Sep 2008
Posts: 602
Update InpaintDelogo.
VoodooFX is offline   Reply With Quote
Old 21st July 2022, 22:25   #349  |  Link
Espinosa
Registered User
 
Join Date: Apr 2021
Posts: 23
Now this:

Espinosa is offline   Reply With Quote
Old 21st July 2022, 22:52   #350  |  Link
VoodooFX
Banana User
 
VoodooFX's Avatar
 
Join Date: Sep 2008
Posts: 602
"AviSynth+ v3.7.1 or later", check Avisynth version with Version().
VoodooFX is offline   Reply With Quote
Old 21st July 2022, 23:27   #351  |  Link
Espinosa
Registered User
 
Join Date: Apr 2021
Posts: 23
Espinosa is offline   Reply With Quote
Old 22nd July 2022, 00:05   #352  |  Link
VoodooFX
Banana User
 
VoodooFX's Avatar
 
Join Date: Sep 2008
Posts: 602
That's strange, upload your InpaintDelogo.avsi to mega and share output of AVSMeter -avsinfo.

Last edited by VoodooFX; 22nd July 2022 at 00:26.
VoodooFX is offline   Reply With Quote
Old 22nd July 2022, 08:54   #353  |  Link
Espinosa
Registered User
 
Join Date: Apr 2021
Posts: 23
https://mega.nz/file/CqhlTIoA#3vwgLF...anHOOfwXUP-mUo

https://mega.nz/file/ymR10JjR#pmJWpn...RpObs1myMULcxA
Espinosa is offline   Reply With Quote
Old 22nd July 2022, 11:13   #354  |  Link
Espinosa
Registered User
 
Join Date: Apr 2021
Posts: 23
Quote:
Originally Posted by VoodooFX View Post
That's strange, upload your InpaintDelogo.avsi to mega and share output of AVSMeter -avsinfo.
Can you upload your mask.bmp file? I get this now:



This is the mask I used:

Espinosa is offline   Reply With Quote
Old 22nd July 2022, 11:26   #355  |  Link
Espinosa
Registered User
 
Join Date: Apr 2021
Posts: 23
It's fine, I forgot that ~10px mask rule. I have other issues with updating Avisynth plugins but that has nothing to do with InpaintDelogo.



Thank you!
Espinosa is offline   Reply With Quote
Old 22nd July 2022, 12:34   #356  |  Link
VoodooFX
Banana User
 
VoodooFX's Avatar
 
Join Date: Sep 2008
Posts: 602
So what was culprit of that "unexpected character" error?
"Mask is full" is because you painted whole Loc area white, only logo should be white.

Upload your bmp & ebmp masks to mega, I'll check if everything is OK.
VoodooFX is offline   Reply With Quote
Old 22nd July 2022, 15:30   #357  |  Link
Espinosa
Registered User
 
Join Date: Apr 2021
Posts: 23
I got lost in all these difficulties with updating but I think it's Avisynth.dll. I use MeGUI and AvsPmod, and since MeGUI uses its own core libraries the same script now runs in AvsPmod but throws the same error in MeGUI. Function objects as a new variable type is something that should be defined in the core part so I suppose it's the problem with the core libraries.

I didn't use a ebmp mask at all but judging by some examples here, I guess it should contain only the logo in order to know what to remove by inpainting and what by deblending or something like that. I'm just not sure whether it should be black & white or not. Can you explain this and also how to name it?

Last edited by Espinosa; 22nd July 2022 at 15:42.
Espinosa is offline   Reply With Quote
Old 22nd July 2022, 16:40   #358  |  Link
VoodooFX
Banana User
 
VoodooFX's Avatar
 
Join Date: Sep 2008
Posts: 602
Quote:
Originally Posted by Espinosa View Post
...but throws the same error in MeGUI.
In MeGUI set to use external Avisynth: MeGUI > Options > uncheck "Always use the included Avisynth" > Save > restart MeGUI

Quote:
Originally Posted by Espinosa View Post
I didn't use a ebmp mask at all... Can you explain this and also how to name it?
ebmp masks are created and used automatically by InpaintDelogo, they are at same place where is your "bmp" basemask, and it's filename starts same as "bmp" mask's name.

Last edited by VoodooFX; 22nd July 2022 at 17:09.
VoodooFX is offline   Reply With Quote
Old 22nd July 2022, 17:23   #359  |  Link
Espinosa
Registered User
 
Join Date: Apr 2021
Posts: 23
Quote:
Originally Posted by VoodooFX View Post
In MeGUI set to use external Avisynth: MeGUI > Options > uncheck "Always use the included Avisynth" > Save > restart MeGUI
Thank you.

Quote:
Originally Posted by VoodooFX View Post
ebmp masks are created and used automatically by InpaintDelogo, they are at same place where is your "bmp" basemask, and it's filename starts same as "bmp" mask's name.
I modified Crop parameters a little bit:

Code:
crop(266, 4, -262, -2)
These are the files:

https://mega.nz/file/rngEXJbZ#h4h0wN...Oe5gK4Vu0PZqKA

https://mega.nz/file/OjYkQTpI#PwmK4y...OxIPsvKiBcnCCk
Espinosa is offline   Reply With Quote
Old 22nd July 2022, 20:11   #360  |  Link
VoodooFX
Banana User
 
VoodooFX's Avatar
 
Join Date: Sep 2008
Posts: 602
Quote:
Originally Posted by Espinosa View Post
These are the files:
Not bad masks, but not so good.

Try these custom masks: https://we.tl/t-yMUvpwMNk1

Code:
InpaintDelogo( mask="D:\mask4.bmp", Loc="1170,44,-0,-950", Mode="Both", Analyze=3, dPP=4, oTune=-5, oTinflate=1, Alphatweak=-3)
Your masks:


My custom masks:

Last edited by VoodooFX; 22nd July 2022 at 21:16.
VoodooFX is offline   Reply With Quote
Reply

Tags
delogo, hardsubs, ocr, remove, watermark

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 09:45.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.