Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > Avisynth Usage

Reply
 
Thread Tools Search this Thread Display Modes
Old 24th November 2017, 14:09   #1  |  Link
pcroland
Registered User
 
Join Date: Mar 2014
Location: Hungary
Posts: 106
Removing DeHalo_Alpha artifacts

Hi!

I'm trying to restore an old DVD which has a lot of grain, dct artifacts and a really strong halo. This is my current avs script:

Code:
DirectShowSource("D:\raccoons\DVD1\VIDEO_TS\VTS_01_1.VOB")
QTGMC(Preset="Slow")
SelectOdd()
Crop(14,2,-16,-0)
FillMargins(0,0,0,1)
bbmod(0,2,8,8)
knlmeanscl(D=8, A=5, h=3, device_type="GPU")
DeHalo_Alpha(rx=3.0, ry=3.0, darkstr=0.4, brightstr=1, lowsens=50, highsens=50, ss=1.5)
GradFun3(thr=1.5, radius=6, mask=2, mode=0, smode=0, debug=0, lsb=False, lsb_in=False, staticnoise=False, y=3, u=3, v=3)
I'm satisfied with the grain removal (but you can recommend something better instead of knlmeanscl), the GradFun3() is maybe a little bit too strong and needs some tweaking. But the dehalo is just not that great so far. The strong white halo is now replaced with a slighty darker color than it should be. brightstr is 1 as you can see in the code, 0.8 is the recommended value for anime and cartoon but it seems that it does not do anything if I try something lower than 1. Could you guys recommend something to fix this? Or maybe another dehalo filter? I tried HaloBuster() but I couldn't get it to work.

Here's the comparison: https://testfra.me/0s/
pcroland is offline   Reply With Quote
Old 27th November 2017, 15:18   #2  |  Link
SaurusX
Registered User
 
Join Date: Feb 2017
Posts: 113
Your KNLMeansCL h strength is set way too high, not to mention your D's and A's are way higher than what this animation really needs. You're killing detail.

And DeHalo_Alpha does work with settings lower than 1, so I'm not sure where you get that it doesn't. I'd recommend turning off the darkstr entirely (darkstr=0) since that will diminish the true cel animation outlines. The rx and ry values also seem greater than what they need to be. Do something like this:

dehalo_alpha(darkstr=0, brightstr=.1,ss=2)
dehalo_alpha(darkstr=0, brightstr=.3,ss=2)
dehalo_alpha(darkstr=0, brightstr=.5,ss=2)
dehalohmod(smooth=true) #cleans remaining edge noise and dark halos

And then see where you end up. You'll have to adjust the brightstr values to suit your source, but follow the increasing strength scheme.
SaurusX is online now   Reply With Quote
Reply

Tags
dehalo, dering, halo, ringing halo

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 17:49.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.