Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > VirtualDub, VDubMod & AviDemux

Reply
 
Thread Tools Search this Thread Display Modes
Old 28th February 2021, 13:09   #1  |  Link
jaa101
Registered User
 
Join Date: Feb 2021
Posts: 1
VirtualDub2 won't create interlaced output

I have VirtualDub2 64-bit (build 44282). I can open an interlaced MKV (mediainfo says: Scan type : MBAFF; Scan type, store method : Interleaved fields; Scan order : Top Field First) and then export video from it with no filters, using x265. The result is a progressive file with combing everywhere. My source is 720x576i25.

VLC plays the original correctly, automatically applying deinterlacing as appropriate, but it shows horrible combing when playing the VirtualDub output since it thinks it's progressive.

How can I get VirtualDub to generate interlaced output? I can find no settings on the output settings of VirtualDub or on its x265 (or any other) codec settings. I've even tried adding the deinterlace filter (duplicate fields, double frame rate) followed by the interlace filter (progressive frames, even field first) but still the output is definitely in progressive format, with combing in the frames. The VirtualDub file information window and the "image format" information available in its filter window say nothing about progressive or interlaced.

What am I missing? Surely VirtualDub can export interlaced video. Or am I stuck exporting the fields at double the frame rate and using some other tool to re-assemble them as interlaced video?

Thanks.

Edit: I've found one answer: select the x264 codec, click configure, and add the following in the "Extra command line (for advanced users)" box:

--tff

meaning top-field first. (I guess "--bff" would work too if you need this.) You get the warning "[!] x264 [warning]: interlace + weightp is not implemented" but it seems harmless.

So the question now is, why doesn't the x265 configuration box offer an "Extra command line" box?

Last edited by jaa101; 4th March 2021 at 07:06. Reason: Found part-solution
jaa101 is offline   Reply With Quote
Old 5th March 2021, 23:21   #2  |  Link
Asmodian
Registered User
 
Join Date: Feb 2002
Location: San Jose, California
Posts: 4,177
You do not want to use x265 for interlaced. H.265 does not support interlaced video very well.

Proper interlaced encoding with x265
__________________
madVR options explained
Asmodian is offline   Reply With Quote
Reply

Tags
interlaced, virtualdub, virtualdub2

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 21:24.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.