Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 Encoder GUIs

Reply
 
Thread Tools Search this Thread Display Modes
Old 29th January 2010, 16:02   #361  |  Link
Fidelix
Registered User
 
Join Date: Mar 2009
Posts: 21
Wow

Man, this is the BEST PROJECT i have ever seen here or anywhere else, that is related to encoding GUI's.

Please, for the world's sake, keep going with your project, there aint decent UI's like Realanime/Bencos out there!
Fidelix is offline   Reply With Quote
Old 29th January 2010, 16:06   #362  |  Link
Sirber
retired developer
 
Sirber's Avatar
 
Join Date: Oct 2002
Location: Canada
Posts: 8,978
Thank you!
__________________
Detritus Software
Sirber is offline   Reply With Quote
Old 30th January 2010, 13:54   #363  |  Link
Fidelix
Registered User
 
Join Date: Mar 2009
Posts: 21
Hey Sirber, i'm getting the same error with all files being encoded by bencos.
I'm sorry if its the wrong way of reporting this, i didnt know where else to post. Anyway, if this doesnt help i'll delete my message.

This is my bencos config/status screen.


This is Benco's log:
Code:
C:\Program Files (x86)\Bencos\enhAacPlusEnc.exe "C:\Users\Fidelix\AppData\Local\Temp/bencos/audio.wav" "C:\Users\Fidelix\AppData\Local\Temp/bencos/audio.mp4" --cbr 48000 --disable-ps 


*************************************************************
* Enhanced aacPlus 3GPP Floating Point Reference Encoder
*
* Source timestamp Wed Jan  3 10:01:12 2007
* Build Jan  3 2007, 10:01:18
*************************************************************

input file C:\Users\Fidelix\AppData\Local\Temp/bencos/audio.wav: 
sr = 48000, nc = 2

output file C:\Users\Fidelix\AppData\Local\Temp/bencos/audio.mp4: 
br = 48000 sr-OUT = 48000  nc-OUT = 2


Writing of 3GPP file failed.
This is the source file info:
Code:
K:\Downz\[Kuroi Raws] Spice and Wolf II OVA (DVD 1280x720 H264 AAC 2ch) [A53B4F8E].mkv
   General
      Complete name : K:\Downz\[Kuroi Raws] Spice and Wolf II OVA (DVD 1280x720 H264 AAC 2ch) [A53B4F8E].mkv
      Format : Matroska
      File size : 295 MiB
      Duration : 22mn 20s
      Overall bit rate : 1 845 Kbps
      Encoded date : UTC 2009-07-16 06:05:37
      Writing application : mkvmerge v2.1.0 ('Another Place To Fall') built on Aug 19 2007 13:40:07
      Writing library : libebml v0.7.7 + libmatroska v0.8.1
   Video #1
      ID : 1
      Format : AVC
      Format/Info : Advanced Video Codec
      Format profile : High@L4.1
      Format settings, CABAC : Yes
      Format settings, ReFrames : 10 frames
      Muxing mode : Container profile=Unknown@4.1
      Codec ID : V_MPEG4/ISO/AVC
      Duration : 22mn 19s
      Nominal bit rate : 1 600 Kbps
      Width : 1 280 pixels
      Height : 720 pixels
      Display aspect ratio : 16:9
      Frame rate : 23.976 fps
      Resolution : 24 bits
      Colorimetry : 4:2:0
      Scan type : Progressive
      Bits/(Pixel*Frame) : 0.072
      Writing library : x264 core 68 r1179M 96e2229
      Encoding settings : cabac=1 / ref=10 / deblock=1:1:1 / analyse=0x3:0x133 / me=umh / subme=9 / psy_rd=0.6:0.0 / mixed_ref=1 / me_range=24 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / chroma_qp_offset=-2 / threads=3 / nr=0 / decimate=1 / mbaff=0 / bframes=6 / b_pyramid=1 / b_adapt=2 / b_bias=0 / direct=3 / wpredb=1 / keyint=250 / keyint_min=25 / scenecut=40 / rc=2pass / bitrate=1600 / ratetol=1.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / vbv_maxrate=17500 / vbv_bufsize=14000 / ip_ratio=1.40 / pb_ratio=1.30 / aq=0
      Language : Japanese
   Audio #2
      ID : 2
      Format : AAC
      Format/Info : Advanced Audio Codec
      Format version : Version 4
      Format profile : LC
      Format settings, SBR : No
      Codec ID : A_AAC
      Duration : 22mn 20s
      Channel(s) : 2 channels
      Channel positions : L R
      Sampling rate : 48.0 KHz
      Resolution : 16 bits
      Language : Japanese
I'm using Windows 7 x64 Ultimate
Processor = Intel Q8200 Woodstock

This seems to be some adaptability problem in the aac encoder with different file formats...

Anyway, for now i'll do my things with Realanime, but i'm really eager to use bencos ^^
Fidelix is offline   Reply With Quote
Old 30th January 2010, 17:19   #364  |  Link
Sirber
retired developer
 
Sirber's Avatar
 
Join Date: Oct 2002
Location: Canada
Posts: 8,978
Quote:
Format : AAC
the current build of mplayer used in bencos has issues with MKV/AAC. You can try to upgrade mplayer:


MPlayer for Win32 by sherpya


I'd suggest de "rtm" build. Just extract into Bencos installation folder, overwriting the existing files, then retry the encoding. Please tell me if it fixes the issue. Thanks!

[edit]

I made a release (for testing): download
Updated mencoder/mplayer to revision 30369. The UI has changed a bit too to display better
on linux.
__________________
Detritus Software

Last edited by Sirber; 30th January 2010 at 18:50.
Sirber is offline   Reply With Quote
Old 30th January 2010, 21:20   #365  |  Link
Sirber
retired developer
 
Sirber's Avatar
 
Join Date: Oct 2002
Location: Canada
Posts: 8,978
nah it still fails

[edit]

Code:
mplayer.exe -ao pcm:file=out.wav -vo null test.mp4
seems to work, but is much more slower

Code:
mplayer.exe -ao pcm:file=out.wav -vo null -vc null test.mp4"
the code that bencos currently use. fails with:
"Too many audio packets in the buffer"
__________________
Detritus Software

Last edited by Sirber; 30th January 2010 at 21:30.
Sirber is offline   Reply With Quote
Old 30th January 2010, 21:56   #366  |  Link
Sirber
retired developer
 
Sirber's Avatar
 
Join Date: Oct 2002
Location: Canada
Posts: 8,978
made an update to the code named "Slow audio extraction". Only enable if the source is using AAC audio, because it's terribly slower.

download
__________________
Detritus Software
Sirber is offline   Reply With Quote
Old 30th January 2010, 22:23   #367  |  Link
Sirber
retired developer
 
Sirber's Avatar
 
Join Date: Oct 2002
Location: Canada
Posts: 8,978
@Fidelix

Your first video (1280x720.mkv) failed the "video encoding". Can you post the mencoder logs?
__________________
Detritus Software
Sirber is offline   Reply With Quote
Old 31st January 2010, 15:43   #368  |  Link
Fidelix
Registered User
 
Join Date: Mar 2009
Posts: 21
Quote:
Originally Posted by Sirber View Post
@Fidelix

Your first video (1280x720.mkv) failed the "video encoding". Can you post the mencoder logs?
The error happened because i canceled the process.
I tried it again (1280x720) and it only failed on the audio. Same thing.

Well, i realized the UI "feels" a little different from realanime, i guess thats because your programming approach regarding the interface has changed, so i cant tell if it would be difficult to add a really nice feature RealAnime had, which is Drag n' Drop.

Anyway, i'll try ur new build for aac right now.

Edit: Oops, u said before: "Haven't find a working way with FreePascal yet."
Too bad. I really dont know if this helps, and i realize not all delphi components works on lazarus, but anything is worth a try hehhe:

http://www.chami.com/tips/delphi/111196D.html
http://delphi.about.com/od/vclusing/a/dragdrop.htm
http://www.delphidabbler.com/software/dropfiles?mid=3.1
I found also this:
http://wiki.lazarus.freepascal.org/L...Drop#Drag_Drop

Last edited by Fidelix; 31st January 2010 at 16:16.
Fidelix is offline   Reply With Quote
Old 31st January 2010, 15:51   #369  |  Link
Fidelix
Registered User
 
Join Date: Mar 2009
Posts: 21
Sirber, which enhAacPlusEnc build is Bencos using?

Wouldn't it be a good idea to use Nero's aac encoder? I heard it is better, although i have no base for stating this for sure, but i believe you do.

About the aac problem: The process failed with audio encoding, i dont get how mplayer is responsible for it.

Edit: I looked at some of the early posts, and it seems that licensing is a problem for neroaac.
I've got a suggestion. What about something like this?
Code:
if FileExists(neroaacenc.exe) or FileExists(neroaacenc.so) then
somebooleanvariable = true;
Or maybe a "NeroAAC" option in Audio Codec dropdown. I dont know the complexity needed to achieve something like this, because it would certainly involve a lot of ifs and elses regarding other options like bitrate, mplayer and etc, but i'm just brainstorming ^^

Last edited by Fidelix; 31st January 2010 at 16:05.
Fidelix is offline   Reply With Quote
Old 31st January 2010, 17:21   #370  |  Link
Sirber
retired developer
 
Sirber's Avatar
 
Join Date: Oct 2002
Location: Canada
Posts: 8,978
Quote:
Originally Posted by Fidelix View Post
Well, i realized the UI "feels" a little different from realanime, i guess thats because your programming approach regarding the interface has changed, so i cant tell if it would be difficult to add a really nice feature RealAnime had, which is Drag n' Drop.
I'll have a look at it, last time I tryed (drag drop) was in 2006
Realanime 6 was a stripdown version of Bencos made in Turbo Delphi, mainly because Bencos wasn't working on Vista at that time.

Quote:
Originally Posted by Fidelix View Post
Sirber, which enhAacPlusEnc build is Bencos using?
An old one?

Quote:
Originally Posted by Fidelix View Post
Wouldn't it be a good idea to use Nero's aac encoder? I heard it is better, although i have no base for stating this for sure, but i believe you do.
It is better but I cannot bundle it due to it's licence. I will add code to detect and support it though.
__________________
Detritus Software
Sirber is offline   Reply With Quote
Old 31st January 2010, 17:23   #371  |  Link
Sirber
retired developer
 
Sirber's Avatar
 
Join Date: Oct 2002
Location: Canada
Posts: 8,978
v2010-01-30 with "slow audio extraction" enabled works with AAC source.
For a 24 minutes clip, audio extraction took 9 minutes...
__________________
Detritus Software
Sirber is offline   Reply With Quote
Old 31st January 2010, 17:24   #372  |  Link
Fidelix
Registered User
 
Join Date: Mar 2009
Posts: 21
"For a 24 minutes clip, audio extraction took 9 minutes..."

Thats due to Mplayer right? Ur using mplayer to extract audio?

What about mkvmerge cli?

Last edited by Fidelix; 31st January 2010 at 17:53.
Fidelix is offline   Reply With Quote
Old 31st January 2010, 18:02   #373  |  Link
Sirber
retired developer
 
Sirber's Avatar
 
Join Date: Oct 2002
Location: Canada
Posts: 8,978
I'm using mplayer to convert the source audio track into an uncompressed WAV file, then I launch the audio encoder on that file (faac or enhaacplus, soon nero aac too).
__________________
Detritus Software
Sirber is offline   Reply With Quote
Old 31st January 2010, 18:09   #374  |  Link
Fidelix
Registered User
 
Join Date: Mar 2009
Posts: 21
Then i guess demuxing files with aac through mp4box or mkvmerge-cli isnt an option?

I believe this would solve the problem, am i right?
Fidelix is offline   Reply With Quote
Old 31st January 2010, 22:06   #375  |  Link
Sirber
retired developer
 
Sirber's Avatar
 
Join Date: Oct 2002
Location: Canada
Posts: 8,978
I need to demux and decompress to feed the encoders
__________________
Detritus Software
Sirber is offline   Reply With Quote
Old 1st February 2010, 00:26   #376  |  Link
Fidelix
Registered User
 
Join Date: Mar 2009
Posts: 21
Well then... thanks for the answers, i guess currently "slow aac encoding" is the only option for me.

Good luck Sirber. And if there is anything i can do to help, i'll gladly do it.
good bye.
Fidelix is offline   Reply With Quote
Old 1st February 2010, 14:50   #377  |  Link
Sirber
retired developer
 
Sirber's Avatar
 
Join Date: Oct 2002
Location: Canada
Posts: 8,978
bencos is not really responsive while encoding from HD sources..

[edit]

I'm getting lots of: "Too many video packet in the buffer" and the encoding is realllly slow.

[edit]

I'll gonna try with "-nosound -noskip". I read somewhere that mencoder does that when it fails to keep the sinc with video and audio. I hope the sound keeps sync..
__________________
Detritus Software

Last edited by Sirber; 1st February 2010 at 22:53.
Sirber is offline   Reply With Quote
Old 2nd February 2010, 14:37   #378  |  Link
Sirber
retired developer
 
Sirber's Avatar
 
Join Date: Oct 2002
Location: Canada
Posts: 8,978
Quote:
Originally Posted by Sirber View Post
I'll gonna try with "-nosound -noskip". I read somewhere that mencoder does that when it fails to keep the sinc with video and audio. I hope the sound keeps sync..
No more video buffer packets errors, but audio did not encode since I look in mencoder logs to see if there's an audio track lol. I think I'll launch mplayer to extract the audio, and if there's an extracted file, proceed to the audio encoding, else proceed to the final merge.
__________________
Detritus Software
Sirber is offline   Reply With Quote
Old 2nd February 2010, 14:45   #379  |  Link
Sirber
retired developer
 
Sirber's Avatar
 
Join Date: Oct 2002
Location: Canada
Posts: 8,978
I'm gonna remove XviD and add profiles for 720p and 1080p.

[edit]

I think I'm gonna change the toolchain to:

* handbrake CLI for H264 and AAC LC encoding
* mplayer for audio extraction
* enhAacPlus for AAC HE and HE+PS encoding
* optional: Nero AAC for AAC HE and HE+PS encoding
__________________
Detritus Software

Last edited by Sirber; 2nd February 2010 at 15:20.
Sirber is offline   Reply With Quote
Old 8th February 2010, 01:51   #380  |  Link
Fidelix
Registered User
 
Join Date: Mar 2009
Posts: 21
Quote:
Originally Posted by Sirber View Post
I'm gonna remove XviD and add profiles for 720p and 1080p.

[edit]

I think I'm gonna change the toolchain to:

* handbrake CLI for H264 and AAC LC encoding
* mplayer for audio extraction
* enhAacPlus for AAC HE and HE+PS encoding
* optional: Nero AAC for AAC HE and HE+PS encoding
That seems to be getting really good.
good luck man, and keep up the progress!
Fidelix is offline   Reply With Quote
Reply

Tags
aac, bencos, gui, webm, x264

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 16:33.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.