Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old 24th February 2024, 23:09   #1  |  Link
Aleq
Registered User
 
Join Date: Apr 2010
Posts: 10
Unable to restore smooth 23.976 playback in mpc-hc

Hi,
I have Windows 11, MPC-HC 2.1.2 on ThinkPad with nVIDIA RTX 3080, audio pass-through to AVR. After very long struggle (with various renderers including madVR), I managed to get perfectly smooth playback of 23.976 videos using MPC Video Renderer on SONY VPL-HW15 1080p projector using 23.976 Hz refresh. I have upgraded projector ho VPL-VW520ES 4K and I fail to achieve same smoothness. It's gone, no matter what I do. I tried
  • Disabling HDR
  • MPC Video Renderer (with or without exclusive mode, with VBlank or without)
  • EVR
  • Sync renderer
  • madVR (again, with or without exclusive mode, VSync, ...)
No luck, the final subtitles are not smooth, there are glitches here and there (every couple of seconds).

It's really strange, but VLC is smooth.
Also if I switch the display to 60 (59.940) then it's quite ok (with small amount of judder which is much less obtrusive than the problems with 23.976) - this leads me to thinking it's not a performance issue (neither CPU, GPU nor Windows itself)

I have recorded few seconds of such playback including statistics using MPC VR, EVR, madVR on a mobile phone camera.
https://www.youtube.com/watch?v=_MnTacN5Vkc
https://www.youtube.com/watch?v=OmqWRO73_gc
https://www.youtube.com/watch?v=McORx-hmj3U

I'm desperate. Anybody any ideas, please?

TIA

Last edited by Aleq; 25th February 2024 at 00:26.
Aleq is offline   Reply With Quote
Old 24th February 2024, 23:15   #2  |  Link
Aleq
Registered User
 
Join Date: Apr 2010
Posts: 10
Huh, MPC BE with default EVR and even in MPC VR is also smooth...
However only if HDR is turned off. Once the HDR is ON, it's same as MPC-HC

Last edited by Aleq; 25th February 2024 at 02:05.
Aleq is offline   Reply With Quote
Old 25th February 2024, 06:50   #3  |  Link
Klaus1189
Registered User
 
Join Date: Feb 2015
Location: Bavaria
Posts: 1,667
I can not watch the videos.
Klaus1189 is offline   Reply With Quote
Old 25th February 2024, 19:32   #4  |  Link
Aleq
Registered User
 
Join Date: Apr 2010
Posts: 10
Hi @Klaus1189,
thanks for the info! I did not realize it did not get fully published. It should be ok now.

Cheers
A.
Aleq is offline   Reply With Quote
Old 25th February 2024, 19:43   #5  |  Link
Charky
Registered User
 
Join Date: Apr 2018
Location: Paris, France
Posts: 92
There's something wrong with your rendering times, especially with madvr. Your GPU should swallow any setting you use. With a 3080 you should peak to 5 ms/frame max.

Benchmark you GPU. Maybe check driver and global GPU power management settings.
__________________
Charky

"Rule #1 : If it works, don't change anything."

Last edited by Charky; 25th February 2024 at 19:49.
Charky is offline   Reply With Quote
Old 26th February 2024, 00:36   #6  |  Link
clsid
*****
 
Join Date: Feb 2005
Posts: 5,646
Change hardware decoder to D3D11 in the video decoder settings.

Also update MPC-HC and MPCVR:
https://github.com/clsid2/mpc-hc/releases/tag/2.1.5.14
__________________
MPC-HC 2.2.1
clsid is offline   Reply With Quote
Old 29th February 2024, 00:43   #7  |  Link
Aleq
Registered User
 
Join Date: Apr 2010
Posts: 10
Many thanks for replies. I finally got to it and tested all (with exception of the benchmarking the GPU - not sure which benchmark exactly should I run) what was suggested.

I have installed MPC-HC 2.1.5.22 x64 + MPCVideoRenderer 0.7.2.2199
Changed: Filters - LAV Video Decoder - Hardware Decoder DXVA2 (native) -> D3D11

I used defaults in MPCVR + Increased font for statistics only.

The screen went blank on playback, had to change Windows HDR: Do not change or Allow turn on (Fullscreen). Strangely, when I test it now, it works even with all values Default (I'm using that button).

Another update - MPC-HC 2.1.6 + MPCVR 0.7.2.2203

Still the same

Windows Settings - Power Mode - changed from Best power efficiency through Balanced up to Best performance
Both pre and post resize shaders turned off.

If I enable Wait for VBlank, it's better, it looks smoother between the stutters, which still occurs very often...

If I try madVR, I get similar performance

I have done an upgrade (CLEAN Installation) of the NVIDIA drivers from Lenovo ThinkPad default 537.79 to 551.61 reference NVIDIA driver. No change.

Videos follow:

https://www.youtube.com/watch?v=P2BnkYu42zA

https://www.youtube.com/watch?v=v1lYFAnPDks
https://www.youtube.com/watch?v=jwuo7MqpMkg
Attachments Pending Approval
File Type: png Screenshot_37.png
File Type: png Screenshot_38.png
File Type: png Screenshot_39.png
File Type: png Screenshot_40.png
File Type: png Screenshot_42.png
Aleq is offline   Reply With Quote
Old 29th February 2024, 01:37   #8  |  Link
clsid
*****
 
Join Date: Feb 2005
Posts: 5,646
There are weird spikes in present and render times. So hardware/driver issue.

Check for DPC latency issues.

In madvr reduce the "frames presented in advance" to 1.
__________________
MPC-HC 2.2.1
clsid is offline   Reply With Quote
Old 29th February 2024, 10:19   #9  |  Link
Grimsdyke
Registered User
 
Join Date: Nov 2013
Location: Hannover, Germany
Posts: 292
In LAV you might also try D3D11 Automatic (Native)
__________________
MPC-BE feature wishlist: 1) DiscID
2) Two independent volume control sliders in the UI when using dual-audio-out.
Grimsdyke is offline   Reply With Quote
Old 4th March 2024, 17:00   #10  |  Link
Aleq
Registered User
 
Join Date: Apr 2010
Posts: 10
I have LAV D3D11 Automatic (Native)
DPC Latency looks reasonably fine - there are some spikes, but much less frequently than observed stutters in video. However I tested it without projector running. I'll check the latencies when the setup is identical (that's something I can test usually in the evening (my monitors don't support anything but 60) and when nobody complains I'm fiddling with it too much ) Looking forward to see "frames presented in advance" in action with 1. I always though - the more the better.
Attachments Pending Approval
File Type: png Screenshot_46.png
Aleq is offline   Reply With Quote
Old 4th March 2024, 22:58   #11  |  Link
Aleq
Registered User
 
Join Date: Apr 2010
Posts: 10
Huh!
1. madVR + "frames presented in advance" 1
2. MPCVR + Wait for VBlank + pause the video, wait a bit and then resume

both options now provide smooth 23.976 even in HDR for me!
I'll keep experimenting, many thanks for your help. Hope this is it, no new problem pops out, I did just a few one minute short tests (although even that's way longer than what it used to take to stutter)
Aleq is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 03:43.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.