Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 AVC / H.264

Reply
 
Thread Tools Search this Thread Display Modes
Old 11th September 2008, 21:03   #1  |  Link
elmarikon
der Name sagt alles
 
elmarikon's Avatar
 
Join Date: Jul 2008
Location: Hamburg, Germany
Posts: 37
BluRay with Adobe Encore CS3 and Roxio HDVDit pro HD 6.4

Some results and still some problems

i was encoding some material for BluRays.
All movies are 1920x1080, 25psf, I encoded them to raw .264 as tff "interlaced", 8Mbit, GOP size 18 (I-PBB-PBB-...)...
1st try: using the SA-BD-fast preset of me-gui.
With Adobe Encore CS3 these files cause problems, when they are longer then about 10 secs.
I found out, that it had to do with the time base.
One can not use --fps 25, but --fps 2500/100.
Then it kind of worked without transcoding.
But since Encore is everything but stable and reliable (at least with AVC-HD content), not to speak about the time it needs to do things, i want to switch to Roxio DVDit pro HD 6.4.
This prog is much more basic and I was hoping to do better with this.
But although they both seem to use the same muxing engine, Roxio does not accept my files.
(file ending for Roxio has o be .264, for Adobe it must be .m4v, but that's 2 names for the same thing, right?!)
The program can identify the clips as AVC codec, but with the wrong duration. AND wants to transcode them. Then I get crappy looking mpegs way too short.

Someone posted a .264 1920x1080 50i in the Roxio forum created by MainConcept reference encoder.
This file is being accepted (right duration) and not transcoded, just muxed.
So I generated a file of about the same length and started comparing the 2 with Elecard stream analyzer.
And I found out some things:

MainC. seems to generate pure interlaced files, not mbaff, as x264 does...
(At least for Adobe this is fine and)
(24p does not work for Roxio as well)

in the MainC. file every frame appears 6 times in groups of 3.
Since MainC. file is pure interlaced, every frame is separated in 2 fields, but then every field seems to be portioned in 3 splices again...
(I don't know, if this matters, nor what it is good for... I could no recreate that with x264)

MainC. writes the "H264 picture parameter set" before every frame, while x264 only puts them before every I-frame.
To check if this matters, I encoded my file to "I-frames only".
Suddenly the Roxio saw the right duration. But the prob still is: it wants to transcode...
This may have to do with keyint=1 is not supported?!

Since I sadly do not have a single clue about programming, I do not know, how much effort it would make to add an option for "H264 picture parameter set before every frame"...
But this would at least solve one of the problems and one could do further tryouts...

please mind the attachments...

Has anyone experiences with bluray?


keep on rokkin'!
SwK
Attached Files
File Type: zip fb-25.zip (283.9 KB, 37 views)
File Type: zip MainC-50i.zip (288.5 KB, 30 views)
File Type: zip fb-Ionly-25.zip (137.4 KB, 22 views)
elmarikon is offline   Reply With Quote
Reply

Tags
adobe, bluray, dvdit, encore, roxio

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 17:24.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.