Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 AVC / H.264

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 17th September 2015, 18:59   #1  |  Link
Prathamesh
Registered User
 
Join Date: Sep 2015
Posts: 4
muxing raw h.264 and aac using manzanita muxer.

Hi,

My first post on this forum. I used the below command to get raw h.264 video file and aac audio file from source mp4 video.

fmpeg -i s1.mp4 -acodec aac -strict -2 -b:a 128k testA.aac -vcodec libx264 -r 30000/1001 -s 720x480 -aspect 16:9 -profile:v main -level:v 3.1 -x264opts aud:force-cfr:ref=1:keyint=15:min-keyint=15:scenecut=-1:bframes=2:b-adapt=0:b-pyramid=none:weightb=0:weightp=0 -b:v 1500k -minrate 1500k -maxrate 1500k -bufsize 1835k -nal-hrd cbr -f h264 testA.h264

the output h.264 file plays well, but shows no duration in mediainfo.

I muxed the audio and video into Mpeg 2 TS using Manzanita mp2tsme, the muxed file plays well on the pc, but when checking with ts analyzer it shows error "video end of bitstream units not found"

Can somebody kindly help me in finding a solution for this. I dont have deep knowledge of h264/ffmpeg, but is this error because of raw h.264 stream?

Thanks & Regards.

Last edited by Prathamesh; 17th September 2015 at 19:02.
Prathamesh is offline   Reply With Quote
 

Tags
ffmpeg, h.264, mpeg-ts, x264

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 18:10.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.