Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 Encoder GUIs

Reply
 
Thread Tools Search this Thread Display Modes
Old 15th June 2024, 22:34   #20741  |  Link
chainring
Registered User
 
chainring's Avatar
 
Join Date: Sep 2006
Posts: 178
@essential,

Easiest way is to modify your Windows power plan.

Control Panel > Hardware and Sound > Choose a power plan > Change plan settings (I use "Balanced") > Change advanced power settings > Processor power management > Maximum processor state > set to 99%.

The six machines I have participating in DE mode used to sound like a vortex, all spun up to 100%. Now, with them all at 99%, it's nice and quiet and I didn't lose any speed.
chainring is offline   Reply With Quote
Old 16th June 2024, 02:40   #20742  |  Link
essential
Registered User
 
Join Date: Oct 2005
Posts: 32
Quote:
Originally Posted by chainring View Post
@essential,

Easiest way is to modify your Windows power plan.

Control Panel > Hardware and Sound > Choose a power plan > Change plan settings (I use "Balanced") > Change advanced power settings > Processor power management > Maximum processor state > set to 99%.

The six machines I have participating in DE mode used to sound like a vortex, all spun up to 100%. Now, with them all at 99%, it's nice and quiet and I didn't lose any speed.
Nice, thank you. I will try that.
essential is offline   Reply With Quote
Old 18th June 2024, 02:30   #20743  |  Link
rlev11
Registered User
 
Join Date: Aug 2020
Location: Pennsylvania
Posts: 97
Quote:
Originally Posted by chainring View Post
@essential,

Easiest way is to modify your Windows power plan.

Control Panel > Hardware and Sound > Choose a power plan > Change plan settings (I use "Balanced") > Change advanced power settings > Processor power management > Maximum processor state > set to 99%.

The six machines I have participating in DE mode used to sound like a vortex, all spun up to 100%. Now, with them all at 99%, it's nice and quiet and I didn't lose any speed.
Agree with this, have done this in the past and I agree, didn't notice any real encoding performance drop. maybe a few fps at most. Will really help lowering cpu temperatures

What setting it to 99% does is limit the cpu's from going into their turbo or boost modes. Will just run at the stock max frequency.

Should be able to find instructions on the web, I don't remember now anymore how I did it, but I ended up making 2 power plan desktop shortcuts, 1 for 100% and 1 for 99%. made it easy to switch back and forth just by clicking the shortcut.
rlev11 is offline   Reply With Quote
Old 19th June 2024, 07:59   #20744  |  Link
Atak_Snajpera
RipBot264 author
 
Atak_Snajpera's Avatar
 
Join Date: May 2006
Location: Poland
Posts: 7,870
Quote:
Will just run at the stock max frequency.
Exactly at 99% of the stock CPU clock. (on my cpu)


I wonder if the same rule applies to for example Intel 14900k where base clock is just 2GHz?
Atak_Snajpera is offline   Reply With Quote
Old 30th June 2024, 12:48   #20745  |  Link
userx
Registered User
 
userx's Avatar
 
Join Date: Mar 2016
Location: Austria
Posts: 33
issues with attachment parsing

  1. Is there a setting to switch off attachment parsing in general?
  2. Encountered issues with attached fonts and whitespaces, so MKVExtract would fail.

MKVExtract.json
Code:
[
  "<REMOVED>",
  "tracks",
  "1:D:\\Temp\\RipBot264temp\\job1082\\1_audio_German_DEFAULT.aac",
  "2:D:\\Temp\\RipBot264temp\\job1082\\2_audio_Japanese.aac",
  "3:D:\\Temp\\RipBot264temp\\job1082\\1_subtitles_German_DEFAULT_FORCED.ass",
  "4:D:\\Temp\\RipBot264temp\\job1082\\2_subtitles_German_DELAY4460ms.ass",
  "5:D:\\Temp\\RipBot264temp\\job1082\\3_subtitles_English_DELAY4410ms.ass",
  "chapters",
  "-s",
  "D:\\Temp\\RipBot264temp\\job1082\\chapters.txt",
  "attachments",
  "1:D:\\Temp\\RipBot264temp\\job1082\\AmazonEmber_Bd.ttf",
  "2:D:\\Temp\\RipBot264temp\\job1082\\AmazonEmber_BdIt.ttf",
  "3:D:\\Temp\\RipBot264temp\\job1082\\AmazonEmber_Rg.ttf",
  "4:D:\\Temp\\RipBot264temp\\job1082\\AmazonEmber_RgIt.ttf",
  "5:D:\\Temp\\RipBot264temp\\job1082\\Tahoma.ttf",
  "6:D:\\Temp\\RipBot264temp\\job1082\\Georgia.ttf",
  "7:D:\\Temp\\RipBot264temp\\job1082\\Times",
  "New",
  "Roman.ttf",
  "8:D:\\Temp\\RipBot264temp\\job1082\\Times",
  "New",
  "Roman",
  "Bold.ttf",
  "9:D:\\Temp\\RipBot264temp\\job1082\\Trebuchet",
  "MS.ttf"
]
attachments.csv
Code:
"font/ttf";"D:\Temp\RipBot264temp\job1082\AmazonEmber_Bd.ttf"
"font/ttf";"D:\Temp\RipBot264temp\job1082\AmazonEmber_BdIt.ttf"
"font/ttf";"D:\Temp\RipBot264temp\job1082\AmazonEmber_Rg.ttf"
"font/ttf";"D:\Temp\RipBot264temp\job1082\AmazonEmber_RgIt.ttf"
"font/ttf";"D:\Temp\RipBot264temp\job1082\Tahoma.ttf"
"font/ttf";"D:\Temp\RipBot264temp\job1082\Georgia.ttf"
"application/x-truetype-font";"D:\Temp\RipBot264temp\job1082\Times New Roman.ttf"
"application/x-truetype-font";"D:\Temp\RipBot264temp\job1082\Times New Roman Bold.ttf"
"application/x-truetype-font";"D:\Temp\RipBot264temp\job1082\Trebuchet MS.ttf"

Last edited by userx; 30th June 2024 at 12:51. Reason: additional info
userx is offline   Reply With Quote
Old 30th June 2024, 13:58   #20746  |  Link
Atak_Snajpera
RipBot264 author
 
Atak_Snajpera's Avatar
 
Join Date: May 2006
Location: Poland
Posts: 7,870
Send me mkv sample containing those attachments for testing purposes.
Atak_Snajpera is offline   Reply With Quote
Old 6th July 2024, 04:37   #20747  |  Link
FTLOY
Friend of a friend..
 
FTLOY's Avatar
 
Join Date: Feb 2023
Posts: 310
A month on since that last update, and I am still getting random AV alerts on Encoding Server, which can be a pain when it's quarantined mid encode (like it just did).

But other than that, things are running pretty sweet, despite what some say....
__________________
RipBot264 v1.27.3 (08-06-2024)
FTLOY is offline   Reply With Quote
Old 7th July 2024, 08:08   #20748  |  Link
Atak_Snajpera
RipBot264 author
 
Atak_Snajpera's Avatar
 
Join Date: May 2006
Location: Poland
Posts: 7,870
Quote:
Originally Posted by FTLOY View Post
A month on since that last update, and I am still getting random AV alerts on Encoding Server, which can be a pain when it's quarantined mid encode (like it just did).

But other than that, things are running pretty sweet, despite what some say....
Can't you just add encodingserver.exe to some whitelist in your AV?
Atak_Snajpera is offline   Reply With Quote
Old 8th July 2024, 12:32   #20749  |  Link
FTLOY
Friend of a friend..
 
FTLOY's Avatar
 
Join Date: Feb 2023
Posts: 310
Quote:
Originally Posted by Atak_Snajpera View Post
Can't you just add encodingserver.exe to some whitelist in your AV?
I have Googled how to do this with Defender, and it's not as easy as it sounds.

The problem is that when you get a notification that there's a problem, you can "Allow" it, but this isn't a permanent "Allow" like most other alerts...it just likes to repeat, every day or so.
__________________
RipBot264 v1.27.3 (08-06-2024)
FTLOY is offline   Reply With Quote
Old 8th July 2024, 13:20   #20750  |  Link
LigH
German doom9/Gleitz SuMo
 
LigH's Avatar
 
Join Date: Oct 2001
Location: Germany, rural Altmark
Posts: 6,885
Windows Defender should support exclusions.
__________________

New German Gleitz board
MediaFire: x264 | x265 | VPx | AOM | Xvid
LigH is offline   Reply With Quote
Old 8th July 2024, 13:36   #20751  |  Link
FTLOY
Friend of a friend..
 
FTLOY's Avatar
 
Join Date: Feb 2023
Posts: 310
Quote:
Originally Posted by LigH View Post
Windows Defender should support exclusions.
Thanks LigH,

I got close to those settings, but didn't find that one...I will have to remember that.

Cheers.
__________________
RipBot264 v1.27.3 (08-06-2024)
FTLOY is offline   Reply With Quote
Old 9th July 2024, 01:22   #20752  |  Link
rlev11
Registered User
 
Join Date: Aug 2020
Location: Pennsylvania
Posts: 97
What I did was open Defender, Then Virus and threat protection, Manage settings under Virus&threat protection settings, scroll to bottom and hit Add or remove exclusions under Exclusions, +add an exclusion.

I just excluded the ripbot folder. You can exclude files of folders from there.
rlev11 is offline   Reply With Quote
Old 9th July 2024, 01:33   #20753  |  Link
FTLOY
Friend of a friend..
 
FTLOY's Avatar
 
Join Date: Feb 2023
Posts: 310
Quote:
Originally Posted by rlev11 View Post
What I did was open Defender, Then Virus and threat protection, Manage settings under Virus&threat protection settings, scroll to bottom and hit Add or remove exclusions under Exclusions, +add an exclusion.

I just excluded the ripbot folder. You can exclude files of folders from there.
Yep, that's what I ended up doing, I just wasn't 100% sure where this option was.

But we really shouldn't need to do this, it shouldn't have happened in the first place
__________________
RipBot264 v1.27.3 (08-06-2024)
FTLOY is offline   Reply With Quote
Old 12th July 2024, 05:34   #20754  |  Link
FTLOY
Friend of a friend..
 
FTLOY's Avatar
 
Join Date: Feb 2023
Posts: 310
Hi Atak,

An interesting request (problem / dilemma)...

I have some .mov files created with DaVinci Resolve (below, MediaInfo)

I can load them into RB, but they do not encode with DE. (haven't tried them in single mode)

Not sure if it's an x265 limitation (or it needs specific commands)

Code:
x265 [FLAW]: unable to open input file <->

OR

y4m [FLAW]: bad sequence header magic
x264 [FLAW]: could not open input file `-'
But how could I retain that very high Bitrate ??

Code:
Video
ID                                       : 1
Format                                   : CineForm
Codec ID                                 : CFHD
Codec ID/Info                            : CineForm High-Definition (HD) wavelet codec
Duration                                 : 1 h 20 min
Bit rate mode                            : Variable
Bit rate                                 : 1 110 Mb/s
Width                                    : 3 840 pixels
Height                                   : 2 160 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 60.000 FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:2
Bit depth                                : 10 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 2.230
Stream size                              : 621 GiB (100%)
Encoded date                             : 2024-07-11 03:50:31 UTC
Tagged date                              : 2024-07-11 03:50:31 UTC
Color primaries                          : Display P3
Transfer characteristics                 : PQ
Matrix coefficients                      : BT.709
__________________
RipBot264 v1.27.3 (08-06-2024)

Last edited by FTLOY; 12th July 2024 at 07:50.
FTLOY is offline   Reply With Quote
Old 12th July 2024, 09:41   #20755  |  Link
LigH
German doom9/Gleitz SuMo
 
LigH's Avatar
 
Join Date: Oct 2001
Location: Germany, rural Altmark
Posts: 6,885
Not sure what "DE" means in your case...

DaVinci has a CineForm codec to export videos in CineForm HD format. But RipBot cannot use the codec which is built into DaVinci to decode that CineForm video again; you need a source filter for Avisynth which is able to decode the CineForm HD format, which may not be the case on your system. So you can probably not use the CineForm HD video format as intermediate exchange format, but a different one which is also supported by Avisynth source filters.
__________________

New German Gleitz board
MediaFire: x264 | x265 | VPx | AOM | Xvid
LigH is offline   Reply With Quote
Reply

Tags
264, 265, appletv, avchd, bluray, gui, iphone, ipod, ps3, psp, ripbot264, x264 2-pass, x264 gui, x264_64, x265, xbox360

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 08:44.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.