Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > Avisynth Usage

Reply
 
Thread Tools Search this Thread Display Modes
Old 18th October 2014, 23:56   #1  |  Link
normann
Registered User
 
Join Date: Dec 2013
Posts: 2
MPEG2Source freezes after Windows 7 reinstall

Hi

I've just reinstalled my Windows 7 workstation and all programs and now MPEG2Source doesn't work in AVISynth. I have been using AviSynth 2.5.8 and DGDecode without any problems in the old Windows installation, but that's over now.

I have tried both AviSynth 2.6.0 and 2.5.8 with the same problem occurring and it doesn't matter whether i put DGDecode.dll (v1.5.8) in AviSynth's plugins directory or if I load it from elsewhere with LoadPlugin(). If I trim my .avs file down to only on line loading a newly created .d2v (from DGIndex) with

MPEG2Source("file.d2v")

then AviSynth hangs, both when loaded from MPC-HC, VirtualDub or ffmpeg, and I have to kill the parent process.

I'm (just like before) running Windows 7 64-bit and the 32-bit official builds of AVISynth and the most recent 32-bit versions of MPC-HC, VirtualDub and ffmpeg.

Does anyone have an idea of what could be wrong or what I should do to debug this situation? Google hasn't been able to help me yet.

Any help is appreciated.

Best wishes,
Jan
normann is offline   Reply With Quote
Old 19th October 2014, 00:29   #2  |  Link
Groucho2004
 
Join Date: Mar 2006
Location: Barcelona
Posts: 5,034
Pretty odd.

- Run this tool and post the log (File->Save Info).
- Where did you download DGIndex/DGDecode?
Groucho2004 is offline   Reply With Quote
Old 19th October 2014, 01:31   #3  |  Link
normann
Registered User
 
Join Date: Dec 2013
Posts: 2
I must have been staring at my new scripts for too long before I posted this issue. After looking at my scripts again, I now see that I was actually doing a thing I hadn't done before: I was running DGIndex and MPEG2Source on M2TS and MKV containers and those seem not to be supported although DGIndex will read them and create a .d2v file without complaining. If I demux my containers and run DGIndex on the elementary MPEG2 video stream, it seems that MPEG2Source works without any problems.

I also realize that my old scripts that previously did work don't actually hang due to MPEG2Source not working as the problem above, but due to Normalize() taking a long time to complete on my huge files. My new disk is silent so I can't hear Normalize working it's way through the file as I could previously so I thought it was the same problem.

I'm sorry for wasting everybody's precious time, at least I hope my answer will help others if they run into the same problem as I did.
normann is offline   Reply With Quote
Reply

Tags
avisynth, dgdecode, mpeg2source

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 03:17.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.