Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 29th May 2007, 20:18   #261  |  Link
Casimir666
Registered User
 
Join Date: Jan 2007
Posts: 455
I think i have solve the subtitle bug : one of the Drevil_xxl was not applied by "Subversion" grrrr.

Daily build available here :
http://tibrium.neuf.fr/temp/mplayerc_1.0.7.2.rar

With thoses corrections :
- Fixed : jitter test did not display on some files
- Fixed : crash if display statistics when d3dx9_29.dll was not present
- Fixed : crash possible with OSD when closing file
- Fixed : kick off power option screen saver with Vista (if MPC have focus only)
- Fixed : DVD menu freeze with nVidia Pure Video decoder
- Fixed : clic to play not working at the bottom of video
- Fixed : MKV internal subtitles did not displayed from time to time
__________________
Tired of tearing?
Try this Media Player Classic mod : http://mpc-hc.sourceforge.net
Casimir666 is offline  
Old 29th May 2007, 20:33   #262  |  Link
foxyshadis
ангел смерти
 
foxyshadis's Avatar
 
Join Date: Nov 2004
Location: Lost
Posts: 9,487
Quote:
Originally Posted by sillKotscha View Post
first thanks for your answer but are you really sure?... 'cause if I use VMR9 without post-processing in ffdshow it is nearly the same result as with VMR7 (windowed) in conjunction with ffdshow's post-processing...

so, at least visually, I can see a difference using different renderer with/ without post-processing...
Then your video driver is doing post-processing in DX9, which should be controllable from its control panel.
__________________
There are four boxes to be used in defense of liberty: soap, ballot, jury, and ammo. Please use in that order.
foxyshadis is offline  
Old 29th May 2007, 20:35   #263  |  Link
Egh
Registered User
 
Join Date: Jun 2005
Posts: 630
Quote:
Ctrl+C to close video, or Ctrl+X to exit MPC
First right, second not, Alt+X to close the program :P

Seconds, just tried latest build. Not that I use D3D Fullscreen atm, but a very funny bug was found ^^

In short in D3D + EVR Custom Pres. you as usual need to move cursor to the bottom of the screen to see the slider bar. It IS shown when you move to the bottom of the screen but it is shown at the bottom of the FRAME, thus you're unable to seek video whatsoever :rofl: Seems to work as usual when VMR9 is on.

Note of course my video is yet again 720p and therefore there're black bars on top/bottom of the frame (i have casual 4:3 CRT).
Egh is offline  
Old 29th May 2007, 20:38   #264  |  Link
LoRd_MuldeR
Software Developer
 
LoRd_MuldeR's Avatar
 
Join Date: Jun 2005
Location: Last House on Slunk Street
Posts: 13,122
I recently installed .NET Bloatwork 3.0, so I can test EVR now

Then I noticed that the "Resizer" option obviously doesn't work with "EVR Custom Pres" renderer.
I selected "Nearest Neighbor", went to Fullscreen and it clearly was not Nearest Neighbor
__________________
There was of course no way of knowing whether you were being watched at any given moment.
How often, or on what system, the Thought Police plugged in on any individual wire was guesswork.


LoRd_MuldeR is offline  
Old 29th May 2007, 21:01   #265  |  Link
JarrettH
Registered User
 
Join Date: Aug 2004
Posts: 845
Is there a preferred resizer? just wondering...
JarrettH is offline  
Old 29th May 2007, 21:05   #266  |  Link
skafidask
Registered User
 
Join Date: Feb 2007
Posts: 13
[QUOTE=Casimir666;1008730][QUOTE=skafidask;1008624]i have a little problem. when i use evr custom i don't get DXVA 2.0 from my 8600gt
Quote:
Where did you see if DXVA 2.0 is activated?
i just opened a task manager on the background and left it there for a while, also most of my x264 files when i play them without DXVA 2.0 i get stuttering because i have 100% cpu util.(i have a 3.0ghz HT p4)

By the way i went from powerdvd 7.3.2605 to 7.3.2911 and i got black screen on all players(powerdvd,wmp 11,mpc,zoom) using cyberlink decoder and dxva 2.0 and i went back to 2605 anybody else having the same problem??
skafidask is offline  
Old 29th May 2007, 21:22   #267  |  Link
Casimir666
Registered User
 
Join Date: Jan 2007
Posts: 455
Quote:
Originally Posted by Egh View Post
In short in D3D + EVR Custom Pres. you as usual need to move cursor to the bottom of the screen to see the slider bar. It IS shown when you move to the bottom of the screen but it is shown at the bottom of the FRAME, thus you're unable to seek video whatsoever :rofl: Seems to work as usual when VMR9 is on.
Yes i know EVR custom is not perfect yet
__________________
Tired of tearing?
Try this Media Player Classic mod : http://mpc-hc.sourceforge.net
Casimir666 is offline  
Old 29th May 2007, 21:22   #268  |  Link
Avish
Registered User
 
Avish's Avatar
 
Join Date: Jan 2006
Posts: 147
In MPC's Internal Filters menu, when I hover my mouse over MPEG-1 Video, a tool tip appears, which says "6.4.0.3 Based on libmpeg2 (mpeg1 video decoding is bogus)". What exactly does it means??? Does that mean we should not use it for mpeg1 decoding coz its bogus? or is it something else??

Can anybody please clarify this??

Thanks in advance,
Avish.
__________________
i7-2600 | GA-B75-D3V | Tempest EVO | VX450 & XMS3 16GB | SanDisk Extreme 120GB | U2311H | MK520 | MSI GTX750 Ti Gaming | CM Hyper 212+ | APC 1KVA | Xonar DG | SoundSticks III | Win 7 x64
Avish is offline  
Old 29th May 2007, 21:28   #269  |  Link
Kado
Otaku
 
Kado's Avatar
 
Join Date: Sep 2006
Location: Portugal
Posts: 576
@Casimir666

Great job! Subs are now working great!
I have found some issues but I'm going to do some more testing before submitting.
__________________
In the school, the three guys met. Their relation had been changed in the season, and turned into three love stories.
Kado is offline  
Old 29th May 2007, 21:45   #270  |  Link
JarrettH
Registered User
 
Join Date: Aug 2004
Posts: 845
libmpeg2 can do all MPEG streams if I am not mistaken
JarrettH is offline  
Old 29th May 2007, 23:33   #271  |  Link
chros
Registered User
 
chros's Avatar
 
Join Date: Mar 2002
Posts: 1,623
Quote:
Originally Posted by JarrettH View Post
libmpeg2 can do all MPEG streams if I am not mistaken
And in ffdshow it's multithreaded (mpeg1 also) !
chros is offline  
Old 29th May 2007, 23:41   #272  |  Link
chros
Registered User
 
chros's Avatar
 
Join Date: Mar 2002
Posts: 1,623
Quote:
Originally Posted by Egh View Post
In short in D3D + EVR Custom Pres. you as usual need to move cursor to the bottom of the screen to see the slider bar. It IS shown when you move to the bottom of the screen but it is shown at the bottom of the FRAME, thus you're unable to seek video whatsoever :rofl: Seems to work as usual when VMR9 is on.
You CAN seek with it (you can click at the bottom)! (PS: I don't like the new seekbar )

For me, there's nothing useful in these builds, since I've got XP and I use Haali's renderer, but I'm helping discover bugs.
Anyway, thanks for your work Casimir!

One question (not related to these builds): I often get a message at the status bar when a second entry tried to be played in the playlist (or if I play 1 file, then I double-click in a file manager) and MPC can't open the next file:
"Faild to query the needed interfaces for playback"

What the heck is that? It's drive me crazy... (It's renderer independent)
chros is offline  
Old 30th May 2007, 02:37   #273  |  Link
B.F.
Registered User
 
B.F.'s Avatar
 
Join Date: Jul 2004
Location: Russia, Novosibirsk
Posts: 92
Quote:
Originally Posted by Casimir666 View Post
I think i have solve the subtitle bug : one of the Drevil_xxl was not applied by "Subversion" grrrr.
Yes.
Subtitles is working now.
And toolbar is working now with Haali render.
I think I can use your builds not just for tests now.

Ifo files still not working with Haali render.

Last edited by B.F.; 30th May 2007 at 02:40.
B.F. is offline  
Old 30th May 2007, 02:46   #274  |  Link
Sirber
retired developer
 
Sirber's Avatar
 
Join Date: Oct 2002
Location: Canada
Posts: 8,978
EVR custom (bicubic -1.00, 10 buffers) + H264 + DXVA = no acceleration (8-12% CPU)
EVR + H264 + DXVA = acceleration (2-4% CPU)

Also, crop don't work with EVR.

[edit]

seems DXVA bug is already reported
__________________
Detritus Software

Last edited by Sirber; 30th May 2007 at 02:50.
Sirber is offline  
Old 30th May 2007, 04:22   #275  |  Link
burfadel
Registered User
 
Join Date: Aug 2006
Posts: 2,234
For me in EVR custom the aspect ratio goes askew! It seems to default to 4:3, I have to manually override it to 16:9 and all is fine!

The picture quality in EVR custom though is better, so the resizer etc settings do work! I made comment in another post about an interface and name update, maybe if someone reading this thread is interested?...! The other thread got carried away a bit, I just think a modernisation of the buttons, colour scheme etc would be great. A good reason for this is that the buttons can get a bit small at high resolutions! Anyways, we all appreciate the great work you are doing with MPC! I don't expect you to work on the interface, its more of a 'that would be nice if anyone is interested in doing it' kind of thing. I'm not talking theme support! just bigger modernised buttons and colouring mainly! (thats when not in VMR9 mode etc, the slider bar there is nice and big)! 3D buttons anyone? lol

Last edited by burfadel; 30th May 2007 at 04:31.
burfadel is offline  
Old 30th May 2007, 19:49   #276  |  Link
clsid
Registered User
 
Join Date: Feb 2005
Posts: 5,059
Could you please adapt your mod to use Escape and F11 buttons for exiting Direct3D fullscreen?

During D3D mode, the context menu doesn't work properly, it disappears almost instantly. I guess that is a limitation of D3D. But perhaps you can pause the movie and properly show the menu? Otherwise I think it would be better to disable the menu entirely in D3D mode.

I also have some weird problem in D3D mode. The taskbar appears and starts flickering. This only seems to happen after pressing alt+enter twice.
clsid is offline  
Old 30th May 2007, 20:22   #277  |  Link
Avish
Registered User
 
Avish's Avatar
 
Join Date: Jan 2006
Posts: 147
Quote:
Originally Posted by chros View Post
And in ffdshow it's multithreaded (mpeg1 also) !
@chros & JarrettH, if your replies were to my query, then I already know that libmpeg2 can do all MPEG streams & in ffdshow it's multithreaded.
But my query was about MPC's internal MPEG-1 Decoder. Why it's tooltip says that "mpeg1 video decoding is bogus"???
__________________
i7-2600 | GA-B75-D3V | Tempest EVO | VX450 & XMS3 16GB | SanDisk Extreme 120GB | U2311H | MK520 | MSI GTX750 Ti Gaming | CM Hyper 212+ | APC 1KVA | Xonar DG | SoundSticks III | Win 7 x64
Avish is offline  
Old 30th May 2007, 20:58   #278  |  Link
Tima
Registered User
 
Join Date: Aug 2004
Location: Russia, Novosibirsk
Posts: 162
Seems there is some bug in MPC's internal VP6 decoder (and ffdshow's decoder is also broken).

Video sample: http://nwfiles.gorodok.net/VP6_MPC_internal.test.avi [771 Kb]. On MPC with internal VP6 decoder it plays corrupted and hangs at the frame #121 (with ffdshow decoder MPC doesn't hang, but there's just black screen all the time). With On2 VP6 DShow decoder all decoding is ok.

Last edited by Tima; 30th May 2007 at 21:02.
Tima is offline  
Old 31st May 2007, 02:08   #279  |  Link
iron2000
Questioning User
 
Join Date: Jan 2005
Posts: 166
Quote:
Originally Posted by Casimir666 View Post
Are you using YUV mixing option? If so try to remove it and leave just VMR9 mixer mode i think there is a bug with this option
I'm not using VMR9 at all, I'm on VMR7(windowed).
Anyway selecting VMR9 shows no video(a black screen only) with sound.


EDIT:
Ok, sort of solved the VMR9 issue.
The VMR9 colour controls were really off and a reset shows the picture.

Last edited by iron2000; 31st May 2007 at 03:47.
iron2000 is offline  
Old 31st May 2007, 13:15   #280  |  Link
LotharZ
Registered User
 
Join Date: Oct 2001
Posts: 47
http://tibrium.neuf.fr = error404

Seems tha website its down, anyone can provide a link for the last version?
LotharZ is offline  
Closed Thread

Tags
dxva, h264, home cinema, media player classic, mpc-hc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 05:40.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.