Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old 24th October 2015, 13:53   #3701  |  Link
Zachs
Suptitle, MediaPlayer.NET
 
Join Date: Nov 2001
Posts: 1,721
Well delayed frames occur when your GPU had failed to present the frame in the vsync MPDN wanted. This can be due to various reasons external to MPDN. But if it's just delayed by one frame on a 75hz display, chances are you won't even notice it.
Zachs is offline   Reply With Quote
Old 24th October 2015, 16:56   #3702  |  Link
christopherw
Registered User
 
Join Date: Mar 2006
Posts: 24
Interesting player with some useful potential. Small footprint is a bonus.

I'm having unexpected results with interlaced content though - with identical LAV filter settings, using either DXVA or CUVID, it's not properly deinterlacing. Even with 50/60p enabled and attempting to force either just hardware or just Yadif software, and aggressively deinterlacing, everything is being blend deinterlaced.

The same video files, with MPC-HC and LAV configured identically, play perfectly.

I'm happy to communicate privately and send some example video files so you can attempt to replicate the issue if you wish, PM me through the board.
christopherw is offline   Reply With Quote
Old 24th October 2015, 21:15   #3703  |  Link
burfadel
Registered User
 
Join Date: Aug 2006
Posts: 2,229
Quote:
Originally Posted by Zachs View Post
Does this happen with the older build as well (i.e. API level 7)?
Yes, I tried the last release with the old extension, and when the media file changes it comes up with the crash dialogue that says MPDN - Media Player .NET has stopped working.

I might try a really ancient version and associated extension and see if something has changed over the versions.
burfadel is offline   Reply With Quote
Old 24th October 2015, 22:43   #3704  |  Link
burfadel
Registered User
 
Join Date: Aug 2006
Posts: 2,229
I found where the issue is introduced, it's the extensions version v1.22.0. I tried numerous MPDN's and extensions, and they all worked fine (they would not crash). I then went back to MPDN v2.44.3.3480 and tried the numerous supported extensions. The v1.21.x series works fine (including v1.21.4), I went previous/next about 60 times trying to get it to crash, perfectly stable! I then tried extension version v1.22.0 (also supported under the same MPDN), and it crashed just like the latest versions, without fail. I then tried extension version v1.21.4 again, and no issues!

So, the issue was definitely introduced in v1.22.0. I hope that makes it easier to track down what could be causing it!
burfadel is offline   Reply With Quote
Old 25th October 2015, 00:12   #3705  |  Link
ryrynz
Registered User
 
ryrynz's Avatar
 
Join Date: Mar 2009
Posts: 3,653
Quote:
Originally Posted by burfadel View Post
So, the issue was definitely introduced in v1.22.0. I hope that makes it easier to track down what could be causing it!
Possibly unrelated but I had mpdn crash on Windows 7 last night when changing files. Not sure what caused it but Icaros crashed also.
ryrynz is offline   Reply With Quote
Old 25th October 2015, 00:41   #3706  |  Link
burfadel
Registered User
 
Join Date: Aug 2006
Posts: 2,229
Quote:
Originally Posted by ryrynz View Post
Possibly unrelated but I had mpdn crash on Windows 7 last night when changing files. Not sure what caused it but Icaros crashed also.
It could be? I don't use Icaros so I can't say about that. All I know is that anything before extensions v1.22.0 works perfectly, v1.22.0 or later it crashes when changing files consistently.
burfadel is offline   Reply With Quote
Old 25th October 2015, 00:44   #3707  |  Link
Anima123
Registered User
 
Join Date: Jun 2005
Posts: 504
Quote:
Originally Posted by burfadel View Post
It could be? I don't use Icaros so I can't say about that. All I know is that anything before extensions v1.22.0 works perfectly, v1.22.0 or later it crashes when changing files consistently.
I've experienced similar crashes too. Now I had to quit MPDN and restarted it playing another file in order to avoid the crash.
Anima123 is offline   Reply With Quote
Old 25th October 2015, 01:18   #3708  |  Link
burfadel
Registered User
 
Join Date: Aug 2006
Posts: 2,229
Quote:
Originally Posted by Anima123 View Post
I've experienced similar crashes too. Now I had to quit MPDN and restarted it playing another file in order to avoid the crash.
It's good to know that's it's not just me then! I'm sure it's something simple.
burfadel is offline   Reply With Quote
Old 25th October 2015, 02:43   #3709  |  Link
Zachs
Suptitle, MediaPlayer.NET
 
Join Date: Nov 2001
Posts: 1,721
Do you have preload next file enabled in your playlist settings?

If you do, try disabling that to isolate the problem.
Zachs is offline   Reply With Quote
Old 25th October 2015, 02:47   #3710  |  Link
edison
Registered User
 
Join Date: Dec 2005
Posts: 108
The program will crash if the speaker/headphone was unpluged.
edison is offline   Reply With Quote
Old 25th October 2015, 03:41   #3711  |  Link
burfadel
Registered User
 
Join Date: Aug 2006
Posts: 2,229
Quote:
Originally Posted by Zachs View Post
Do you have preload next file enabled in your playlist settings?

If you do, try disabling that to isolate the problem.
No luck here. I tried that and it still crashes as before.
burfadel is offline   Reply With Quote
Old 25th October 2015, 11:25   #3712  |  Link
Zachs
Suptitle, MediaPlayer.NET
 
Join Date: Nov 2001
Posts: 1,721
Can you try disable xysubfilter and try again?
Zachs is offline   Reply With Quote
Old 25th October 2015, 12:17   #3713  |  Link
Anima123
Registered User
 
Join Date: Jun 2005
Posts: 504
Crash still occurs after disabling subtitle feature.
Anima123 is offline   Reply With Quote
Old 25th October 2015, 12:35   #3714  |  Link
burfadel
Registered User
 
Join Date: Aug 2006
Posts: 2,229
Same here, and I also have subtitles disabled by default and double checked to make sure.
burfadel is offline   Reply With Quote
Old 25th October 2015, 14:27   #3715  |  Link
ryrynz
Registered User
 
ryrynz's Avatar
 
Join Date: Mar 2009
Posts: 3,653
I sometimes get visual corruption when loading the next file (pink or green lines throughout the image) briefly when preloading is active.'
I haven't been able to reliably reproduce the next file load crashing so far.
ryrynz is offline   Reply With Quote
Old 25th October 2015, 23:30   #3716  |  Link
Zachs
Suptitle, MediaPlayer.NET
 
Join Date: Nov 2001
Posts: 1,721
Well I can't seem to be able to replicate the crashing problem. Are you guys using the LAV Filters included with MPDN?
Zachs is offline   Reply With Quote
Old 25th October 2015, 23:37   #3717  |  Link
Anima123
Registered User
 
Join Date: Jun 2005
Posts: 504
In recent days I twiddled parameters around SuperRes, since I am not satisfied with the 'artificial' kind effect NNEDI3 produced.

Now I am quite satisfied with Super-xBR as image doubler with Edge Strength 1.00 and Sharpness 0.35, and without 'third pass', the SuperRes configured with the default parameters. Though not perfect, but it gives me natural and vivid images watching a movie from a fare distance.

Tried with other image doublers, some, e.g. the NNEDI3 may better closed look, yet the overall visual pleasure it brings is not as good as with the settings I mentioned.
Anima123 is offline   Reply With Quote
Old 25th October 2015, 23:45   #3718  |  Link
Zachs
Suptitle, MediaPlayer.NET
 
Join Date: Nov 2001
Posts: 1,721
Quote:
Originally Posted by burfadel View Post
So, the issue was definitely introduced in v1.22.0. I hope that makes it easier to track down what could be causing it!
This is strange. v1.22.0 was mainly about the playlist supporting URLs. When it crashes, do you get an error message?
Zachs is offline   Reply With Quote
Old 25th October 2015, 23:45   #3719  |  Link
burfadel
Registered User
 
Join Date: Aug 2006
Posts: 2,229
I was using the latest LAVFilters 0.66.0-31 which works perfectly with all other media players, and even all versions of MPDN with the extensions prior to v1.22.0. However, I just tried a fresh install of MPDN (clean install option) and extensions (same, clean install), installing the version of LAV Filters that came with MPDN. Same result, crash on changing media files.

Something between the extensions in v1.21.4 and v1.22.0 is causing the crash. Was the compile environment exactly the same for v1.21.4 and v1.22.0? Since it is such a specific fault (only with extensions v1.22.0 and later) and for me doesn't affect anything else, I still suspect the issue lies with one of the commits. It could either be the commit itself, or something in the commit that causes something in MPDN to go awry?

Is it possible for you to compile a few different test MPDN extensions omitting some of the different commits between v1.21.4 and v1.22.0 to see which commit is causing the issue?

Thanks
burfadel is offline   Reply With Quote
Old 25th October 2015, 23:47   #3720  |  Link
Zachs
Suptitle, MediaPlayer.NET
 
Join Date: Nov 2001
Posts: 1,721
Quote:
Originally Posted by christopherw View Post
Interesting player with some useful potential. Small footprint is a bonus.

I'm having unexpected results with interlaced content though - with identical LAV filter settings, using either DXVA or CUVID, it's not properly deinterlacing. Even with 50/60p enabled and attempting to force either just hardware or just Yadif software, and aggressively deinterlacing, everything is being blend deinterlaced.

The same video files, with MPC-HC and LAV configured identically, play perfectly.

I'm happy to communicate privately and send some example video files so you can attempt to replicate the issue if you wish, PM me through the board.
Could you cut a small section and post it somewhere so others could have a look at it too?
Zachs is offline   Reply With Quote
Reply

Tags
direct3d, mpdn, nnedi3, opencl, reclock

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 17:03.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.