Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old 12th April 2015, 11:46   #1741  |  Link
aufkrawall
Registered User
 
Join Date: Dec 2011
Posts: 1,812
Quote:
Originally Posted by huhn View Post
this is just my guess why this maybe isn't hardware related.

http://abload.de/img/directcomputegtugt.png

at least i remembered correctly.

edit: yeah i totally forgot. some people can't reach 24 FPS so they can't use dx9 <-> openCL for any realtime program. i call this a bug and i'm talking about GPU like r7 or r9 series.
Could you please relink that benchmark?
aufkrawall is offline   Reply With Quote
Old 12th April 2015, 11:59   #1742  |  Link
huhn
Registered User
 
Join Date: Oct 2012
Posts: 7,927
Quote:
Originally Posted by aufkrawall View Post
Could you please relink that benchmark?
doesn't work with nvidia.

if i remember correctly someone has written a version for nvidia(was it cyberbeing? sorry i can't remember) but yeah this is the original version from madshi from his server for AMD GPUs (works fine for intel).

i use it with every new AMD driver version just to see nothing has changed...

Last edited by huhn; 19th April 2015 at 16:44.
huhn is offline   Reply With Quote
Old 12th April 2015, 12:15   #1743  |  Link
aufkrawall
Registered User
 
Join Date: Dec 2011
Posts: 1,812
Thanks. Since I'm with NV, I hope that the author of the compatible version will read this or maybe someone else still has it.
aufkrawall is offline   Reply With Quote
Old 12th April 2015, 12:46   #1744  |  Link
Zachs
Suptitle, MediaPlayer.NET
 
Join Date: Nov 2001
Posts: 1,721
It's a synthetic benchmark, so don't read too much into the result.
Zachs is offline   Reply With Quote
Old 12th April 2015, 13:50   #1745  |  Link
huhn
Registered User
 
Join Date: Oct 2012
Posts: 7,927
and it's a copy benchmark the really important part is the processing that's done on the frame later at openCL.

but numbers like 37 fps slow some real problem...
huhn is offline   Reply With Quote
Old 12th April 2015, 13:53   #1746  |  Link
Zachs
Suptitle, MediaPlayer.NET
 
Join Date: Nov 2001
Posts: 1,721
I meant the Nvidia benchmark.
Zachs is offline   Reply With Quote
Old 12th April 2015, 13:58   #1747  |  Link
aufkrawall
Registered User
 
Join Date: Dec 2011
Posts: 1,812
With your benchmark 11, I'm getting 1278fps (GTX 980). Seems to be CPU limited. Cuda wrapper overhead?
aufkrawall is offline   Reply With Quote
Old 12th April 2015, 14:01   #1748  |  Link
Zachs
Suptitle, MediaPlayer.NET
 
Join Date: Nov 2001
Posts: 1,721
I think it's gpu memory bandwidth limited.
Zachs is offline   Reply With Quote
Old 12th April 2015, 14:16   #1749  |  Link
huhn
Registered User
 
Join Date: Oct 2012
Posts: 7,927
just run it with gpu-z.
huhn is offline   Reply With Quote
Old 12th April 2015, 14:24   #1750  |  Link
aufkrawall
Registered User
 
Join Date: Dec 2011
Posts: 1,812
I get lower fps when I have Process Hacker opened, which consumes CPU power. But probably it could also be due to its way of GPU polling?
It's definitely bandwidth limited. When I OC VRAM from 3.6 to 4.0Ghz, I get an increase to 1380fps.
aufkrawall is offline   Reply With Quote
Old 12th April 2015, 19:36   #1751  |  Link
patul
Registered User
 
Join Date: Sep 2005
Posts: 130
I get 164 fps for v11, AMD A6-5400K APU (HD 7540D). Haven't test on my laptop yet.
patul is offline   Reply With Quote
Old 13th April 2015, 04:02   #1752  |  Link
Zachs
Suptitle, MediaPlayer.NET
 
Join Date: Nov 2001
Posts: 1,721
Hi guys,

Thanks for all the help so far. I'd appreciate it if I could get you guys to run version 12 of the test app to see if it still runs and report back the new frame rate.

Thanks again!

Cheers.
Zachs is offline   Reply With Quote
Old 13th April 2015, 04:48   #1753  |  Link
Anima123
Registered User
 
Join Date: Jun 2005
Posts: 504
Test version 12 on Optimus (Intel HD 4600 + nVidia 880M), 249 fps, with previous version 9, the fps was 366.

Last edited by Anima123; 13th April 2015 at 04:52.
Anima123 is offline   Reply With Quote
Old 13th April 2015, 05:37   #1754  |  Link
cyberbeing
Broadband Junkie
 
Join Date: Oct 2005
Posts: 1,859
Quote:
Originally Posted by huhn View Post
doesn't work with nvidia.

if i remember correctly someone has written a version for nvidia(was it cyberbeing? sorry i can't remember).
At the time, all I did compile a build with DirectCompute-only so I could see the results on my NVIDIA card. I never attempted to fix the OpenCL tests. It doesn't appear I ever shared the DirectCompute-only build back then, so here it is if anyone wanted it: https://www.mediafire.com/?u6x778w7odoaqdi

It is somewhat reassuring to see that NVIDIA has made some improvements to DirectCompute performance improvements since then though. A nice +65% increase (172fps->285fps) in DirectCompute Error Diffusion performance with 350.05 compared to the 321.10 driver I initially tested one year ago. Still quite poor compared to AMD cards though, considering even madshi's HD7770 could break 300fps in that DirectCompute test.

Last edited by cyberbeing; 13th April 2015 at 06:05.
cyberbeing is offline   Reply With Quote
Old 13th April 2015, 05:44   #1755  |  Link
Anime Viewer
Troubleshooter
 
Anime Viewer's Avatar
 
Join Date: Feb 2014
Posts: 339
Quote:
Originally Posted by Zachs View Post
Hi guys,

Thanks for all the help so far. I'd appreciate it if I could get you guys to run version 12 of the test app to see if it still runs and report back the new frame rate.

Thanks again!

Cheers.
Version 12 gives 400-404 on my Optimus system.
__________________
System specs: Sager NP9150 SE with i7-3630QM 2.40GHz, 16 GB RAM, 64-bit Windows 10 Pro, NVidia GTX 680M/Intel 4000 HD optimus dual GPU system. Video viewed on LG notebook screen and LG 3D passive TV.
Anime Viewer is offline   Reply With Quote
Old 13th April 2015, 07:41   #1756  |  Link
ryrynz
Registered User
 
ryrynz's Avatar
 
Join Date: Mar 2009
Posts: 3,650
Zach, you need to clear your inbox.

750 Ti 440 FPS build 12, we've dropped some performance.

Last edited by ryrynz; 13th April 2015 at 07:50.
ryrynz is offline   Reply With Quote
Old 13th April 2015, 08:45   #1757  |  Link
burfadel
Registered User
 
Join Date: Aug 2006
Posts: 2,229
187.039 fps this time, AMD R9-280X.
burfadel is offline   Reply With Quote
Old 13th April 2015, 09:45   #1758  |  Link
aufkrawall
Registered User
 
Join Date: Dec 2011
Posts: 1,812
Gives me a performance gain with GTX 980, 1343fps.
aufkrawall is offline   Reply With Quote
Old 13th April 2015, 11:36   #1759  |  Link
Zachs
Suptitle, MediaPlayer.NET
 
Join Date: Nov 2001
Posts: 1,721
Quote:
Originally Posted by ryrynz View Post
750 Ti 440 FPS build 12, we've dropped some performance.
On my GTX 560, it's gone up from 640 to 716fps. On the Intel, it's gone up from 315fps to 370fps.
Zachs is offline   Reply With Quote
Old 13th April 2015, 11:55   #1760  |  Link
ryrynz
Registered User
 
ryrynz's Avatar
 
Join Date: Mar 2009
Posts: 3,650
Quote:
Originally Posted by Zachs View Post
On my GTX 560, it's gone up from 640 to 716fps. On the Intel, it's gone up from 315fps to 370fps.
*cough* 540 *cough*
ryrynz is offline   Reply With Quote
Reply

Tags
direct3d, mpdn, nnedi3, opencl, reclock

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 09:01.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.