Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 Encoder GUIs

Reply
 
Thread Tools Search this Thread Display Modes
Old 27th January 2024, 19:34   #9261  |  Link
StainlessS
HeartlessS Usurer
 
StainlessS's Avatar
 
Join Date: Dec 2009
Location: Over the rainbow
Posts: 10,980
Why not just use DGIndexNV to generate index, and also generate avs from template [with your tonemap/downscale/clean/sharpen/etc], and then use MeGUI on that avs to encode.
[Make your AVS template, and set it as default in DGIndexNV settings]

Below untested
MyDefaultDgIndexNV_Template.avs
Code:
# Below 3 lines __names__ filled in by DgIndexNV
VideoFileName   ="__vid__"
AudioFileName   =LCase("__aud__")
AudioDelay      =Value("__del__")
# ...
# example load code
Video = LWLibavVideoSource(VideoFileName)
Audio = LWLibavAudioSource (AudioFileName)
AudioDub(Video,Audio)
DelayAudio(AudioDelay)
Trim(0,0) # Chop/add audio, ensure same length as video
# ...
# + your code to tonemap/downscale/clean/sharpen/etc
# ...
Prefetch(SomeNumber)
Return Last#.ConvertToYV12 # MeGUI usually requires YV12
EDIT: DgIndexNV 251:- https://www.rationalqm.us/dgdecnv/binaries/
Maybe use current DgIndexNV as above instead of the one in MeGUI directories, copy file to index onto a DgIndexNV shortcut on Desktop,
and press F4 to index. [after setting default template, in settings]
__________________
I sometimes post sober.
StainlessS@MediaFire ::: AND/OR ::: StainlessS@SendSpace

"Some infinities are bigger than other infinities", but how many of them are infinitely bigger ???

Last edited by StainlessS; 27th January 2024 at 20:00.
StainlessS is offline   Reply With Quote
Old 31st January 2024, 19:40   #9262  |  Link
LouieChuckyMerry
Registered User
 
LouieChuckyMerry's Avatar
 
Join Date: Feb 2014
Posts: 355
StainlessS: Originally I did as you suggest but quickly discovered that the encoding time for a single script with everything was about four times greater than the encoding time for a tonemap-downscale-to-lossless script followed by a clean-sharpen-shrivel script. Of course, some would argue, not necessarily incorrectly, that downscaling before cleaning-sharpening leads to a lower quality encode. Hmmm, maybe I'll test tonemaping-to-lossless then cleaning-downscaling-sharpening-shriveling. Thanks for your input .

Last edited by LouieChuckyMerry; 31st January 2024 at 19:45. Reason: Order
LouieChuckyMerry is offline   Reply With Quote
Old 21st February 2024, 21:22   #9263  |  Link
kalehrl
Registered User
 
Join Date: Feb 2011
Posts: 331
What tools can be updated safely without breaking MeGUI?
kalehrl is offline   Reply With Quote
Old 21st February 2024, 21:30   #9264  |  Link
LigH
German doom9/Gleitz SuMo
 
LigH's Avatar
 
Join Date: Oct 2001
Location: Germany, rural Altmark
Posts: 6,781
All of the EXE encoders which did not change their command line interface to an incompatible syntax.

And MeGUI x64 is surely the better choice to keep up with the development of Avisynth+ and its plugins.
__________________

New German Gleitz board
MediaFire: x264 | x265 | VPx | AOM | Xvid
LigH is offline   Reply With Quote
Old 21st March 2024, 23:32   #9265  |  Link
diavliyo
Registered User
 
Join Date: Jun 2014
Posts: 3
Quote:
[Error] Unhandled error
--[Information] [21/03/2024 16:02:17] Exception message
---[NoImage] No se puede obtener acceso al objeto desechado.
---[NoImage] Nombre del objeto: 'VideoPlayer'.
--[Information] [21/03/2024 16:02:17] Stacktrace
---[NoImage] en System.Windows.Forms.Control.CreateHandle()
---[NoImage] en System.Windows.Forms.Form.CreateHandle()
---[NoImage] en System.Windows.Forms.Control.get_Handle()
---[NoImage] en MeGUI.VideoPlayer.SetMaxZoomWidth() en D:\MeGUI\_MeGUI_clean\core\gui\VideoPlayer.cs:línea 374
---[NoImage] en MeGUI.VideoPlayer.LoadVideo(String path, PREVIEWTYPE type, Boolean hasAR, Boolean inlineAvs, Int32 startFrame, Boolean originalSize) en D:\MeGUI\_MeGUI_clean\core\gui\VideoPlayer.cs:línea 170
---[NoImage] en MeGUI.AviSynthWindow.previewButton_Click(Object sender, EventArgs e) en D:\MeGUI\_MeGUI_clean\packages\tools\avscreator\AviSynthWindow.cs:línea 218
---[NoImage] en System.Windows.Forms.Control.OnClick(EventArgs e)
---[NoImage] en System.Windows.Forms.Button.OnClick(EventArgs e)
---[NoImage] en System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
---[NoImage] en System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
---[NoImage] en System.Windows.Forms.Control.WndProc(Message& m)
---[NoImage] en System.Windows.Forms.ButtonBase.WndProc(Message& m)
---[NoImage] en System.Windows.Forms.Button.WndProc(Message& m)
---[NoImage] en System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
---[NoImage] en System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
---[NoImage] en System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
--[Information] [21/03/2024 16:02:17] Inner exception: null
sorry hehehehe you're right, I forgot the translator,
I was wondering about the error I present below. The megui does not load and gives me a video player error. Could someone or know how to tell me if it is because I need to update or install something?

Last edited by diavliyo; 22nd March 2024 at 10:20.
diavliyo is offline   Reply With Quote
Old 22nd March 2024, 02:08   #9266  |  Link
frobber
Registered User
 
frobber's Avatar
 
Join Date: Sep 2023
Posts: 1
Hi,

I've been trying to use MeGUI to deinterlace some video using QTGMC.

My script seems to work as I can play the video, but whenever I click AutoEncode, MeGUI waits a little and then crashes.

I don't see anything obvious in the log file (linked below).

I've used MeGUI for other projects (not deinterlacing), so I think the installation is basically OK.

How can I troubleshoot this? Is there something like the AviSynth Info Tool for MeGUI?

Thanx

MeGUI log file: https://www.sendspace.com/file/cyutix
frobber is offline   Reply With Quote
Old 22nd March 2024, 02:48   #9267  |  Link
TDS
Formally known as .......
 
TDS's Avatar
 
Join Date: Sep 2021
Location: Down Under.
Posts: 994
Quote:
Originally Posted by diavliyo View Post
hola a todos. disculpad por que no se si este es el sitio correcto para esto. pero desde hace un par de dias que reinstale megui me sale este problema

decir que me meguie me busca algo en el disco local D y nunca he tenido nada instalado alli,
queria saber si es que me falta algo por instalar por si me podrian decir que es
ENGLISH, please.

Translated....

Hello everyone. Sorry I don't know if this is the right place for this. But since a couple of days ago I reinstalled Megui I got this problem

To say that I was looking for something on the local disk D and I have never had anything installed there,
I wanted to know if I have something missing to install in case you could tell me what it is.

https://forum.doom9.org/showthread.p...444#post841444

https://www.videohelp.com/software/MeGUI

https://sourceforge.net/projects/megui/
__________________
Long term RipBot264 user.

RipBot264 modded builds..

Last edited by TDS; 22nd March 2024 at 03:01.
TDS is offline   Reply With Quote
Old 22nd March 2024, 10:12   #9268  |  Link
diavliyo
Registered User
 
Join Date: Jun 2014
Posts: 3
sorry hehehehe you're right, I forgot the translator,
I was wondering about the error I present below. The megui does not load and gives me a video player error. Could someone or know how to tell me if it is because I need to update or install something?
diavliyo is offline   Reply With Quote
Old 22nd March 2024, 10:22   #9269  |  Link
diavliyo
Registered User
 
Join Date: Jun 2014
Posts: 3
Quote:
Originally Posted by diavliyo View Post
sorry hehehehe you're right, I forgot the translator,
I was wondering about the error I present below. The megui does not load and gives me a video player error. Could someone or know how to tell me if it is because I need to update or install something?


Sorry and thank you for moving the post to the correct place. Does anyone know why this error?
diavliyo is offline   Reply With Quote
Old 22nd March 2024, 10:56   #9270  |  Link
tebasuna51
Moderator
 
tebasuna51's Avatar
 
Join Date: Feb 2005
Location: Spain
Posts: 6,915
If there are references to a drive D: better make a new install (now 64 bits recommended) in a folder out of windows system, recommended C:\Portable\MeGUI
After:
Options -> Extended -> Use development update server
Tools -> Update -> Show all packages (enable and update all)
__________________
BeHappy, AviSynth audio transcoder.
tebasuna51 is online now   Reply With Quote
Reply

Tags
megui

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 09:40.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.