Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 2nd November 2009, 12:08   #10321  |  Link
Spec-Chum
Registered User
 
Join Date: Jan 2009
Posts: 60
Quote:
Originally Posted by boyumeow View Post
MPC-HC 1326

Изменения/Changes:

* CHANGED: Allow screensaver to activate when audio only (sleep is still stopped).;


Hi, I need someone to confirm that the above status not only allow screensaver to activate when audio only but happens when video too. Thanks.
Screensaver is still stopped when video is active. It will only activate when mpc-hc is playing only audio.
Spec-Chum is offline  
Old 2nd November 2009, 12:30   #10322  |  Link
boyumeow
Registered User
 
boyumeow's Avatar
 
Join Date: Aug 2007
Posts: 143
@Spec-Chum,
Sorry for not being clear, I mean in full screen mode but not D3D mode. I did get screen saver activated when playing .avi, but it did not happens on previous mpc-hc. I did not change any status, so I'm not sure what went wrong too. I will try out the previous version again before I report again. Thanks.

Edit: Yes, I have confirm mpc-hc1326 kick-in screen saver in my case while mpc-hc1323 did not during full-screen (not sure about window mode as I did not check). Can any1 double confirm its just me or any1 else is getting it. Thanks.

Last edited by boyumeow; 2nd November 2009 at 14:53.
boyumeow is offline  
Old 2nd November 2009, 13:14   #10323  |  Link
tetsuo55
MPC-HC Project Manager
 
Join Date: Mar 2007
Posts: 2,317
@Everyone about DXVA and subtitles.

DXVA and subtitles officially only works when you use the internal subtitle renderer in combination with an internal DXVA decoder.
We know that for some people different combinations of subtitle renderer and DXVA do work, these combinations are however not officially supported.

If anyone has any detailed information, on how to improve the internal subtitle renderer to further improve the DXVA/Subtitle compatibility please provide us with a patch or detailed technical description

Quote:
Originally Posted by Snowknight26 View Post
When no DX9 compatible device (no video card) is installed in a machine running MPC-HC, several errors are throw:

EVR: CreateDevice failed, DX9AllocatorPresenter failed, D3DERR_NOTAVAILABLE
VMR9: CreateDevice failed, D3DERR_NOTAVAILABLE
VMR7: No video
Overlay: No video
Old renderer: Crash <-- shouldn't happen
System default (Video Renderer): No video

Should at least get video as it works fine in graphedit using Video Renderer.
Hello, its unfortunate that you got these results.
At this time we are only developing EVR-CP and VMR9-renderless, both depend on drawing a DirectX surface directly to the videocard, if the surface can not be created it will give you the errors you have reported.

It would be a good idea if someone could fix the cause of the crash in the old renderer (since its basically software based) and then applied a patch that would cause any failure of VMR9-R or EVR-CP to fall back to the old renderer.
__________________
MPC-HC, an open source project everyone can improve. Want to help? Test Nightly Builds, submit patches or bugs and chat on IRC

Last edited by tetsuo55; 2nd November 2009 at 13:47.
tetsuo55 is offline  
Old 2nd November 2009, 15:06   #10324  |  Link
tetsuo55
MPC-HC Project Manager
 
Join Date: Mar 2007
Posts: 2,317
Compiling news:

I have done some research, and it looks like MinGW64 can completely replace MinGW32.

It works on 32 and 64 bit hosts and can compile both the 32 and 64 bit build of mpc-hc (and probably the same for ffdshow)
It is already used to build a lot of other programs this way.

Available here: http://www.cadforte.com/downloads.html

it offers a choice between msys and cygwin, not sure which one is best for us?

Also, for x64 hosts they offer x64native compiling which should speed up the compiling time considerably.
__________________
MPC-HC, an open source project everyone can improve. Want to help? Test Nightly Builds, submit patches or bugs and chat on IRC
tetsuo55 is offline  
Old 2nd November 2009, 15:21   #10325  |  Link
hoborg
Registered User
 
Join Date: Nov 2008
Posts: 454
Quote:
Originally Posted by gngn View Post
admittedly, "that" graph was pretty much pointless
i put up a new screenshot to show that DVD-subs + DXVA (in my case mpeg2-IDCT) works on XP. dunno about win7 thou
Yep, working without any problem (navigation too), but WinXP only (no go on Vista/Win7)
__________________
Working machine: Win10x64 + Intel Skull Canyon
My HTPC.

How to start with Bitcoin
hoborg is offline  
Old 2nd November 2009, 15:25   #10326  |  Link
namaiki
Registered User
 
Join Date: Sep 2009
Location: Sydney, Australia
Posts: 1,073
Quote:
Originally Posted by tetsuo55 View Post
If anyone has any detailed information, on how to improve the internal subtitle renderer to further improve the DXVA/Subtitle compatibility please provide us with a patch or detailed technical description
I don't think this is what you meant, but would it be possible to make a setting where the subtitles texture resolution is the same resolution as the video?

For example, if I select 'Subtitles -> 'Maximum texture resolution' as 'Desktop', it will renderer subtitles in full screen at 1280x800 even though the video is 1280x720, that would be fine, however, sometimes there is positional text (eg signs), which will only render correctly over the video if the subtitle canvas is rendered over 1280x720 pixels (ie exactly over the video), and so it ends up that the sign is positioned either too low or too high compared to if it were being rendered by for example, the DirectVobSub external filter.
namaiki is offline  
Old 2nd November 2009, 16:15   #10327  |  Link
gngn
the hedgehog
 
gngn's Avatar
 
Join Date: Apr 2008
Posts: 163
Quote:
Originally Posted by namaiki View Post
... and so it ends up that the sign is positioned either too low or too high compared to if it were being rendered by for example, the DirectVobSub external filter.
check the option "Position subtitles relative to the video frame" under "Subtitles - Default Style".
__________________
Athlonx2@2,9Ghz,2G DDRAM2@800Mhz,WinXPSP3 x86,GF8600GTS-256M,Nvidiadrivers 295.73
latest MPC-HC (MVS2010 SP1, GCC 4.7.1)
VMR9renderless+VMR9MixerMode+YUVMixing,VSync+AccurateVSync,all GPUflushes on
gngn is offline  
Old 2nd November 2009, 16:54   #10328  |  Link
Polcius
Registered User
 
Join Date: Aug 2009
Posts: 102
Quote:
Originally Posted by tetsuo55 View Post
@Everyone about DXVA and subtitles.

DXVA and subtitles officially only works when you use the internal subtitle renderer in combination with an internal DXVA decoder.
We know that for some people different combinations of subtitle
Ok. But is there a way to force DXVA (other than selecting auto-load subtitles and EVRCP in the options).

It's weird because in PowerDVD9, DXVA+Subtitles works, but it has a bug where some subtitle lines don't show up. Very annoying. I'm just asking these questions about DXVA because it's the only way I've found to get a PERFECT deinterlacing (using Ati Avivo).
Polcius is offline  
Old 2nd November 2009, 17:23   #10329  |  Link
Snowknight26
Registered User
 
Join Date: Aug 2007
Posts: 1,397
MPC-HC displays video track information incorrectly:


Quote:
C:\unzipped\eac3to>eac3to.exe "D:" 1)
M2TS, 3 video tracks, 7 audio tracks, 5 subtitle tracks, 1:39:27, 24p /1.001
1: Chapters, 37 chapters
2: h264/AVC, 1080p24 /1.001 (16:9)
3: h264/AVC, 480p24 /1.001 (15:11)
4: h264/AVC, 480p24 /1.001 (20:11)
5: DTS Master Audio, English, 5.1 channels, 24 bits, 48khz
(core: DTS, 5.1 channels, 24 bits, 1509kbps, 48khz)
6: DTS, Spanish, 5.1 channels, 24 bits, 768kbps, 48khz
7: DTS, French, 5.1 channels, 24 bits, 768kbps, 48khz
8: AC3 Surround, English, 2.0 channels, 192kbps, 48khz, dialnorm: -27dB
9: AC3 Surround, English, 2.0 channels, 192kbps, 48khz, dialnorm: -27dB
10: AC3 Surround, English, 2.0 channels, 192kbps, 48khz, dialnorm: -27dB
11: AC3 Surround, English, 2.0 channels, 192kbps, 48khz, dialnorm: -27dB
12: Subtitle (PGS), English
13: Subtitle (PGS), Spanish
14: Subtitle (PGS), French
15: Subtitle (PGS), Spanish
16: Subtitle (PGS), French
Snowknight26 is offline  
Old 2nd November 2009, 18:40   #10330  |  Link
Casimir666
Registered User
 
Join Date: Jan 2007
Posts: 455
Quote:
Originally Posted by tetsuo55 View Post
DXVA and subtitles offically only works when you use the internal subtitle renderer in combination with an internal DXVA decoder.

If a subtitling filter is connected between video decoder and renderer, DXVA cannot works. This limitation is caused by DXVA design, and cannot be changed. Only internal subtitle engine can works, because in this configuration subtitles are display by renderer (VRM9 renderless or EVR custom) and not by an intermediate filter.
__________________
Tired of tearing?
Try this Media Player Classic mod : http://mpc-hc.sourceforge.net
Casimir666 is offline  
Old 2nd November 2009, 19:32   #10331  |  Link
tetsuo55
MPC-HC Project Manager
 
Join Date: Mar 2007
Posts: 2,317
Quote:
Originally Posted by Polcius View Post
Ok. But is there a way to force DXVA (other than selecting auto-load subtitles and EVRCP in the options).

It's weird because in PowerDVD9, DXVA+Subtitles works, but it has a bug where some subtitle lines don't show up. Very annoying. I'm just asking these questions about DXVA because it's the only way I've found to get a PERFECT deinterlacing (using Ati Avivo).
Every application is only able to DXVA+Subtitles using their own decoder and renderer. (although some people do get lucky with other combinations, like the XP example above)
Quote:
Originally Posted by Snowknight26 View Post
MPC-HC displays video track information incorrectly:
The internal splitter does not support multiple video streams at all, wierd behaviour is expected as it does try to do something with it.
Quote:
Originally Posted by Casimir666 View Post

If a subtitling filter is connected between video decoder and renderer, DXVA cannot works. This limitation is caused by DXVA design, and cannot be changed. Only internal subtitle engine can works, because in this configuration subtitles are display by renderer (VRM9 renderless or EVR custom) and not by an intermediate filter.
Which is exactly what i said
__________________
MPC-HC, an open source project everyone can improve. Want to help? Test Nightly Builds, submit patches or bugs and chat on IRC

Last edited by tetsuo55; 2nd November 2009 at 20:10.
tetsuo55 is offline  
Old 2nd November 2009, 21:02   #10332  |  Link
Jong
Registered User
 
Join Date: Mar 2007
Location: London, UK
Posts: 576
Quote:
Originally Posted by Polcius View Post
Ok. But is there a way to force DXVA (other than selecting auto-load subtitles and EVRCP in the options).

It's weird because in PowerDVD9, DXVA+Subtitles works, but it has a bug where some subtitle lines don't show up. Very annoying. I'm just asking these questions about DXVA because it's the only way I've found to get a PERFECT deinterlacing (using Ati Avivo).
Yes, we really need a built in MPEG2 decoder that supports HA deinterlacing (and preferably other DXVA acceleration too, although that is less important these days). This is stopping me moving to W7 right now as the Cyberlink decoder works with subtitles/DVD menus in XP, but not Vista/W7 (as I understand it).

Last edited by Jong; 2nd November 2009 at 21:04.
Jong is offline  
Old 2nd November 2009, 21:41   #10333  |  Link
THX-UltraII
Registered User
 
Join Date: Aug 2008
Location: the Netherlands
Posts: 850
question about MPC-HC:

When I play a BD structure folder subtitles can be selected (with Haali splitter) however, they are not displayed. What could be wrong?
THX-UltraII is offline  
Old 2nd November 2009, 23:20   #10334  |  Link
Polcius
Registered User
 
Join Date: Aug 2009
Posts: 102
Quote:
Originally Posted by Jong View Post
Yes, we really need a built in MPEG2 decoder that supports HA deinterlacing (and preferably other DXVA acceleration too, although that is less important these days). This is stopping me moving to W7 right now as the Cyberlink decoder works with subtitles/DVD menus in XP, but not Vista/W7 (as I understand it).
I totally agree.

Maybe I should create an XP partition...
Polcius is offline  
Old 3rd November 2009, 07:54   #10335  |  Link
Lincoln Burrows
Registered User
 
Lincoln Burrows's Avatar
 
Join Date: Mar 2008
Posts: 280
I hate when this sort of thing happens... and now it's not only limited to MPC, but other players as well.

Here's the situation: I tested the M2TS from one of CSI: LA (Blu-ray) episodes and MPC-HC is always using this filter to play those files which are using VC-1:

How to stop using WMVideo decoder DMO?

And worst than that, even if I disable those Windows filters, the M2Ts files will not run. I tried several combinations, and also tried to force the external/internal filters from MPC-HC, ffdshow, Haali, etc.

Nothing seems to make those M2TS work (a black screen is what you get), except for adding the WMVideo decoder DMO as a new filter (that's right, we need to add) in the MPC-HC External Filter's section.
__________________
"Whoever has not known himself has known nothing. But whoever has known himself has simultaneously achieved knowledge about the depth of all things."

Last edited by Lincoln Burrows; 3rd November 2009 at 08:22.
Lincoln Burrows is offline  
Old 3rd November 2009, 08:30   #10336  |  Link
tmbt
Registered User
 
Join Date: Oct 2009
Posts: 11
Polcius :

In ati Avivo settings try to remove the flag on "useautomatic deinteralacing" and select manually a deinterlacing method. Works great for me and i don't need dxva anymore.
tmbt is offline  
Old 3rd November 2009, 09:47   #10337  |  Link
Andy o
Registered User
 
Join Date: Mar 2009
Posts: 940
Quote:
Originally Posted by THX-UltraII View Post
question about MPC-HC:

When I play a BD structure folder subtitles can be selected (with Haali splitter) however, they are not displayed. What could be wrong?
As far as I understand, you need to use the internal TS splitter and the internal sub renderer for them to work.
Andy o is offline  
Old 3rd November 2009, 09:52   #10338  |  Link
THX-UltraII
Registered User
 
Join Date: Aug 2008
Location: the Netherlands
Posts: 850
Quote:
Originally Posted by Andy o View Post
As far as I understand, you need to use the internal TS splitter and the internal sub renderer for them to work.
How do I use the internal TS Splitter and the internal sub renderer?
THX-UltraII is offline  
Old 3rd November 2009, 09:53   #10339  |  Link
Lincoln Burrows
Registered User
 
Lincoln Burrows's Avatar
 
Join Date: Mar 2008
Posts: 280
As far as I know, Haali can't display those subtitles, it's returning all sorts of errors, I don't know why. You need to activate VMR 7 or 9 renderless in the MPC-HC internal settings to display them.

Also, try to force MPC-HC to use ffdshow Video Decoder instead of Haali's, if that tip doesn't help.

P.S. Regarding my previous post, this is the first time I am seeing a M2TS file that is requiring me to disable VC1 (ffmpeg) and only use WMVideo decoder DMO. I tested other movies and they played fine, even the ones who used VC-1. Is there something wrong with some of them? This is really strange. And TMT is the only player that is not having any lag while playing this BD project, even when displaying subtitles. I heard somewhere that enabling VMR 7/9 renderless is requiring too much from the video card? Mine is NVidia 8800 GTS 512 MB, plus a Q9450/2GB RAM/XP SP3 system.
__________________
"Whoever has not known himself has known nothing. But whoever has known himself has simultaneously achieved knowledge about the depth of all things."

Last edited by Lincoln Burrows; 3rd November 2009 at 09:58.
Lincoln Burrows is offline  
Old 3rd November 2009, 10:05   #10340  |  Link
THX-UltraII
Registered User
 
Join Date: Aug 2008
Location: the Netherlands
Posts: 850
Quote:
As far as I know, Haali can't display those subtitles, it's returning all sorts of errors, I don't know why. You need to activate VMR 7 or 9 renderless in the MPC-HC internal settings to display them.
So by using VMR9 instead of EVR Custom MPC-HC can show the subtitles of a BD folder AND still use Haali Splitter?

Quote:
Also, try to force MPC-HC to use ffdshow Video Decoder instead of Haali's, if that tip doesn't help
I use noth ffdshow Video Decoder and Haali auto-loads. What do you mean exactly?
THX-UltraII is offline  
Closed Thread

Tags
dxva, h264, home cinema, media player classic, mpc-hc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 15:43.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.