Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 AVC / H.264

Reply
 
Thread Tools Search this Thread Display Modes
Old 22nd March 2015, 11:23   #1  |  Link
pcroland
Registered User
 
Join Date: Mar 2014
Location: Hungary
Posts: 115
x264 encoding error. Should I ignore it?

Hi! I demuxed a few m2ts files with tsMuxer to .264 files and I wanted to encode them. When I encode them with x264 I get error messages continuously but the encoded video looks well.
Quote:
...
[h264 @ 0x20a2a00] non-existing SPS 1 referenced in buffering period
[h264 @ 0x20a1880] non-existing SPS 1 referenced in buffering period
[h264 @ 0x20a5aa0] non-existing SPS 1 referenced in buffering period
[h264 @ 0x20a1880] non-existing SPS 1 referenced in buffering period
[h264 @ 0x20a6220] non-existing SPS 1 referenced in buffering period
[h264 @ 0x20a1880] non-existing SPS 1 referenced in buffering period
[h264 @ 0x20a69a0] non-existing SPS 1 referenced in buffering period
[h264 @ 0x20a1880] non-existing SPS 1 referenced in buffering period
...
So what should I do?
pcroland is offline   Reply With Quote
Old 22nd March 2015, 22:48   #2  |  Link
LoRd_MuldeR
Software Developer
 
LoRd_MuldeR's Avatar
 
Join Date: Jun 2005
Location: Last House on Slunk Street
Posts: 13,248
I'm pretty sure that this is actually a decoding error (warning) and that the message originates from the FFmpeg/libavcodec decoder that is included with x264.

As long as you cannot spot any glitches, there probably isn't much reason to be concerned. The H.264 bitstream created by x264 should be perfectly fine, regardless of the decoding issues!

Anyway, you could try a different method for feeding the M2TS file into x264. What about using DGDecodeNV? Or, if that is not an option, LSMASHSource?
__________________
Go to https://standforukraine.com/ to find legitimate Ukrainian Charities 🇺🇦✊

Last edited by LoRd_MuldeR; 22nd March 2015 at 23:58.
LoRd_MuldeR is offline   Reply With Quote
Old 23rd March 2015, 21:04   #3  |  Link
pcroland
Registered User
 
Join Date: Mar 2014
Location: Hungary
Posts: 115
Well, I tried to encode the video without demuxing and now there is no error message I didn't know that I could easily encode it without demux the video Thanks for the answer
pcroland is offline   Reply With Quote
Reply

Tags
tsmuxer, x264

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 10:27.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.