Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > (HD) DVD, Blu-ray & (S)VCD > (HD) DVD & Blu-ray authoring

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 4th February 2016, 14:51   #11  |  Link
slavanap
Registered User
 
slavanap's Avatar
 
Join Date: May 2011
Location: Moscow, Russia
Posts: 126
Quote:
Originally Posted by r0lZ View Post
Right. I did a test, and my method doesn't work.

[EDIT] Just tested with your method and it doesn't work either. The computer goes to sleep when it is encoding. I'm puzzled.

[EDIT2] Tried again today, because yesterday Windows Update was working in the background, and it may have influenced the result, but I have the same result now. The computer goes to sleep anyway. So, it appears that either BlockSleep doesn't work, or there is something special with cmd.exe. Could it be because cmd.exe is loaded from system32 and is therefore a 64-bit program, but the main x264 process is 32-bit? Anyway, the CMD window is not closed, so I assume that its process remains active, and BlockSleep should work. I don't understand.
Well, let's figure that out. I guess, this info will be useful to other users that's why I post in in the thread instead PMing you.

Please, run "powercfg -requests" under administrator 2 times (when blocksleep is running and when it's not) and post its output or PM it to me. "powercfg -requests" shows what processes/drivers/etc. blocks computer to go sleep. Moreover, if you're using a notebook, then go to "Explorer -> right click Computer -> Manager -> expand Event Viewer -> Windows Logs -> System" and see if there're recent messages with source UserModePowerService coming and what process generates them. Note, when this message appears, then sleep timer resets, so your computer may never go to sleep or go to sleep by explicit external call (which still logs in Event Log). Usually, some third-party notebook related programs can influence Windows power settings behavior.

[ADDED] I have this output (first is for running blocksleep, second if it's not running). Btw, don't forget to check your selected power plan settings.
P.S. Here's a thread @ sevenforums that shows how to deal with issue when auto sleep does not work.


Last edited by slavanap; 4th February 2016 at 15:08.
slavanap is offline  
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 15:40.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.