Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > Avisynth Usage

Reply
 
Thread Tools Search this Thread Display Modes
Old 10th March 2010, 18:32   #1  |  Link
teeman
TEEMAN
 
Join Date: Mar 2010
Location: Canada
Posts: 3
Coded avs file errors

Can anybody help me with this error I get when trying to open the avs file in Virtual dub.

I have pasted my error below. I am not familiar with coding I believe I typed everything as it should if not could you please advise or send me to the proper help link

I run Win 7 64 bit
Adobe premier cs3
virtual dub
dbug frame server


aviSource("tomspractice.avi")
FlipHorizontal
greyscale

I get the following error

Virtual Dub Error

Avisynth open failure
avisource autodetect: couldn't open file "tomspractice.avi"
error code 2

(F:\manitougreenscreen\VIDEO\tomspractise.avs, line 1)

The beginning lesson would not open in wmp following your script

Teeman
teeman is offline   Reply With Quote
Old 10th March 2010, 19:35   #2  |  Link
osgZach
Registered User
 
Join Date: Feb 2009
Location: USA
Posts: 680
Never seen this error before, so just a stab in the dark:

Do you know what codec the video is encoded in? (AVI is a container, it could be Xvid, DivX, etc)

If you know what codec the video is encoded in, then you should find out whether or not you have the proper codec tools installed so you can decode it.
osgZach is offline   Reply With Quote
Old 10th March 2010, 21:33   #3  |  Link
IanB
Avisynth Developer
 
Join Date: Jan 2003
Location: Melbourne, Australia
Posts: 3,173
error code 2 = ERROR_FILE_NOT_FOUND

"tomspractice.avi" is not found in the same directory as "F:\manitougreenscreen\VIDEO\tomspractise.avs"
IanB is offline   Reply With Quote
Old 10th March 2010, 23:49   #4  |  Link
osgZach
Registered User
 
Join Date: Feb 2009
Location: USA
Posts: 680
haha wow.. how did I even miss that
osgZach is offline   Reply With Quote
Old 11th March 2010, 01:30   #5  |  Link
teeman
TEEMAN
 
Join Date: Mar 2010
Location: Canada
Posts: 3
Quote:
Originally Posted by IanB View Post
error code 2 = ERROR_FILE_NOT_FOUND

"tomspractice.avi" is not found in the same directory as "F:\manitougreenscreen\VIDEO\tomspractise.avs"
I feel so stupid I will retry and again I apologize, I never noticed it.

Thanks Teeman
teeman is offline   Reply With Quote
Old 11th March 2010, 01:44   #6  |  Link
osgZach
Registered User
 
Join Date: Feb 2009
Location: USA
Posts: 680
Don't sweat it, we all goof up on silly stuff sometimes
osgZach is offline   Reply With Quote
Old 11th March 2010, 05:06   #7  |  Link
teeman
TEEMAN
 
Join Date: Mar 2010
Location: Canada
Posts: 3
Same Error correct spelling

Quote:
Originally Posted by IanB View Post
error code 2 = ERROR_FILE_NOT_FOUND

"tomspractice.avi" is not found in the same directory as "F:\manitougreenscreen\VIDEO\tomspractise.avs"
I redid and got the same error, any ideas

Teeman
teeman is offline   Reply With Quote
Old 11th March 2010, 12:00   #8  |  Link
Gavino
Avisynth language lover
 
Join Date: Dec 2007
Location: Spain
Posts: 3,413
Is the avi file in the same directory (folder) as the script file? If not, you will need to use the full path name.
Gavino is offline   Reply With Quote
Old 12th March 2010, 22:10   #9  |  Link
rkalwaitis
Robert
 
Join Date: Jan 2008
Location: Stuttgart
Posts: 407
Your not telling avisynth where the file is.
rkalwaitis is offline   Reply With Quote
Reply

Tags
avisynth, editing, errors, script, video

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 11:23.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.