Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 AVC / H.264

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 5th September 2013, 13:57   #1  |  Link
ff58
Registered User
 
Join Date: Sep 2012
Posts: 6
H.264 NAL Unit start code inside SEI

Hi,

We have problem related to the NAL unit start code (00 00 00 01 or 00 00 01) when found inside User-data unregistered SEI data.

At the decoder side, if the start code is found inside SEI, the decoder supposes that this is a new NAL unit and so this causes a problem. There is nothing inside h.264 specification related to this subject.

My questions are;
1) Is it possible that the SEI packets can include start code indicator? or NOT?
2) If it is forbidden to insert a start code inside SEI, what should we do? Do we need to re-encode that portion of data?
3) Or anything else?

Thank you for your support.

Fikret
ff58 is offline   Reply With Quote
 

Tags
h.264 encoder, nalu, sei

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 01:32.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.