Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Announcements and Chat > General Discussion

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 12th February 2024, 15:26   #1  |  Link
VoodooFX
Banana User
 
VoodooFX's Avatar
 
Join Date: Sep 2008
Posts: 989
FFmpeg arnndn filter has bugs?

Test files: https://we.tl/t-TrGUOgj5IN

Command:
Code:
ffmpeg.exe -i out-full.wav -filter_complex [0:a]arnndn=m=sh.rnnn[s0] -map [s0] out-full.sh.wav
Original:


1 case) Spectrograms of result look exactly same on i5-2500M and i7-13700K:


2 case) But for i7-8700K and Ryzen 5 5500 results look like this [both have similar look, but not same]:


Anyone knows what is going on? Or how to debug it?

I tried:
Code:
ffmpeg.exe -i out-full.wav -filter_complex [0:a]arnndn=m=sh.rnnn[s0] -map [s0] o_0.wav -cpuflags 0
For "1" case it didn't had influence, for "2" case it produced ~slightly different spectrograms.

Tried FFmpeg v5.1.2 vs v6.1.1, no influence on "1" case, for "2" case spectrograms ~slightly different.

Last edited by VoodooFX; 12th February 2024 at 15:29.
VoodooFX is offline   Reply With Quote
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 17:46.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.