Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old 28th January 2015, 14:29   #1  |  Link
Lebowsky
Registered User
 
Join Date: Apr 2007
Posts: 66
Need help getting rid of horizontal tearing in video playback

Hello,

I have to different computers, both of which have tearing problem during video playback.

First one is my workhorse pc. i4770, Geforce GTX770, Eizo CX240 monitor. I play videos with MPC-HC and madVR. I don't have tearing when watching videos in fullscreen, but I do have tearing when they are played in windowed mode, at the video native size. I also have tearing when watching online flash content, fullscreen or not.

Second one is an Asus Eeepc 1215N netbook. With this one it seems tearing started to appear after upgrading all drivers (video card, chipset, etc). Tearing appears both in windowed and fullscreen mode. I use MPC-HC, I tried all different rendering modes but nothing helps. This PC is not powerful enough to use madVR.

Any ideas?
Lebowsky is offline   Reply With Quote
Old 28th January 2015, 16:30   #2  |  Link
huhn
Registered User
 
Join Date: Oct 2012
Posts: 7,512
did you disable aero?

aero handles the Vsync on vista and new so it shouldn't be disabled completely .
huhn is offline   Reply With Quote
Old 28th January 2015, 17:00   #3  |  Link
hello_hello
Registered User
 
Join Date: Mar 2011
Posts: 4,698
For some reason using Bicubic resizing in MPC-HC causes tearing for me when displaying video on my TV. Bilinear doesn't. I've no idea why but obviously it only happens when video is resized. It's an old Nvidia card (Windows XP) but it copes with MadVR's default settings (although I don't normally use MadVR).

Other than that, have you tried Reclock? It mightn't fix the tearing, but you never know.
hello_hello is offline   Reply With Quote
Old 28th January 2015, 17:53   #4  |  Link
Lebowsky
Registered User
 
Join Date: Apr 2007
Posts: 66
yeah, Aero is disabled. I hate that desktop. I use classic theme with classic shell and 7+ Taskbar Tweaker. Both computers use windows 7.

Pretty "funny" that such videos were playing fine on XP but that win7 has issues...

I'll look into Reclock for the Netbook, thanks!

Last edited by Lebowsky; 28th January 2015 at 17:57.
Lebowsky is offline   Reply With Quote
Old 28th January 2015, 18:07   #5  |  Link
huhn
Registered User
 
Join Date: Oct 2012
Posts: 7,512
Quote:
Originally Posted by Lebowsky View Post
yeah, Aero is disabled. I hate that desktop. I use classic theme with classic shell and 7+ Taskbar Tweaker. Both computers use windows 7.

Pretty "funny" that such videos were playing fine on XP but that win7 has issues...

I'll look into Reclock for the Netbook, thanks!
you can cripple aero to a point it doesn't look much different than classic theme but the vsync is still working.

you can go to system properties -> performance -> visual effects and uncheck everything except "enable desktop composition".

aero is an important feature under windows and shouldn't be disabled if you don't know what can happen without aero.

there is an other way to fix this problem with madVR only by using windows 7 overlay mode this mode doesn't need aero vsync this doesn't fix flash issue of cause only aero can do this..
huhn is offline   Reply With Quote
Old 29th January 2015, 19:17   #6  |  Link
Lebowsky
Registered User
 
Join Date: Apr 2007
Posts: 66
thanks, I haven't had the time to try either solution on the netbook yet but I will soon and post back results.

on question though:

Quote:
Originally Posted by huhn View Post
there is an other way to fix this problem with madVR only by using windows 7 overlay mode this mode doesn't need aero vsync this doesn't fix flash issue of cause only aero can do this..
how/where do you set the overlay mode in madVR? I couldn't find out. thanks!
Lebowsky is offline   Reply With Quote
Old 29th January 2015, 19:20   #7  |  Link
huhn
Registered User
 
Join Date: Oct 2012
Posts: 7,512
Quote:
Originally Posted by Lebowsky View Post
how/where do you set the overlay mode in madVR? I couldn't find out. thanks!
rendering - > general settings -> enable windowed overlay (windows 7 and newer)

only works with intel and nvidia
huhn is offline   Reply With Quote
Old 29th January 2015, 19:32   #8  |  Link
Lebowsky
Registered User
 
Join Date: Apr 2007
Posts: 66
solved my non-fullscreen tearing on the main machine, thanks a lot!
Lebowsky is offline   Reply With Quote
Old 30th January 2015, 00:10   #9  |  Link
Lebowsky
Registered User
 
Join Date: Apr 2007
Posts: 66
well I reinstalled MPC-HC and madVR on the netbook. madVR is too cpu greedy for the poor lad.

however, since the complete reinstall, Overlay Mixer Renderer has no tearing at all, hehe. amazing! wonder why that is, but it works for me...
Lebowsky is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 23:57.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.