Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > VP9 and AV1

Reply
 
Thread Tools Search this Thread Display Modes
Old 26th September 2022, 21:56   #1  |  Link
gonzooka
Registered User
 
Join Date: Dec 2014
Posts: 6
AV1 picture too smooth compared with VP9

Hi there,

i am trying to encode an "old movie" with 1080P from MP4/AVC-18GB to save some space - and just for trying.

With VP9 it takes in second pass 24 hours with 4 threads, good result!

I would like to use AV1, it uses more threads
(but not all 16, Intel 12600K, hmm)
and does it in a half about.

What me annoys: AV1 is smoothing way too much.
Example: on a face I cant see the wrinkles in the eyes
anymore and beauty spots vanish a bit but obvious.

I tried AV1 with lower preset but no visible effect at all, CRF also.

How can I tune it, not to smooth? Any experiences?


Here the command line for both, AV1 and VP9:
(ffmpeg und AV1encoder are latest stable build.)

Code:
ffmpeg -hide_banner -loglevel warning -i input.mp4 -nostdin -strict -1 -pix_fmt yuv420p10le -f yuv4mpegpipe - | SvtAv1EncApp --progress 1 -i stdin --lp 0 --tile-rows 3 --tile-columns 3 --preset 7 -q 20 --mbr 2000k --irefresh-type 2 --enable-restoration 0 --enable-dlf 0 --enable-cdef 0 --keyint 240 -b av1_libsvtav1_output.mkv
Code:
ffmpeg -i input.mkv -c:v libvpx-vp9 -b:v 2M -crf 30 -pass 2 -threads 16 -row-mt 1 -c:a copy output.webm
gonzooka is offline   Reply With Quote
Old 26th September 2022, 22:40   #2  |  Link
gonzooka
Registered User
 
Join Date: Dec 2014
Posts: 6
annotation

footnote:

Encoding the second movie:

with tile rows switch VP9 now it uses all 16 threads with 50%, thats great! But still a lot of time: 30 hours...

Code:
ffmpeg -i input.mkv -c:v libvpx-vp9 -b:v 2M -crf 30 -pass 2 
-threads 16 -row-mt 1 -tile-columns 4 -tile-rows 2 -an output.webm
gonzooka is offline   Reply With Quote
Old 27th September 2022, 01:35   #3  |  Link
benwaggoner
Moderator
 
Join Date: Jan 2006
Location: Portland, OR
Posts: 4,309
It's a feature of modern codecs that they increasingly degrade into loss of detail instead of creating visible artifacts. I wouldn't expect AV1 to look as good as VP9 at double the bitrate. If you want to do a comparison, start with the same bitrate and see if AV1 has more detail. Then you can reduce the bitrate until you start getting undesired detail loss.
__________________
Ben Waggoner
Principal Video Specialist, Amazon Prime Video

My Compression Book
benwaggoner is offline   Reply With Quote
Old 7th October 2022, 12:59   #4  |  Link
birdie
Artem S. Tashkinov
 
birdie's Avatar
 
Join Date: Dec 2006
Posts: 248
AV1 looks like crap, sorry.

Last time I used it with these libaom 3.5 final release options and it smears out the details like there's no tomorrow:

Code:
./aomenc --end-usage=q --cq-level=12 --cpu-used=4 --threads=16 --bit-depth=10 --lag-in-frames=48
    --enable-fwd-kf=1 --enable-qm=1 --enable-chroma-deltaq=1 --quant-b-adapt=1 --mv-cost-upd-freq=2 
    --sharpness=3 --enable-keyframe-filtering=2 --arnr-strength=1 --disable-trellis-quant=0 -o out.webm out.y4m
cq-level=12 !!! That's almost lossless.

I'm disappointed as hell. Now trying vvenc-1.6.1 which is slow as hell but on a first attempt it looks much better:

Code:
./vvencapp --preset slower -qp 20 -i out.y4m --output=bit.266
Edit: at qp=20 the bitrate matches the bitrate of the original H.264 video. LOL.

Modern codecs are something. Weird.

Truth to be told I don't know how to use x264 properly. My source is encoded at 40Mbit/sec. I can only get comparable quality if I encode it at ... 35MBit/sec despite the source being produced by a terrible HW encoder and the result produced by the latest revision of x264 with the following flags:

Code:
ffmpeg -i source.mp4 -c:a copy -c:v libx264 -preset veryslow -x264opts keyint=180:min-keyint=30:bframes=16 -crf 17 -tune grain result.mkv

Last edited by birdie; 7th October 2022 at 17:05.
birdie is offline   Reply With Quote
Old 9th October 2022, 00:52   #5  |  Link
Beelzebubu
Registered User
 
Join Date: Feb 2003
Location: New York, NY (USA)
Posts: 100
The smoothing you're seeing is from temporal filtering. Try disabling it using --arnr-strength=0 --arnr-maxframes=0 --enable-keyframe-filtering=0.

I'm not sure why you're using custom settings like --enable-qm=1 --enable-chroma-deltaq=1 --quant-b-adapt=1 --mv-cost-upd-freq=2 --sharpness=3, you should use codec defaults for these unless you know what you're doing.
Beelzebubu is offline   Reply With Quote
Reply

Tags
av1, ffmpeg, vp9

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 20:58.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.