Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 3rd April 2013, 21:15   #1  |  Link
BassPig
Registered User
 
BassPig's Avatar
 
Join Date: Jan 2003
Posts: 302
VLC Media Player Won't Play m4v files in Win 7 64-bit

I've got a problem that's been evading solutions. Since moving to Windows 7 64-bit, I find that VLC Media Player won't play full HD video files that I rendered in Adobe Premiere/Media Encoder. It will only play m2v files in SD, but not m4V files in 1080P. Instead of playback, the player appears to begin play, window client area expands to 1920x1080, but remains black. However, the HDD light comes on and stays on. A look in Windows 7 Resource Manager, Disk tab, reveals that VLC is WRITING approximately 128,000,000 B/sec for the duration of the 'playback'. It is almost as if it is redirecting playback to the HDD, but I know of no such setting in VLC to cause that. It does this for a few minutes for a 45-minute video and then stops.
Is there a configuration that I am overlooking that may be causing HD videos to be treated as 'write to disc' instead of to screen? It's only affecting HD videos. All SD stuff plays in the player normally.

EDIT: Windows Media Player will play the file, but with pauses every 2 seconds, not a smooth playback. VLC Media Player worked great under XP, but I'm not having any luck with it under Win 7 64-bit.

EDIT 2: I just installed VLC x64 (experimental version). Same result. BTW, this situation exists across BOTH of my Win 7 64 machines. I have two PCs, both with Win 7 64-bit and neither of them will play a .m4v file in VLC Media Player. However, Windows Media Player does play these files, and if I install my old XP boot drive and play these files on VLC Media Player that's install in XP, they play beautifully and smoothly.

My suspicion is that Win 7 is missing something necessary to the support of playback of m4v on VLC, but I don't know what that may be.


EDIT: I've pretty much separated the problem videos and the okay videos into two categories: MPEG2 and h.264. Apparently VLC isn't producing any screen output when the file format is h.264.
Oddly, QuickTime 7 can't play the files either. But Windows Media Player can. This situation is exclusive to Windows 7 machines. Our Windows XP machines are not experiencing any playback problems with VLC and h.264 files.
__________________
Take care,

Mark & Mary Ann Weiss

www.mwhdvideo.com The Best in Video & Sound
www.ampexperts.com
www.basspig.com The Bass Pig's Lair - 20,000 Watts of Driving Stereo!
-

Last edited by BassPig; 4th April 2013 at 00:40.
BassPig is offline   Reply With Quote
 

Tags
vlc media player

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 18:37.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.