Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 Encoder GUIs

Reply
 
Thread Tools Search this Thread Display Modes
Old 2nd November 2009, 04:24   #1  |  Link
k2snowboards88
Registered User
 
Join Date: Mar 2008
Posts: 2
Megui x264. Argument Error for every b-pyrimid option

I am using version 0.3.1.1056 of MeGUI. I tried updating to the newest version of x264 (1318) at x264.nl. I've been getting an argument error no matter what I set the b-pyramid option to. Here is an example:

An error occurred: x264 [error]: invalid argument: b-pyramid = --b-bias

Here is another:

An error occurred: x264 [error]: invalid argument: b-pyramid = --direct


Do you know whats wrong? Or even better, do you know a fix?
k2snowboards88 is offline   Reply With Quote
Old 2nd November 2009, 04:31   #2  |  Link
XhmikosR
Registered User
 
Join Date: Mar 2007
Location: Hellas (Greece)
Posts: 543
You can use latest 0.3.1.1057 which has been updated to reflect the latest x264's changes, but it has a bug and will delete all your x264 profiles. The best would be to stop using MeGUI until it gets fixed, or use another GUI, or even better don't even use a GUI; encode via command line.
__________________
My Specs
XhmikosR is offline   Reply With Quote
Old 2nd November 2009, 04:34   #3  |  Link
k2snowboards88
Registered User
 
Join Date: Mar 2008
Posts: 2
Is it worth updating to the latest version of x264? Are there substantial quality or speed gains? Aside from moving files around and compiling java applications, I don't have much experience in the DOS command line (i have some more experience in unix). Is there a good guide somewhere for the the command line version of x264?
k2snowboards88 is offline   Reply With Quote
Old 2nd November 2009, 04:43   #4  |  Link
XhmikosR
Registered User
 
Join Date: Mar 2007
Location: Hellas (Greece)
Posts: 543
x264 IS a commandline application. MeGUI is a GUI for x264. Personally I always update to the latest version of x264. Not so many speed gains, since it's already optimized, but quality improvements. Take a look at some of the commits in the GIT repository to just get an idea of its development. First thing you should do if you want to encode via cmd, run x264 --help and you'll see all the various choices. You can even use the builtin presets to make things easier.
__________________
My Specs

Last edited by XhmikosR; 2nd November 2009 at 04:47.
XhmikosR is offline   Reply With Quote
Old 2nd November 2009, 15:38   #5  |  Link
Anacletus
Registered User
 
Anacletus's Avatar
 
Join Date: Mar 2005
Posts: 50
Quote:
Originally Posted by k2snowboards88 View Post
I am using version 0.3.1.1056 of MeGUI. I tried updating to the newest version of x264 (1318) at x264.nl. I've been getting an argument error no matter what I set the b-pyramid option to. Here is an example:

An error occurred: x264 [error]: invalid argument: b-pyramid = --b-bias

Here is another:

An error occurred: x264 [error]: invalid argument: b-pyramid = --direct


Do you know whats wrong? Or even better, do you know a fix?
That is happening because the newer builds of x264 use a different command line where you should pass a value for --b-pyramid (none, strict, normal) whereas MeGUI uses the old commandline where b-pyramid comes with no values.

So getting back to your example x264 is taking as value for --b-pyramid the next parameter in the commandline, in your examples "--direct" and "--b-bias"
Anacletus is offline   Reply With Quote
Old 26th November 2009, 07:15   #6  |  Link
lnatan25
Software Developer
 
lnatan25's Avatar
 
Join Date: Jan 2005
Posts: 83
So any idea when an update to 0.3.1.1057 will come out to fix x264 bugs and profile-removal bugs?
lnatan25 is offline   Reply With Quote
Old 26th November 2009, 07:17   #7  |  Link
Dark Shikari
x264 developer
 
Dark Shikari's Avatar
 
Join Date: Sep 2005
Posts: 8,667
Quote:
Originally Posted by lnatan25 View Post
So any idea when an update to 0.3.1.1057 will come out to fix x264 bugs and profile-removal bugs?
You could stop complaining and, in the meantime, switch to a GUI that sucks less and is actively maintained, like Staxrip, Handbrake, Ripbot264, HDConvertToX, and so forth.
Dark Shikari is offline   Reply With Quote
Old 26th November 2009, 07:23   #8  |  Link
lnatan25
Software Developer
 
lnatan25's Avatar
 
Join Date: Jan 2005
Posts: 83
Actually all the ones you mention suck a lot more than MeGUI when aesthetics are concerned, but whatever. Stop complaining yourself, just asked a question. Deal with it.
lnatan25 is offline   Reply With Quote
Old 26th November 2009, 07:27   #9  |  Link
Dark Shikari
x264 developer
 
Dark Shikari's Avatar
 
Join Date: Sep 2005
Posts: 8,667
Quote:
Originally Posted by lnatan25 View Post
Actually all the ones you mention suck a lot more than MeGUI when aesthetics are concerned, but whatever. Stop complaining yourself, just asked a question. Deal with it.
You asked an obviously rhetorical question which you don't expect to be answered, hence the eyeroll and trolling in your post.
Dark Shikari is offline   Reply With Quote
Old 26th November 2009, 07:41   #10  |  Link
lnatan25
Software Developer
 
lnatan25's Avatar
 
Join Date: Jan 2005
Posts: 83
Actually the eyeroll was because it's now 26/11 and last response here was 2/11, so it was more in the lines of "how longer do we have to wait". Check your trolling decoder for spec-violation bugs.

Last edited by lnatan25; 26th November 2009 at 07:48.
lnatan25 is offline   Reply With Quote
Old 26th November 2009, 12:24   #11  |  Link
Atak_Snajpera
RipBot264 author
 
Atak_Snajpera's Avatar
 
Join Date: May 2006
Location: Poland
Posts: 7,655
Quote:
Actually all the ones you mention suck a lot more than MeGUI when aesthetics are concerned, but whatever.
I can't wait to see your gui amigo! We will judge later.
Atak_Snajpera is offline   Reply With Quote
Old 26th November 2009, 14:12   #12  |  Link
prOnorama
Registered User
 
Join Date: Mar 2005
Posts: 249
Quote:
Originally Posted by Dark Shikari View Post
You could stop complaining and, in the meantime, switch to a GUI that sucks less and is actively maintained, like Staxrip, Handbrake, Ripbot264, HDConvertToX, and so forth.
You have a good point about the actively maintained part but if these alternative GUI's were better than MeGUI (better as in give full user control over x264 and other options) there wouldn't be so many ppl asking for MegUI to get fixed

It's not that I don't want to switch to another GUI but the GUI's mentioned above don't give me the amount of control I want (RipBot), or I don't like the way they work (StaxRip, HDConverttoX). Having said that I see there's a new version of Handbrake with the latest x264 build, I'll try that out again.
prOnorama is offline   Reply With Quote
Old 26th November 2009, 23:37   #13  |  Link
MKVCrazy
HD-Fan
 
Join Date: Aug 2007
Posts: 164
MeGUI doesn't suck. It's probably the best or if best is not a good word, then the most useful app than any other GUI I've seen on Doom9. It's really advanced and less CPU usage where others put things you don't know in the scripts and take more CPU usages. Super annoying. MeGUI is like set up the x264 you want, set up the script you want and go convert. Done!

I am also having that problem the b-pyramid -direct and please with respect do not reply here just to suggest another GUI. It's really not helping the problem. If x264 is too new for the MeGUI then will using an older x264.exe help? I'll try and see and reply back but I asked because I don't know how the details will be like if latest MeGUI is suppose to be used with one of the older x264.exe files or not etc.
MKVCrazy is offline   Reply With Quote
Old 27th November 2009, 00:21   #14  |  Link
Atak_Snajpera
RipBot264 author
 
Atak_Snajpera's Avatar
 
Join Date: May 2006
Location: Poland
Posts: 7,655
Why don't you grab sources and fix this syntax error???? Everybody is crying but at the same time everybody has two left hands.
Atak_Snajpera is offline   Reply With Quote
Old 27th November 2009, 04:57   #15  |  Link
lnatan25
Software Developer
 
lnatan25's Avatar
 
Join Date: Jan 2005
Posts: 83
Quote:
Originally Posted by Atak_Snajpera View Post
Why don't you grab sources and fix this syntax error???? Everybody is crying but at the same time everybody has two left hands.
You are 100% correct, will do that.

Quote:
Originally Posted by Atak_Snajpera View Post
I can't wait to see your gui amigo! We will judge later.
Excuse me? So now anyone that doesn't have a GUI can't criticize? Yeah, that shows real maturity and real confidence in what you do.
lnatan25 is offline   Reply With Quote
Old 27th November 2009, 05:52   #16  |  Link
prOnorama
Registered User
 
Join Date: Mar 2005
Posts: 249
Quote:
Originally Posted by Atak_Snajpera View Post
Why don't you grab sources and fix this syntax error???? Everybody is crying but at the same time everybody has two left hands.
Sadly I wil fully admit I do not have the knowledge for that, I'm not a programmer.

Still I'm hoping someone will take your suggestion at heart and pick up MeGUI development again

Would be sad to see this GUI go down the same path as GordianKnot which I liked in the past for Xvid encoding.
prOnorama is offline   Reply With Quote
Old 27th November 2009, 08:00   #17  |  Link
crackerjohn
Registered User
 
Join Date: May 2006
Location: China
Posts: 4


setting like this will avoid this error but it may has a big influence to quality....
crackerjohn is offline   Reply With Quote
Old 29th November 2009, 02:23   #18  |  Link
Schra
Registered User
 
Join Date: Oct 2001
Location: Germany
Posts: 8
Quote:
Originally Posted by Atak_Snajpera View Post
Why don't you grab sources and fix this syntax error???? Everybody is crying but at the same time everybody has two left hands.
I have two left hands, too. But these hands tried to change a few things. Maybe it is helpful:
http://forum.doom9.org/showthread.ph...60#post1347860

Last edited by Schra; 29th November 2009 at 02:36.
Schra is offline   Reply With Quote
Old 1st December 2009, 00:46   #19  |  Link
thehurricane
Registered User
 
Join Date: Nov 2006
Posts: 5
Regarding the error, the syntax mismatch in 1056 can easily be got around by unchecking 'Keep some B-Frames as reference' in Frame Type and entering a custom parameter for x264 in the Misc tab. For b-pyramid it would be --b-pyramid strict or --b-pyramid normal (depending on if u want a strictly hierarchical pyramid or not).

BTW is it really a bug in 1057 coz I compared the scratchpad profile xml in 1057 with a profile xml in 1056 and found that the elements for mixed frames and the value types for BFramePyramid were different. On changing those, 1057 accepted the profile as a valid one & didnt delete it.

Took me 6 days to encode an hr long video with 2pass insane settings in build 1057 (Yea I know I have a bad processor. Moreover, it's a laptop). Cool huh.
thehurricane is offline   Reply With Quote
Old 1st December 2009, 01:52   #20  |  Link
lnatan25
Software Developer
 
lnatan25's Avatar
 
Join Date: Jan 2005
Posts: 83
It's not a bug, the profiles just need to be updated for the new version.
lnatan25 is offline   Reply With Quote
Reply

Tags
error, invalid argument, megui, x264

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 06:41.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.