Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 8th May 2007, 20:27   #141  |  Link
chros
Registered User
 
chros's Avatar
 
Join Date: Mar 2002
Posts: 1,673
Quote:
Originally Posted by Pyr0 View Post
Are you guys doing anything special to use EVR in XP ?
I'm currently using Windows XP x64 and the EVR option is greyed out for me
I think if you install .NET 3.0 through Windows Update then EVR become available under XP.
chros is offline  
Old 8th May 2007, 21:02   #142  |  Link
Pyr0
Video N00b
 
Join Date: Jan 2005
Location: U.K.
Posts: 43
ah, thanks chros, that was it
in XP x64, i'm seeing the same grey bars as the other guys when using this renderer (158.22 drivers & 8800GTX), the VRM7&9 seem to be fine tho

[edit]
if i use Haali's renderer, left-clicking to pause the video does not work at all

Last edited by Pyr0; 8th May 2007 at 21:47.
Pyr0 is offline  
Old 8th May 2007, 21:47   #143  |  Link
Casimir666
Registered User
 
Join Date: Jan 2007
Posts: 455
Quote:
Originally Posted by chros View Post
Can someone make a compile from it? (So I could test with the old movs)

and what did you want to say exactly ?
More complicated than just recompile Maybe later.
__________________
Tired of tearing?
Try this Media Player Classic mod : http://mpc-hc.sourceforge.net
Casimir666 is offline  
Old 9th May 2007, 07:15   #144  |  Link
TheBashar
Registered User
 
TheBashar's Avatar
 
Join Date: Jan 2002
Posts: 112
MPC Chapter Problem

I have a x264 video in Matroska container that has quite a few chapters (and sub-chapters) specified. MPC is using its internal splitter because Haali's does not handle the sub-chapters.

My problem is after a number of chapters, the chapter mechanism fails to work. This is best illustrated with the screenshot below. It looks like there is some hardcoded limit in MPC.

Has anyone seen a patch for this floating around? Thanks!

Screenshot:
TheBashar is offline  
Old 9th May 2007, 08:43   #145  |  Link
hdboy
Registered User
 
Join Date: Jan 2007
Posts: 130
Casimir: thanks for your work! I really like the remember file position feature. EVR works quite well under XP and 7600GT, 93.81 forceware. No tearing seen so far.

Only hitch is MPC's internal subtitling does not work with EVR, as it still wants vmr7 or vmr9 renderless.

edit: quicktime HD h264 trailers, aspect ratio is messed up using EVR. 2.35:1 movies fill the screen instead of having black bars top and bottom. happens with either coreavc or cyberlink decoder. aspect ratio is correct when VMR9 is used instead. could be a drivr issue though.

Last edited by hdboy; 9th May 2007 at 15:48.
hdboy is offline  
Old 9th May 2007, 16:03   #146  |  Link
Xin-Hong
Registered User
 
Join Date: May 2006
Location: France
Posts: 29
Thanks for those major updates Casimir666

A little resquest though : showing the filename in OSD during some seconds when we open a file, usefull when we have many files in playlist. And maybe customized color and font of the OSD.
Xin-Hong is offline  
Old 9th May 2007, 19:21   #147  |  Link
Rash
Registered User
 
Rash's Avatar
 
Join Date: Aug 2002
Posts: 403
Quote:
Originally Posted by Pyr0 View Post
Could some kind soul using Vista see if the EVR option stops the screensaver or powersave options from kicking in while media is playing please?
Humm, I thought it was the player the one responsible for disabling screensaver. Anyway, on WMP it doesn't kick in, on MPC + EVR I don't know since I'm trying to get as far as I can from EVR at the moment.

Guys, I am also having a problem. I am getting "DVD: Macrovision Fail" all the time when trying to play DVDs. I am trying on a region 0 DVD disc I authored myself (DVDMaestro). It only happens when using Haali Media Splitter (and all MPC internal codecs). Is this a Haali problem? Or maybe a Haali + Vista problem? I'm going to ask on Haali's topic too.

And just a question. Drevil's release comes with lots of filters in the rar package. Are they required?

Thanks a lot.
Rash is offline  
Old 9th May 2007, 20:08   #148  |  Link
iron2000
Questioning User
 
Join Date: Jan 2005
Posts: 166
Tried Casimir's mod. Its nice to have some one working on MPC.

Some problems:
-I can't seem to get the controls to appear in fullscreen, I can't see my cursor in fullscreen too.
-The 1px border around the video(more accurately the top and left) turns transparent when the window is called from behind another.
-the player is not focused on video load.

Last edited by iron2000; 9th May 2007 at 20:17.
iron2000 is offline  
Old 9th May 2007, 20:52   #149  |  Link
sillKotscha
what's this for?
 
sillKotscha's Avatar
 
Join Date: Apr 2002
Location: Berlin, Germany
Posts: 993
Quote:
Originally Posted by iron2000 View Post
Some problems:
-I can't seem to get the controls to appear in fullscreen, I can't see my cursor in fullscreen too.
same here...
__________________
latest mix sets: http://soundcloud.com/sill
sillKotscha is offline  
Old 10th May 2007, 02:36   #150  |  Link
B.F.
Registered User
 
B.F.'s Avatar
 
Join Date: Jul 2004
Location: Russia, Novosibirsk
Posts: 92
Quote:
Originally Posted by iron2000 View Post
Tried Casimir's mod. Its nice to have some one working on MPC.

Some problems:
-The 1px border around the video(more accurately the top and left) turns transparent when the window is called from behind another.
Try to disable FSAA
B.F. is offline  
Old 10th May 2007, 09:26   #151  |  Link
mariner
Registered User
 
Join Date: Nov 2005
Posts: 572
Hi Casimir666,

Tested EVR on Xp with 6600GT AGP with no visible tearing. Hope you can get the tearing test working in the next version.

Bu the way, how is the OSD enabled?

Best regards.
mariner is offline  
Old 10th May 2007, 18:08   #152  |  Link
hdboy
Registered User
 
Join Date: Jan 2007
Posts: 130
Quote:
Originally Posted by mariner View Post
Hi Casimir666,

Tested EVR on Xp with 6600GT AGP with no visible tearing. Hope you can get the tearing test working in the next version.

Bu the way, how is the OSD enabled?

Best regards.
I think it's enabled by default. Try changing volume, playback speed, or sound delay.

I notice something: I cannot play/pause by clicking on the screen with the mouse. I have Play/Pause mapped to mouse Left Up.
hdboy is offline  
Old 10th May 2007, 18:20   #153  |  Link
Casimir666
Registered User
 
Join Date: Jan 2007
Posts: 455
Quote:
Originally Posted by mariner View Post
Hope you can get the tearing test working in the next version.
I'm working on "EVR custom presenters". If i can make it works I'll be able to add tearing test, internal subtitles, pixels shader and D3D fullscreen mode
__________________
Tired of tearing?
Try this Media Player Classic mod : http://mpc-hc.sourceforge.net
Casimir666 is offline  
Old 10th May 2007, 18:49   #154  |  Link
mariner
Registered User
 
Join Date: Nov 2005
Posts: 572
1. Internal subtitles with EVR would be great as VSfilter really slows things down.
2. Pixel Shader to do 16-235 to 0-255 mapping.
3. D3D Full Screen Mode : is this the same as FullScreenMode on EVR properties panel? It seems that control F does not work at the moment.
4. Would you also look into making video processor mode selectable by user.

Now, did I forget anything?

Thanks.
mariner is offline  
Old 10th May 2007, 20:09   #155  |  Link
hdboy
Registered User
 
Join Date: Jan 2007
Posts: 130
what are the advantages of EVR? picture quality wise, I really cannot see a difference from VMR9
hdboy is offline  
Old 11th May 2007, 02:14   #156  |  Link
NoX1911
Registered User
 
NoX1911's Avatar
 
Join Date: Aug 2003
Location: Germany
Posts: 174
Better timings, so no tearing. And no colorspace problems (YUV 16:235 output on vmr9, seems driver problem though).

Is it possible to have a separate thread for seeking and an optional 'seek by keyframe' seeking mode? Currently, if i seek by mouse wheel (5sec jump per click) mpc processes next jump only when actual picture is decoded so seeking is very uncomfortable at the moment.

EVR is running fine. I have some problems with EVR+ffdshow and WMVs though. Chroma channel is corrupt and picture is mainly b&w. Same happens with KMP Player so it maybe a driver problem (ati) or ffdshow's fault.

Last edited by NoX1911; 11th May 2007 at 02:24.
NoX1911 is offline  
Old 11th May 2007, 06:45   #157  |  Link
wozio
Registered User
 
Join Date: Apr 2005
Location: Krakow, Poland
Posts: 141
Quote:
Originally Posted by NoX1911 View Post
And no colorspace problems (YUV 16:235 output on vmr9, seems driver problem though).
It is driver who performs actual color conversion, it is not dependent on renderer. So if you have any color space issues blame ati or nvidia not renderer (vmr9 or evr).
wozio is offline  
Old 11th May 2007, 11:11   #158  |  Link
chros
Registered User
 
chros's Avatar
 
Join Date: Mar 2002
Posts: 1,673
Quote:
Originally Posted by NoX1911 View Post
an optional 'seek by keyframe' seeking mode?
Whoaa! This idea is in my mind too!
Like in GOM Player (unfortunately, only their avi splitter supports it).
In MPC avi, mkv, mp4 built-in splitters supports the jump to next keyframe (SHIFT+arrows), so I think it can be done for the several types of jumps.
Please implement this!

Thanks
chros is offline  
Old 11th May 2007, 18:57   #159  |  Link
NoX1911
Registered User
 
NoX1911's Avatar
 
Join Date: Aug 2003
Location: Germany
Posts: 174
Quote:
Originally Posted by wozio View Post
It is driver who performs actual color conversion, it is not dependent on renderer. So if you have any color space issues blame ati or nvidia not renderer (vmr9 or evr).
In the end no one cares about that.. The driver is part of the concept as well. EVR and Overlay don't have that bug. Its just VMR.

mplayerc_homecinema_v1.0.6.0:
- EVR Renderer
If you use 'Tweaks/Free window sizing' the offscreen video area as well as the letterbox areas (at fullscreen) are not black(Y0), they are grey(Y16). I think i've seen this with windows media player before but wondering why KMP Player doesn't have it.


Last edited by NoX1911; 11th May 2007 at 19:10.
NoX1911 is offline  
Old 11th May 2007, 19:03   #160  |  Link
Rash
Registered User
 
Rash's Avatar
 
Join Date: Aug 2002
Posts: 403
Quote:
Originally Posted by NoX1911 View Post
In the end no one cares about that.. The driver is part of the concept as well. EVR and Overlay don't have that bug. Its just VMR.
EVR and Overlay *do* depend on driver. And EVR on Vista does have that "bug". It is not EVR's fault, though. Try watching a video on a Intel GMA X3000 and you will see.
Rash is offline  
Closed Thread

Tags
dxva, h264, home cinema, media player classic, mpc-hc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 00:36.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.