Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > New and alternative a/v containers

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 21st February 2007, 19:22   #141  |  Link
Eragon4ever
lost program in the net
 
Join Date: Jun 2006
Location: Germany
Posts: 106
Quote:
Originally Posted by bob0r View Post
1: If you have muxed H.264 previously with nal 3, you open .mkv the nal box is greyed.... do i need to demux/remux to get it fixed or.... ?
See my post and his reply.
http://forum.doom9.org/showthread.ph...768#post947800

Last edited by Eragon4ever; 21st February 2007 at 19:24.
Eragon4ever is offline  
Old 21st February 2007, 23:24   #142  |  Link
Mosu
MKVToolNix author
 
Mosu's Avatar
 
Join Date: Sep 2002
Location: Braunschweig, Germany
Posts: 4,136
mkvmerge does not support re-adjusting the NALU size length of natively muxed h.264 tracks yet. I'm planning to implement that, though I cannot say when I'll get this done.
__________________
Latest MKVToolNix is v67.0.0

If I ever ask you to upload something, please use my file server.
Mosu is offline  
Old 21st February 2007, 23:34   #143  |  Link
tomos
Registered User
 
Join Date: Feb 2002
Location: UK
Posts: 534
Quote:
Originally Posted by Mosu View Post
Thanks. There will be no support for DD+ for the time being because a) I cannot find any specs, b) I don't have any means of playing back such a file (neither hardware nor software).
thanks for looking tho.
tomos is offline  
Old 22nd February 2007, 00:15   #144  |  Link
Mosu
MKVToolNix author
 
Mosu's Avatar
 
Join Date: Sep 2002
Location: Braunschweig, Germany
Posts: 4,136
Quote:
Originally Posted by bob0r View Post
2: H.264 MBAFF still not working right?
I get this:
Error: 'I64d' is not a valid file ID in '--track-order 0:I64d,1:I64d'.
F***! This has nothing to do with h.264 but with the new wxWidgets version I'm compiling against... How I hate this! Get rid of one bug and get a random new one...

Sorry guys, please download this build: http://www.bunkus.org/videotools/mkv....2-1-setup.exe
It's linked against the older wxWidgets version again.

Quote:
3:
Weird visual bugs also:
Never seen this myself, cannot do anything about it. If the older wxWidgets doesn't fix it for you then it'll stay that way.
__________________
Latest MKVToolNix is v67.0.0

If I ever ask you to upload something, please use my file server.
Mosu is offline  
Old 22nd February 2007, 00:24   #145  |  Link
Isochroma
Registered User
 
Join Date: Mar 2005
Posts: 468
Ahh Mosu, I have another delicious file for you!

AVC with OGG in MP4 (132K)

The video remuxes fine with latest MKVMerge, but the audio gives this error and is omitted from the MKV:
Warning: Quicktime/MP4 reader: The audio track 2 is using an unsupported 'object type id' of 221 in the 'esds' atom. Skipping this track.
Why someone would put OGG into MP4 I cannot guess, especially when you've worked so hard to make MKVToolnix the best tool for muxing.
Isochroma is offline  
Old 22nd February 2007, 08:12   #146  |  Link
Mosu
MKVToolNix author
 
Mosu's Avatar
 
Join Date: Sep 2002
Location: Braunschweig, Germany
Posts: 4,136
Yeah, mkvmerge does not support Vorbis-in-MP4 yet. But thanks for the sample; that's always the first thing I need
__________________
Latest MKVToolNix is v67.0.0

If I ever ask you to upload something, please use my file server.
Mosu is offline  
Old 22nd February 2007, 10:36   #147  |  Link
madshi
Registered Developer
 
Join Date: Sep 2006
Posts: 9,140
@Mosu, noticed some weird sound in the beginning of some of my MKV movies. After some thinking about it, what does mkvmerge do if I tell it to delay the audio tracks? Does it loop the beginning of the audio track? Or does it add silence? I guess you're looping the sound? That sounds really weird to me. If possible, I'd prefer if you added silence instead, just like delaycut does. Thanks!
madshi is offline  
Old 22nd February 2007, 14:19   #148  |  Link
Mosu
MKVToolNix author
 
Mosu's Avatar
 
Join Date: Sep 2002
Location: Braunschweig, Germany
Posts: 4,136
mkvmerge should add silence, but it doesn't support this for all audio formats (only for AC3, MP3, Vorbis if I'm not mistaken). At the moment it creates weird sound for AC3 because it does the wrong thing.
__________________
Latest MKVToolNix is v67.0.0

If I ever ask you to upload something, please use my file server.
Mosu is offline  
Old 22nd February 2007, 14:24   #149  |  Link
bob0r
Pain and suffering
 
bob0r's Avatar
 
Join Date: Jul 2002
Posts: 1,337
Quote:
Originally Posted by Mosu View Post
F***! This has nothing to do with h.264 but with the new wxWidgets version I'm compiling against... How I hate this! Get rid of one bug and get a random new one...

Sorry guys, please download this build: http://www.bunkus.org/videotools/mkv....2-1-setup.exe
It's linked against the older wxWidgets version again.



Never seen this myself, cannot do anything about it. If the older wxWidgets doesn't fix it for you then it'll stay that way.

Visual bug(s) fixed!

H.264 MBAFF muxing still fails..... hope you can support it soon


Code:
mkvmerge v2.0.2 ('You're My Flame') built on Feb 21 2007 23:40:43
'I:\cap\pride.h264': Using the AVC/h.264 ES demultiplexer.
'I:\cap\pride.ac3': Using the AC3 demultiplexer.
Track 0 of 'I:\cap\pride.h264': Extracted the aspect ratio information from the MPEG-4 layer 10 (AVC) video data and set the display dimensions to 1964/1080.
'I:\cap\pride.h264' track 0: Using the MPEG-4 part 10 ES video output module.
'I:\cap\pride.ac3' track 0: Using the AC3 output module.
The file 'G:\cap\pride.mkv' has been opened for writing.
'die' called: common.cpp/saferealloc() called from file src/common/common_memory.cpp, line 33: realloc() returned NULL for a size of 183654 bytes.
set the display dimensions to 1964/1080 <-- This makes no sense also, it's 1440x1080 which is displayed as 1920x1080.

Last edited by bob0r; 22nd February 2007 at 14:27.
bob0r is offline  
Old 22nd February 2007, 16:09   #150  |  Link
Mosu
MKVToolNix author
 
Mosu's Avatar
 
Join Date: Sep 2002
Location: Braunschweig, Germany
Posts: 4,136
The BBC file you (or someone else) gave me works fine. So how about you upload the pride.h264 file? I'm guessing that it is not an elementary stream but a transport stream. For those mkvmerge accidentally detects a h.264 elementary streams even though it isn't.

Anyway, I won't stick to using wxWidgets 2.6.3 because it causes other bugs.
__________________
Latest MKVToolNix is v67.0.0

If I ever ask you to upload something, please use my file server.
Mosu is offline  
Old 22nd February 2007, 16:53   #151  |  Link
bob0r
Pain and suffering
 
bob0r's Avatar
 
Join Date: Jul 2002
Posts: 1,337
Its the same .ts source as that sample

This is from BBC-HD also..... only difference: Its 13GB!

So thats the whole problem, same with Haali's dsmuxer... everything under around 4-5GB works fine, all above that goes wrong.

luxe.hd.ateme.ts and bbc.hd.ts <-- both work fine as 20mb files.

Note: NEW added sample was: luxe.hd.ateme.ts this is also H.264 MBAFF, the .ts can not be opened by elecard xmuxer pro, but mplayer was able to extract the raw.264 and raw.ac3

So in that case, you should still have the sample links.... get the raw h.264, and maybe you can figure out why a large file fails.....



.... Guess i got enough bandwidth anyway:
http://x264.nl/h.264.samples/
bob0r is offline  
Old 25th February 2007, 19:33   #152  |  Link
madshi
Registered Developer
 
Join Date: Sep 2006
Posts: 9,140
Quote:
Originally Posted by Mosu View Post
There will be no support for DD+ for the time being because a) I cannot find any specs, b) I don't have any means of playing back such a file (neither hardware nor software).
The spec is available here, I think:

http://www.atsc.org/standards/a52.html

Also I can send you an example DD+ stream, and I can get you going with playback though DirectShow, if you want. What do you think?

But maybe you want to wait until ffmpeg supports DD+? Don't know if that would save you time...
madshi is offline  
Old 26th February 2007, 14:21   #153  |  Link
Dr.Khron
Registered User
 
Dr.Khron's Avatar
 
Join Date: Oct 2006
Location: Gotham City, USA
Posts: 389
MKVMerge GUI is causing my Windows Explorer to crash!

Pretty much anytime I mux an MKV, halfway through the process, my Windows Explorer crashes, closing all of my open windows, and making most of my system tray dissapear. The only fix is to reboot.

Seems like a conflict of some kind... any ideas what might be conflicting with MKVMerge GUI?
Dr.Khron is offline  
Old 26th February 2007, 14:43   #154  |  Link
Mosu
MKVToolNix author
 
Mosu's Avatar
 
Join Date: Sep 2002
Location: Braunschweig, Germany
Posts: 4,136
Neither mmg nor mkvmerge is doing anything low level or interacting directly with the explorer. They only read and write files. What I could think of is that mkvmerge allocates too much memory which would indicate a memory hole somewhere. Maybe you could monitor memory usage during muxing with the task manager.
__________________
Latest MKVToolNix is v67.0.0

If I ever ask you to upload something, please use my file server.
Mosu is offline  
Old 26th February 2007, 14:51   #155  |  Link
Mosu
MKVToolNix author
 
Mosu's Avatar
 
Join Date: Sep 2002
Location: Braunschweig, Germany
Posts: 4,136
Quote:
Originally Posted by madshi View Post
The spec is available here, I think:

http://www.atsc.org/standards/a52.html

Also I can send you an example DD+ stream, and I can get you going with playback though DirectShow, if you want. What do you think?

But maybe you want to wait until ffmpeg supports DD+? Don't know if that would save you time...
Haali has also sent me the specs. Sample files are always welcome. DirectShow playback is nice to have, but not exactly helping because I usually develop on Linux. Developing on Windows is always a lot slower for me.
__________________
Latest MKVToolNix is v67.0.0

If I ever ask you to upload something, please use my file server.
Mosu is offline  
Old 27th February 2007, 06:05   #156  |  Link
foxyshadis
ангел смерти
 
foxyshadis's Avatar
 
Join Date: Nov 2004
Location: Lost
Posts: 9,565
Quote:
Originally Posted by Dr.Khron View Post
MKVMerge GUI is causing my Windows Explorer to crash!

Pretty much anytime I mux an MKV, halfway through the process, my Windows Explorer crashes, closing all of my open windows, and making most of my system tray dissapear. The only fix is to reboot.

Seems like a conflict of some kind... any ideas what might be conflicting with MKVMerge GUI?
I bet you have some kind of shell extension that monitors mkv files, and crashes when it tries to read it while it's still being written. Probably matroskaprop, possibly haali's, but I don't think his is that badly behaved.

Check with this:
http://www.nirsoft.net/utils/shexview.html
foxyshadis is offline  
Old 2nd March 2007, 16:42   #157  |  Link
Mosu
MKVToolNix author
 
Mosu's Avatar
 
Join Date: Sep 2002
Location: Braunschweig, Germany
Posts: 4,136
Something for you guys to play with:

Quote:
2007-03-02 Moritz Bunkus <moritz@bunkus.org>

* mkvmerge: new feature: Added support for EAC3 tracks in MPEG
program streams.

* mkvmerge: new feature: Added support for EAC3/DD+ (Dolby Digital
Plus) files and tracks (raw EAC3 files or inside Matroska with
CodecID A_EAC3).
http://www.bunkus.org/videotools/mkv...20070302-1.rar

Note that I still don't have a working playback solution here, so this is reeeeally untested. You will need the latest version of Haali's splitter of course.
__________________
Latest MKVToolNix is v67.0.0

If I ever ask you to upload something, please use my file server.
Mosu is offline  
Old 2nd March 2007, 18:15   #158  |  Link
madshi
Registered Developer
 
Join Date: Sep 2006
Posts: 9,140
Thanks very much - Mosu!!!

I've just tested to mux an external EAC3 track into an already existing MKV file which was created by Haali's Matroska Muxer. Here are my results:

(1) I'm once again getting a few of the following warnings:

"Warning: pr_generic.cpp/generic_packetizer_c::add_packet(): timecode < last_timecode (00:59:30.600 < 00:59:30.667) for 1 of 'D:\test.mkv'. This should not have happened. Please contact the author with this error/warning message, a description of what you were trying to do, the command line used and which operating system you are using. Thank you."

Interestingly the first warning is at *exactly* the half of the movie (but not at the timecode where the two EVOs were splitted).

Mosu, does this warning have any practical meaning? Does it mean I should trash the new MKV because there's a glitch in it? If yes, is the glitch only in the new MKV or also in the original one? FWIW, I've checked the video at the 3 places the warnings mentioned and didn't notice any glitches. Does that mean I can safely ignore the warnings?

Besides, I'm always getting these warnings, if I remux one of the MKV files which were created by EVO -> Haali's Matroska Muxer. So this is not a problem related to the new EAC3 support. Maybe Haali's Matroska Muxer does something wrong?

(2) Muxing of the EAC3 track generally seems to work, at least I got no crashes, the file size seems to be right and the track is properly listed in MPC. Unfortunately I cannot really test whether the sound plays, because Haali's Media Splitter reports the EAC3 track in such a way that none of my EAC3 capable DirectShow filters can connect. I guess that's a problem in the Haali Media Splitter, cause the same thing happens if I use Haali's Media Splitter directly on EVO files or on MKV files with EAC3 in them created by Haali's Matroska Muxer.
madshi is offline  
Old 2nd March 2007, 18:27   #159  |  Link
madshi
Registered Developer
 
Join Date: Sep 2006
Posts: 9,140
P.S: I'm not sure whether 0xeac3 is the correct way to sign the track. I think rather not.
madshi is offline  
Old 2nd March 2007, 19:49   #160  |  Link
Henrikx
Registered User
 
Henrikx's Avatar
 
Join Date: Aug 2005
Location: Germany
Posts: 306
THX Mosu !!!
__________________
Henrikx
Henrikx is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 15:32.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.