Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old 27th March 2012, 20:00   #1  |  Link
Šabović Adis
Registered User
 
Join Date: Mar 2012
Location: Sarajevo
Posts: 19
Levels on ffdshow

Hi there!
Has anyone (except me) tried this yet?

1) open ffdshow video decoder configuration
2) check "Levels"
3) in "Levels", check "Full range", "Show histogram"
4) set "Input" to 16-255
5) set "Output" to 0-239
6) set Gamma to 2.2
7) leave "Posterize" at 255 (as is)
8) MPCs Brightness/Contrast/Hue/Sat. controls to "neutral" or 0
9) Level in your TV set/PC mon. using "THX" video tests found on,say, S.W. DVDs or alike.


EDIT: Ignore these settings and skip to last post of the tread!
EDIT: Ignore these settings and skip to last post of the tread!
EDIT: Ignore these settings and skip to last post of the tread!
EDIT: Ignore these settings and skip to last post of the tread!

I'm using K-Lite_Codec_Pack_720_Mega and I find these settings to be the most...correct...

They are good for anything except for "Sunshine" for which I set "Input" to 8-255. (the Black as shown in histogram of that movie)

Newer K-Lite packs-less perfect.

I, also, can't get VC-1 movies to run with ffdshow at 23.976 fps.
(only at 15-20 fps.) although CPU is at 20-30% and GPU is 5-10%. It's very frustrating and I don't know why this happens. I change to ffdshow DXVA-very smooth but bad colors&levels...

Hope that someone can help me out...

Last edited by Šabović Adis; 1st April 2012 at 17:50. Reason: EDIT
Šabović Adis is offline   Reply With Quote
Old 27th March 2012, 21:11   #2  |  Link
Asmodian
Registered User
 
Join Date: Feb 2002
Location: San Jose, California
Posts: 4,415
It sounds like you might be interested in LAV Video (for VC1 playback, it is a ffdshow replacement) and MadVR. Have you tried either? I would first uninstall K-Lite.

It would be more correct to set both input and output to 16-235 and set your video card to output limited range to your TV.

I have calibrated my TV to full range (0-255, unlike the THX presets) and use MadVR to do the conversion from 16-235 to 0-255. I can really notice the improvement keeping the levels correct and normal PC content looks normal on the TV too. I also use MadVR to fix my gamut but you need to know your primaries.
Asmodian is offline   Reply With Quote
Old 28th March 2012, 03:44   #3  |  Link
Šabović Adis
Registered User
 
Join Date: Mar 2012
Location: Sarajevo
Posts: 19
Thanks for fast response, Asmodian!


First, let me explain why I've set input to 16-255 and output to 0-239.

THX test has levels of: 7, 11, 16, 21, 25, 29, 33, 37, 43...-219, 223, 228 & 235.

If left untouched, ffdshow will do 16=>0, 235=>255.
16, the Black, becomes 0 the Nothing...235, the White, becomes 255 the Askgodwhat
I've already tried LAV, MadVR, standalone MPC, new, old...nothing...
Black has to be 16, and MadVR's 16 is gray-it has to be blacked out
Furthermore, "everything else's" 16 is gray

It's because of "Full range" & "Gamma 2.2". Those two (only if used together) make an 0-255 range go 16-271 (clipping).
So, by setting the input to 16-255 and output to 0-239, I get the "incoming" level of 255, which is first pushed to 271,
back to where it belongs (271-16=255) with setting 239, and "incoming" level of 16 is not gray anymore but black, with setting 16.
The average, overall level, is higher (movies don't look so dark anymore) plus, the Gamma is corrected.
I just can't get these results with other decoders or renderers I use.
Correcting Gamma and brightness/contrast at video-card is...awful...

Now you'll say that there are no movies with levels up to 255, so why correct, but there are
Check out S.W. ep. 3, 4, 5, 6. The range is 16-255, and not the standard 16-235.
...and no movies with lower than 16 but there is
Sunshine's Black is 8. The range is 8-235...
Majority of all releases is standard 16-235, but having one setting for all doesn't work for me.
I highly recommend these settings to you too-if you have the time

My question remains:
How do I get VC-1 to work with this, particular, ffdshow decoder.

Thanks in advance, Šabović Adis
Šabović Adis is offline   Reply With Quote
Old 28th March 2012, 05:02   #4  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,901
Welcome to the forum, Šabović Adis!

It would be nice for everyone if you could fix your title to comply with our forum rule 9: use a descriptive thread title. You'll get better visibility if readers can see what your thread is about from the title.

http://forum.doom9.org/forum-rules.htm

You can hit edit on your first post, and then go advanced.

Thanks and good luck for good solutions here for you.
Guest is offline   Reply With Quote
Old 28th March 2012, 09:01   #5  |  Link
italospain
Registered User
 
Join Date: Nov 2010
Posts: 57
Quote:
Originally Posted by Šabović Adis View Post
Thanks for fast response, Asmodian!


First, let me explain why I've set input to 16-255 and output to 0-239.

THX test has levels of: 7, 11, 16, 21, 25, 29, 33, 37, 43...-219, 223, 228 & 235.

If left untouched, ffdshow will do 16=>0, 235=>255.
16, the Black, becomes 0 the Nothing...235, the White, becomes 255 the Askgodwhat
I've already tried LAV, MadVR, standalone MPC, new, old...nothing...
Black has to be 16, and MadVR's 16 is gray-it has to be blacked out
Furthermore, "everything else's" 16 is gray

It's because of "Full range" & "Gamma 2.2". Those two (only if used together) make an 0-255 range go 16-271 (clipping).
So, by setting the input to 16-255 and output to 0-239, I get the "incoming" level of 255, which is first pushed to 271,
back to where it belongs (271-16=255) with setting 239, and "incoming" level of 16 is not gray anymore but black, with setting 16.
The average, overall level, is higher (movies don't look so dark anymore) plus, the Gamma is corrected.
I just can't get these results with other decoders or renderers I use.
Correcting Gamma and brightness/contrast at video-card is...awful...

Now you'll say that there are no movies with levels up to 255, so why correct, but there are
Check out S.W. ep. 3, 4, 5, 6. The range is 16-255, and not the standard 16-235.
...and no movies with lower than 16 but there is
Sunshine's Black is 8. The range is 8-235...
Majority of all releases is standard 16-235, but having one setting for all doesn't work for me.
I highly recommend these settings to you too-if you have the time

My question remains:
How do I get VC-1 to work with this, particular, ffdshow decoder.

Thanks in advance, Šabović Adis
enable ffdshow raw so you can use every Decoder you want (try the new LAV Video for VC1) and use ffdshow raw with your special Levels Setup.
italospain is offline   Reply With Quote
Old 28th March 2012, 15:28   #6  |  Link
Šabović Adis
Registered User
 
Join Date: Mar 2012
Location: Sarajevo
Posts: 19
Quote:
Originally Posted by neuron2 View Post
Welcome to the forum, Šabović Adis!

It would be nice for everyone if you could fix your title to comply with our forum rule 9: use a descriptive thread title. You'll get better visibility if readers can see what your thread is about from the title.

http://forum.doom9.org/forum-rules.htm

You can hit edit on your first post, and then go advanced.

Thanks and good luck for good solutions here for you.
Done
Šabović Adis is offline   Reply With Quote
Old 28th March 2012, 19:24   #7  |  Link
Šabović Adis
Registered User
 
Join Date: Mar 2012
Location: Sarajevo
Posts: 19
Quote:
Originally Posted by italospain View Post
enable ffdshow raw so you can use every Decoder you want (try the new LAV Video for VC1) and use ffdshow raw with your special Levels Setup.
It didn't work... but thanks for bothering, mate.
I guess, I'll have to change OS or instal better CPU/GPU...
Šabović Adis is offline   Reply With Quote
Old 28th March 2012, 21:29   #8  |  Link
Asmodian
Registered User
 
Join Date: Feb 2002
Location: San Jose, California
Posts: 4,415
You are changing the levels in a non-standard way.

From what I understand: you are keeping whiter than white (wtw) visible, it is usually meant to be clipped even if it is present, but clipping blacker than black (btb). If I calibrate my TV for limited range anything below 16 isn't visible (16 is black) and anything over 235 isn't visible (235 is 100% white).

So the desktop, video games, web video, etc. look correct too I calibrate my TV to full range and use MadVR to expand 16-235 -> 0-255. After recalibrating my TV I cannot tell the difference between limited and full range coming out of MadVR (I used the BBC Life blurays for my real video tests).

I do not want to try to fix mastering errors for each source individually. I just want to watch movies as they were meant to look.

Are you sure your TV is properly calibrated? It sounds like you are trying to fix a bad calibration with ffdshow's levels.
Quote:
Originally Posted by Šabović Adis View Post
Black has to be 16, and MadVR's 16 is gray-it has to be blacked out
If MadVR’s 16 is gray than you have something set incorrectly. Are you sending full or limited range to your TV? There is a setting for that in both MadVR and your video card's drivers. I do not mean the video cards color/gamma settings but just the color space being sent to the TV.

Last edited by Asmodian; 29th March 2012 at 06:00.
Asmodian is offline   Reply With Quote
Old 29th March 2012, 14:41   #9  |  Link
Šabović Adis
Registered User
 
Join Date: Mar 2012
Location: Sarajevo
Posts: 19
Yesss, it's a mess, Asmodian...

The TV is a LG 50" Plasma. It has it's own tests. Cal. test, sent from PC, looks OK on it too at same settings set by TV self-test.
All looks fine on it, only the movies from PC are dark. If I correct Gamma, at video-card, levels (overall brightness, contr.) seem to be OK,
but then I get to see all the "errors" done by video-card (banding)+ colors seem to be...too hot (MadVR, the same, only without banding).
I guess, it's the decoder itself, be it WMV, ffdshow or DXVA. All that is gone when I use "Levels" in ffdshow + I keep some control over different
"mastering situations". I only can't get the effin' VC-1 through it

I swear by ffd's Levels

Thanks, ŠAbović Adis
Šabović Adis is offline   Reply With Quote
Old 29th March 2012, 20:13   #10  |  Link
Asmodian
Registered User
 
Join Date: Feb 2002
Location: San Jose, California
Posts: 4,415
Interesting, I too am using a 50" LG Plasma TV (PK750). I had a lot of trouble getting it calibrated correctly. Its "self test" was not a lot of help as it is generating the images internally so they are not the same as if they went through your computer's playback. It also doesn't even try to calibrate all the important settings.

I ended up getting best results using Spyder's TV calibration software but ripping their test DVD and playing it though my normal media player (Zoom Player). Because the TV changes how it displays images depending on the total brightness (even with all the dynamic contrast type settings off) I have been unable to get good results using more sophisticated calibration tools. For instance, trying to measure the gamma curve using full screen test images gives a maximum brightness at ~70% with just small changes in color at steps over that.

Remember, if the TV's black level is set to "low" it actually means limited range, if set to "high" it is full range.

It sounds like you are sending full range from the video card? You never said. Do you have a setting for that? I know AMD and Nvidia both do but I am not sure about newer Intels.

Sorry if I seem too antagonistic but you suggest others try your settings but they are just what looks good on your incorrectly calibrated TV and do not have any relevance to any other TV or even your TV using different settings.

I want to help you understand the playback chain so you can get the most out of your TV. After getting everything setup correctly I am very pleased with the picture of my TV; I have great blacks but can also still see details in shadows. Colors are also correct, now I notice skin tones being off on most other (uncalibrated) TVs.

Please do go through all your settings to make sure you keep the same setting for full or limited range all the way through the playback chain. For example having ffdshow output full range to the renderer which changes it back to limited range than sends it to the video card which changes it to full range again and sends it to the TV which is expecting limited range can mess things up a lot. I agree that you should never use any of the video card's gamma/color settings. As you saw they usually do more harm than good. Madishi (author of MadVR) calls them "video damage algorithms".
Asmodian is offline   Reply With Quote
Old 30th March 2012, 12:16   #11  |  Link
Šabović Adis
Registered User
 
Join Date: Mar 2012
Location: Sarajevo
Posts: 19
No, you are not antagonistic at all!

My TV is a PK 250. Strange that you say:"It also doesn't even try to calibrate all the important settings", because mine has controls over Color Gamut; Red, Green, Blue Contrast; Red, Green, Blue Brightness; Red, Green, Blue,Yellow, Cyan, Magenta Color and Tint, besides the "normal" Brightness, Contrast, V&H Sharpness etc... ??? There is a control over PC or HDDVD/Game/BlueRay under "Input Label" too. I get some color boost when I switch from, say, HDDVD to PC. Little, but noticeable.

Brightness is set to 45, Contrast is 100. Color is 46. Tint is G 5. Gamma is High. Black is High. I've measured the difference between High&Low Gamma, and it's 1.13 he he I guess, High Gamma means Gamma is 1, that is, flat. The rest is as is: Blue, Yellow, Magenta Tint...zero. This is after LG's "Self-calibration" test. Then, I ran a signal from PC (not a cal. test out of MPC player, but a PC full-range test, just to make shore that PC and TV are on the same wavelength). I didn't have to change a single thing on TV! Then I watched movies, what else, for a year or so. They were dark, in my opinion, but on the other hand, I disagreed with myself on that because I constantly ran and reran tests and everything was fine. Who am I not to like the dark result... What I didn't know ( at that time) is that every movie, shot on 35 mm, has a Gamma value of cca. 0.45. Digitally shot movies-Gamma 1, but they all get corrected for Gamma 0.45, so they all look correct on CRTs, which all have a Gamma value of 2.2. It's easy, 1:2.2=0.454545; 1:0.4545=2.2. Plus, I learned that only the range 16-235 out of 0-255, is used to "transport" movies via Blue Ray&HDDVD to the viewer and, in addition to that, that range of 16-235 is additionally offset&spread over a range of 0-255 by PC itself! Goddamnitalltogether... So, all I had to do is reverse-engineer all of that: de-ofsett, despread and, finally, de-Invertogammarize the poor signal, and this is what I've came up with:

1) open ffdshow video decoder configuration
2) check "Levels"
3) in "Levels", check "Full range", "Show histogram"
4) set "Input" to 16-255
5) set "Output" to 0-239
6) set Gamma to 2.2
7) leave "Posterize" at 255 (as is)
8) MPCs Brightness/Contrast/Hue/Sat. controls to "neutral" or 0
9) Level in your TV set/PC mon. using "THX" video tests found on,say, S.W. DVDs or alike.

Even now, the Level 235's intensity is on Level 255's intensity place. For 235 on 235 I set "Output" to 0-219.

Now, I hope you'll forgive me for being this protagonistic, but I guess it's worth a try.

Thanks, Šabović Adis


P.S.
I've even find a way around getting those awful bandings, when using a videocard's Gamma slider, but I'm not that far to post it. Yet... Tomorrow, maybe...

Last edited by Šabović Adis; 30th March 2012 at 12:39. Reason: ...smilie...
Šabović Adis is offline   Reply With Quote
Old 1st April 2012, 07:14   #12  |  Link
Šabović Adis
Registered User
 
Join Date: Mar 2012
Location: Sarajevo
Posts: 19
Tick-tick! Tick-tick!

Achtung, Achtung!
An alle LG-750, 50 Zoll Plasma Benutzer, besonders an die, die Asmodian heissen!

Attention, Attention! On all LG-750, 50 inch Plasma users, especially the ones called Asmodian!

I've nailed it, buddy! This one will drop jaws, just check it out!

1) In "Levels" of ffdshow, set both, input and output, to 0-255
2) Gamma 2.2
3) Full range

1a) Switch LG's input label to PC (found in "Options")
2a) Contrast 100
3a) Brightness 0
4a) Play movie (choose 2.35:1 one) and raise Brightness until the noise in black bars the starts to show up (one needs to go real close to the screen for this one he he)
5a) Only one "step into the noise" is good (needs back&forth motion on remote ), I've set mine to 12 (Sunshine-27)


Under these conditions, movies finally look like I've remembered them from theaters. No more bandings except for the "encoded ones". Colors are...unbeliveable. Movies now look good even if you sit at "diagonal" distance. The only thing one can improve, from now on, is the screen size.
This is as good as it gets...

Thanks, Šabović Adis

Last edited by Šabović Adis; 1st April 2012 at 17:25. Reason: ...thanks...
Šabović Adis is offline   Reply With Quote
Old 1st April 2012, 08:31   #13  |  Link
hello_hello
Registered User
 
Join Date: Mar 2011
Posts: 4,855
Quote:
Originally Posted by Šabović Adis View Post
I've nailed it, buddy! This one will drop jaws, just check it out!

1) In "Levels" of ffdshow, set both, input and output, to 0-255
2) Gamma 2.2
3) Full range
Surely if all you're using ffdshow for is to increase the gamma you'd be better of using your TVs setting to bump it up a bit so you don't have to rely on ffdshow? Or alternatively, use you video card's settings to increase it a bit. Then you could go back to DXVA decoding.

I use my TV's settings to increase the gamma a little but are you really sure your TV is calibrated properly or you've got it set to the correct input level? Increasing the gamma to 2.2 using ffdshow looks so washed out on my TV it's unwatchable.
hello_hello is offline   Reply With Quote
Old 1st April 2012, 09:53   #14  |  Link
Šabović Adis
Registered User
 
Join Date: Mar 2012
Location: Sarajevo
Posts: 19
Quote:
Originally Posted by hello_hello View Post
Surely if all you're using ffdshow for is to increase the gamma you'd be better of using your TVs setting to bump it up a bit so you don't have to rely on ffdshow? Or alternatively, use you video card's settings to increase it a bit. Then you could go back to DXVA decoding.

I use my TV's settings to increase the gamma a little but are you really sure your TV is calibrated properly or you've got it set to the correct input level? Increasing the gamma to 2.2 using ffdshow looks so washed out on my TV it's unwatchable.

Nah...My TV boosts Gamma only to 1.13. V-card's Gamma 2.2 is the same as ffdshow's 2.2, only worse. Maybe your TV's Gamma is 2.2 native (CRT), if it looks washed out when you correct it.
But, that's not what this is all about. I suggest U2 try those settings from my previous post. Just make shore you go step by step through it-you'll end up with some serious improvements


Thanks, Šabović Adis

Last edited by Šabović Adis; 1st April 2012 at 17:26.
Šabović Adis is offline   Reply With Quote
Old 1st April 2012, 17:35   #15  |  Link
Šabović Adis
Registered User
 
Join Date: Mar 2012
Location: Sarajevo
Posts: 19
I've nailed it, buddy! This one will drop jaws, just check it out!

1) In "Levels" of ffdshow, set both, input and output, to 0-255
2) Gamma 2.2
3) Full range
4) Histogram

LG-K 250, 50 inch Plasma users do this:

1a) For movies limited at 235 (16-235), switch LG's input label to other than PC (Game, HD-DVD, Blue Ray-found in "Options")
2a) For movies not limited at 235 (for example 16-255), switch LG's input label to PC (found in "Options")
3a) Contrast 100
4a) Brightness 0
5a) Play movie (choose 2.35:1 one) and raise Brightness until the noise in black bars the starts to show up (one needs to go real close to the screen for this one he he)
6a) Only one "step into the noise" is good (needs back&forth motion on remote ), I've set mine to 12 (Sunshine, set to 27)

Consider this!
- 16-235 out of 0-255 is 85,88% used on Blue Ray (85,88% of Blue Ray potential)-preserved with above settings
- "16-235" out of 16-235 is 85,88% out of 85,88=73,75% of Blue Ray potential when not using "Full range+Gamma2.2" in ffdshow

Under these conditions, movies finally look like I've remembered them from theaters. No more bandings except for the "encoded ones". Colors are...great. Movies now look good even if you sit at "diagonal" distance. The only thing one can improve, from now on, is the screen size.
This is as good as it gets...

Regarding VC-1 streams, I still need help

Thanks, Šabović Adis

Last edited by Šabović Adis; 2nd April 2012 at 03:36. Reason: histogram
Šabović Adis is offline   Reply With Quote
Reply

Tags
ffdshow, levels, vc-1

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 01:30.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.