Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > (Auto) Gordian Knot

Reply
 
Thread Tools Search this Thread Display Modes
Old 7th August 2011, 21:01   #1  |  Link
donfrenchiano
Registered User
 
Join Date: Aug 2010
Posts: 35
Lame and AutoGK, Gordian Knot, besweet

i use both autogk and GK. I have noticed that when using mediainfo to look at rips from each the audio portion on AutoGK rips have a section that says nominal bitrate which is lower than the specified 128. When looking at rips done by GK they just show abr as 128. Does anyone know why this is? is it because of the newer version of lame in AutoGK? It seems the autogk rips have a little bit smaller file size in the audio I'm assuming because of this nominal bitrate. I'm not really sure what this means. is there a way to encode audio this way in GK. I like having control over the video more as you do in GK but autogk seems more efficient in audio encoding.
donfrenchiano is offline   Reply With Quote
Old 7th August 2011, 23:40   #2  |  Link
hello_hello
Registered User
 
Join Date: Mar 2011
Posts: 4,855
Are you using constant bitrate of average bitrate mode for encoding the audio, and is it the same for both programs? It sounds like you're using CBR with GK and ABR with AutoGK.

I generally use 128k CBR encoding with AutoGK and I just checked several AVIs with MediaInfo, and it reports them as all being 128k.

You can download the latest LAME version and use it to replace the LAME files AutoGK installs. I did it a while back and it hasn't caused any problems.
hello_hello is offline   Reply With Quote
Old 7th August 2011, 23:58   #3  |  Link
donfrenchiano
Registered User
 
Join Date: Aug 2010
Posts: 35
no GK has the lame option set as -h --abr 128. I think it may have something to do with the versions. GK uses an older version of lame than AutoGK
donfrenchiano is offline   Reply With Quote
Old 8th August 2011, 12:10   #4  |  Link
hello_hello
Registered User
 
Join Date: Mar 2011
Posts: 4,855
Okay.... I thought about it some more, looked at a few old ABR MP3 encodes and yes, I'm pretty sure you're correct. The differences in actual bitrate are probably just differences between the two versions of LAME.

My old AutoGK encodes don't have their nominal bitrates shown by MediaInfo as the test encodes I made today do. Just the encoder settings, so I assume the Nominal Bitrate is something written to the MP3 header by newer versions of LAME. Despite having the same target bitrate, none of the encodes I looked at had the same actual bitrate even though they were encoded using the same version of LAME at the time. They don't vary by a lot (2Kb/s) but they do vary, so it'd probably be safe to assume a different version of LAME might produce a different bitrate again using the same ABR settings.

The only time I found more variation was when I ran a couple of little test encodes today using --abr 128. They were only short but the first one's bitrate was 119 while the next two were 111 (same nominal bitrate). I then discovered the first section contained audio which was much louder than average, so I guess the target bitrate isn't called the "target" bitrate for nothing and in theory the LAME version you're using with AutoGK just give you the same quality for less bits using the same settings.

Assuming of course they're actually encoding the same audio. If it's 5.1ch audio, AutoGK decodes it to a wave file, I think while applying whatever level is present in the AC3 header, mixes it to a stereo wave, normalised it and then LAME takes over from there. If GK does it differently (I don't know) or applies AC3 dynamic range compression, or applies some sort of dynamic normalisation etc, the two versions of LAME mightn't actually be converting the same audio.

I used LAME 3.98.4 with AutoGK today. I've no idea which version it was using when I encoded those old AVIs... the ones with no Nominal Bitrate in their media info. MediaInfo reports the same writing library for all of them, LAME3.98r

Last edited by hello_hello; 8th August 2011 at 12:20.
hello_hello is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 01:54.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.