Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > Avisynth Usage

Reply
 
Thread Tools Search this Thread Display Modes
Old 13th June 2023, 23:21   #801  |  Link
VoodooFX
Banana User
 
VoodooFX's Avatar
 
Join Date: Sep 2008
Posts: 917
I've looked at that video, looks like logo is animated whole clip, you can't deblend it.
Just use inpaint on it.

Code:
mode=Inpaint, Turbo=-1

Before:


After:
VoodooFX is offline   Reply With Quote
Old 16th June 2023, 02:50   #802  |  Link
drunksunk
Registered User
 
Join Date: Apr 2023
Posts: 60
Quote:
Originally Posted by VoodooFX View Post
I've looked at that video, looks like logo is animated whole clip, you can't deblend it.
Just use inpaint on it.
Nice, ty.

Quote:
Originally Posted by VoodooFX View Post
I didn't see it useful anywhere with positive Analyze and in general it's a nonsensical "hack".

EDIT:
Just tested now, AnalyzeTh=45 produced similar reduction on artifacts on that circle without making worse the rest of deblend like Deep:

Code:
LWLibAvVideoSource("D:\zzz.mp4")
InpaintDelogo(mask="D:\mask.bmp", Loc="1570, 904, -28, -58", Mode="Deblend", Analyze=1, AnalyzeTh=45, dPP=-5)
It's amazing how good the result is with this setting, looks perfect almost everywhere except certain parts where you can slightly see the halo effect left by the logo. If I wanted to push a little further getting completely rid of the logo but risking the overlapping text becoming blurrier, what would be the setting to tweak for that?
drunksunk is offline   Reply With Quote
Old 16th June 2023, 03:30   #803  |  Link
VoodooFX
Banana User
 
VoodooFX's Avatar
 
Join Date: Sep 2008
Posts: 917
Quote:
Originally Posted by drunksunk View Post
If I wanted to push a little further getting completely rid of the logo but risking the overlapping text becoming blurrier, what would be the setting to tweak for that?
Then you don't want to use "1" from Optimize2 argument which is enabled by default. Set Optimize2=2.
VoodooFX is offline   Reply With Quote
Old 8th July 2023, 08:37   #804  |  Link
drunksunk
Registered User
 
Join Date: Apr 2023
Posts: 60
Quote:
Originally Posted by katzenjoghurt View Post
1) Get a better version of that video from here:
https://assets14.ign.com/videos/zenc...26343076-w.mp4
(It's a 817MB file with a 5000kbps encoding rather than your 3000kbps clip)
How did you manage to find the real video location on the website? When analyzing the network traffic, the best I can find is the .m3u file of the stream for reconstructing the file using ffmpeg, but somehow you managed to find the actual mp4 source and I wonder how you did that.

Example: https://www.ign.com/articles/2015/02...lved-ign-first

https://assets7.ign.com/videos/zenco...6350275-w.m3u8

Also, do you think this mask would work fine for all videos as long as the type of logo to remove is the same?

Code:
InpaintDelogo(mask="D:\mask.bmp", Loc="1570, 904, -28, -58", Mode="Deblend", Analyze=1, AnalyzeTh=45, dPP=-5)

Last edited by drunksunk; 8th July 2023 at 08:39.
drunksunk is offline   Reply With Quote
Old 17th July 2023, 00:33   #805  |  Link
drunksunk
Registered User
 
Join Date: Apr 2023
Posts: 60
Can somebody tell me how to improve my mask? I use this:

Code:
InpaintDelogo(Loc="1590,910,-10,0", mask="D:\Z_DELOGO\d\mask.bmp", Automask=1, Analyze=3)
But the logo gets removed well only for left half, while right half has some extra stuff that gets captured.

File is THIS
drunksunk is offline   Reply With Quote
Old 17th July 2023, 13:50   #806  |  Link
VoodooFX
Banana User
 
VoodooFX's Avatar
 
Join Date: Sep 2008
Posts: 917
Is that logo only last for 13 seconds?

These settings produce good basemask:

Code:
LWLibAvVideoSource("D:\file.mp4")

InpaintDelogo(Loc="1600,912,-20,-6", mask="D:\morbid.bmp", Automask=1, Analyze=-4, FrB=136, aMix=-5)
VoodooFX is offline   Reply With Quote
Old 19th July 2023, 21:26   #807  |  Link
drunksunk
Registered User
 
Join Date: Apr 2023
Posts: 60
What about this other video?

I used this:

Code:
InpaintDelogo(Loc="1540,870,-70,-30", mask="D:\Z_DELOGO\e\mask.bmp", Automask=1, Analyze=-4, aMix=-5)
But I noticed there are still some small white particles left. Trying to tweak the aMix does never trully give perfect result all-around.
drunksunk is offline   Reply With Quote
Old 19th July 2023, 22:53   #808  |  Link
VoodooFX
Banana User
 
VoodooFX's Avatar
 
Join Date: Sep 2008
Posts: 917
What about you "answering" questions with questions?
VoodooFX is offline   Reply With Quote
Old 29th July 2023, 17:24   #809  |  Link
drunksunk
Registered User
 
Join Date: Apr 2023
Posts: 60
Quote:
Originally Posted by VoodooFX View Post
What about you "answering" questions with questions?
Yes, sorry that was only 13s indeed.
drunksunk is offline   Reply With Quote
Old 29th July 2023, 18:02   #810  |  Link
drunksunk
Registered User
 
Join Date: Apr 2023
Posts: 60
I think I found a bug in InpaintDelogo when using portable (loose files) AviSynth+ installation instead of Windows installer: https://i.imgur.com/uLkcWJ9.png
drunksunk is offline   Reply With Quote
Old 29th July 2023, 18:35   #811  |  Link
VoodooFX
Banana User
 
VoodooFX's Avatar
 
Join Date: Sep 2008
Posts: 917
Quote:
Originally Posted by drunksunk View Post
I think I found a bug in InpaintDelogo when using portable (loose files) AviSynth+ installation instead of Windows installer: https://i.imgur.com/uLkcWJ9.png
It's not a bug, it's a message telling you what to do:
"Load 'ImageSeq.dll' with 'LoadPlugin' or install Avisynth+."
VoodooFX is offline   Reply With Quote
Old 29th July 2023, 18:52   #812  |  Link
drunksunk
Registered User
 
Join Date: Apr 2023
Posts: 60
Quote:
Originally Posted by VoodooFX View Post
It's not a bug, it's a message telling you what to do:
"Load 'ImageSeq.dll' with 'LoadPlugin' or install Avisynth+."
The fact is that AviSynth+ is installed, but it's installed as loose files and it's references inside AvsPmod settings in "Custom AviSynth directory".
drunksunk is offline   Reply With Quote
Old 29th July 2023, 19:19   #813  |  Link
drunksunk
Registered User
 
Join Date: Apr 2023
Posts: 60
After months I'm still unable to automask correctly...

What am I doing wrong? Mask looks perfect, but when applied the end result is garbage... https://i.imgur.com/wakI9KN.png

Code:
Automask=1, mode="Deblend", Analyze=2
Clip is THIS
drunksunk is offline   Reply With Quote
Old 30th July 2023, 01:40   #814  |  Link
drunksunk
Registered User
 
Join Date: Apr 2023
Posts: 60
The problem is that there is no legend with alla the parameters, possible values and what they do.
drunksunk is offline   Reply With Quote
Old 30th July 2023, 12:23   #815  |  Link
VoodooFX
Banana User
 
VoodooFX's Avatar
 
Join Date: Sep 2008
Posts: 917
Quote:
Originally Posted by drunksunk View Post
The fact is that AviSynth+ is installed, but it's installed as loose files and it's references inside AvsPmod settings in "Custom AviSynth directory".
The real fact is that you didn't installed AviSynth+, you just copied files and plugins are not autoloaded, in such case you need to load them manually with LoadPlugin().

Quote:
Originally Posted by drunksunk View Post
What am I doing wrong? Mask looks perfect, but when applied the end result is garbage... https://i.imgur.com/wakI9KN.png

Code:
Automask=1, mode="Deblend", Analyze=2
The basemask is not important for the actual deblending process.
Automask just creates a black/white basemask which is enough only for Inpaint, for Deblend additional deblending masks are auto-created on the first run when Automask is not on.
With "Analyze=2" on this short clip you don't get good deblending masks, that's why you get the garbage result.

Quote:
Originally Posted by drunksunk View Post
The problem is that there is no legend with alla the parameters, possible values and what they do.
The real problem is that you don't read what is posted for you.
I remember answering you multiple times what and where to read.

Quote:
Originally Posted by drunksunk View Post
After months I'm still unable to...
Unable to read posts!? Just kidding...
VoodooFX is offline   Reply With Quote
Old 30th July 2023, 13:38   #816  |  Link
drunksunk
Registered User
 
Join Date: Apr 2023
Posts: 60
Quote:
Originally Posted by VoodooFX View Post
The real fact is that you didn't installed AviSynth+, you just copied files and plugins are not autoloaded, in such case you need to load them manually with LoadPlugin().



The basemask is not important for the actual deblending process.
Automask just creates a black/white basemask which is enough only for Inpaint, for Deblend additional deblending masks are auto-created on the first run when Automask is not on.
With "Analyze=2" on this short clip you don't get good deblending masks, that's why you get the garbage result.


The real problem is that you don't read what is posted for you.
I remember answering you multiple times what and where to read.


Unable to read posts!? Just kidding...
I looked at GitHub, looked at first post, etc. but couldn't find the entire list of parameters like you can for ffmpeg and other tools, so I don't know what dPP, Interp, Optimize, AnalyzeTh, aMix, etc. do. Generally when you download an OSS tool you get either get a file with all the instructions or they have a website with the documentation on how to use the tool.

Could you please suggest what parameters should I use for the best result and why you chose those parameters to help me understand the thought process?

Last edited by drunksunk; 30th July 2023 at 13:42.
drunksunk is offline   Reply With Quote
Old 30th July 2023, 14:24   #817  |  Link
VoodooFX
Banana User
 
VoodooFX's Avatar
 
Join Date: Sep 2008
Posts: 917
Quote:
Originally Posted by drunksunk View Post
I looked at...
Maybe 6th will be your lucky number.

Here you go, links to 5 previous answers I found:

https://forum.doom9.org/showthread.php?p=1987281
https://forum.doom9.org/showthread.php?p=1986329
https://forum.doom9.org/showthread.php?p=1986315
https://forum.doom9.org/showthread.php?p=1986329
https://forum.doom9.org/showthread.php?p=1986299
VoodooFX is offline   Reply With Quote
Old 30th July 2023, 14:53   #818  |  Link
drunksunk
Registered User
 
Join Date: Apr 2023
Posts: 60
So, since the logo is almost completely opaque, I cannot use Deblend on it? With Inpaint I get much better results but there are still some leftover artifacts.
drunksunk is offline   Reply With Quote
Old 30th July 2023, 15:18   #819  |  Link
VoodooFX
Banana User
 
VoodooFX's Avatar
 
Join Date: Sep 2008
Posts: 917
I have no idea what you mean and I don't see any logical connection to the post you quoted.
VoodooFX is offline   Reply With Quote
Old 30th July 2023, 21:08   #820  |  Link
drunksunk
Registered User
 
Join Date: Apr 2023
Posts: 60
Quote:
Originally Posted by VoodooFX View Post
I have no idea what you mean and I don't see any logical connection to the post you quoted.
I meant that by looking at documentation in the script, I read that Deblend is only valid for transparent logos, while the video I provided has basically opaque logo so that doesn't work well. I tryed all previous settings and none of them could remove the logo without being slightly noticeable using the Inpaint mode.
drunksunk is offline   Reply With Quote
Reply

Tags
delogo, hardsubs, ocr, remove, watermark

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 20:50.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.