Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > New and alternative a/v containers

Reply
 
Thread Tools Search this Thread Display Modes
Old 27th February 2022, 11:52   #1  |  Link
DeWTurk
Registered User
 
Join Date: Jan 2009
Posts: 21
Mkvtoolnix UTF-8 error



hello, it doesn't receive UTF-8 in the srt file when writing a video in its sub file. Same processes I don't get errors on windows. Macos is getting into trouble.
DeWTurk is offline   Reply With Quote
Old 28th March 2022, 06:04   #2  |  Link
Liisachan
李姗倩 Lǐ Shān Qin
 
Liisachan's Avatar
 
Join Date: Nov 2002
Posts: 1,337
Some byte sequences are invalid as UTF-8, such as so-called "non minimal" ones. If you're 100% sure that your SRT is in UTF-8, it's somehow corrupted.

How to fix it: Let's say it has 200 lines to show. Save it as a new file and only leave the first 100 lines, and try to mux it. If the error is gone, the offending line is somewhere in 101-200. If the error is still there, the offending line is somewhere in 1-100. Repeat this "halving" procedure a few times and you can spot the offending line, and can fix it as you see fit.

FYI: afaik, mkvmerge can handle both UTF-8 with or without BOM, and also non-BMP codepoints.
Liisachan is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 01:31.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.