Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > (HD) DVD, Blu-ray & (S)VCD > (HD) DVD & Blu-ray authoring

Reply
 
Thread Tools Search this Thread Display Modes
Old 7th July 2021, 01:40   #1081  |  Link
thepotatoboy
Registered User
 
Join Date: Jan 2020
Posts: 2
Quote:
Originally Posted by a5180007 View Post
Hi @thepotatoboy, from DV Blu-rays, tsMuxer outputs only dual track ts/m2ts. What process do you apply to produce single tracks ?
Hey! thankyou for trying to solve the problem.

I had the original BDMV folder, I made it into a single layer dual track using makemkv. I then extracted the .hevc file and I'm putting it back into tsmuxer.

The movie "nobody" is working in .ts and .m2ts singe layer dual track. But "John Wick 3 parabellum" isn't working. Any ideas why?

thanks
thepotatoboy is offline   Reply With Quote
Old 8th July 2021, 23:16   #1082  |  Link
imhh11
Registered User
 
Join Date: Jul 2016
Posts: 169
Quote:
Originally Posted by thepotatoboy View Post
Hey! thankyou for trying to solve the problem.

I had the original BDMV folder, I made it into a single layer dual track using makemkv. I then extracted the .hevc file and I'm putting it back into tsmuxer.

The movie "nobody" is working in .ts and .m2ts singe layer dual track. But "John Wick 3 parabellum" isn't working. Any ideas why?

thanks
yes, same behavior on my Sony x700. Some single-track(dual layer) profile 7 remux just won't play but any dual-track profile 7 remux (ts / m2ts / mp4) will play correctly (but then you have the green screen bug when you stop playback which the single-track dual-layer files don't suffer).

Last edited by imhh11; 8th July 2021 at 23:23.
imhh11 is offline   Reply With Quote
Old 1st September 2021, 17:11   #1083  |  Link
justdan96
Registered User
 
Join Date: Jun 2019
Location: UK
Posts: 49
Quote:
Originally Posted by a5180007 View Post
Hello @justdan96, when can we expect release 2.7.0 ?
Sorry things have slowed down quite a bit since xavery stepped back from the project, I might just pencil in a date and call whatever code we have then the 2.7.0 release.
justdan96 is offline   Reply With Quote
Old 5th September 2021, 17:34   #1084  |  Link
a5180007
Registered User
 
Join Date: Jun 2014
Location: Marrakech, Morocco
Posts: 227
Quote:
Originally Posted by thepotatoboy View Post
I had the original BDMV folder, I made it into a single layer dual track using makemkv. I then extracted the .hevc file and I'm putting it back into tsmuxer.

The movie "nobody" is working in .ts and .m2ts singe layer dual track. But "John Wick 3 parabellum" isn't working. Any ideas why?
You should use yusesope tool to mux to single layer dual track. MakeMKV has the annoying habit of not adding -or removing- the Access Unit Delimiter NALs.
a5180007 is offline   Reply With Quote
Old 5th September 2021, 18:21   #1085  |  Link
a5180007
Registered User
 
Join Date: Jun 2014
Location: Marrakech, Morocco
Posts: 227
VVC codec has been included in the latest version, as alpha release for trial purposes.
Please try muxing/demuxing some VVC files e.g. produced by Fraunhofer VVEnc or other encoders, and report any bug / provide samples.
No need to try non-compliant samples produced before the issuance of the ITU-T-Rec H.266 dd. Aug-20.
a5180007 is offline   Reply With Quote
Old 6th September 2021, 18:39   #1086  |  Link
imhh11
Registered User
 
Join Date: Jul 2016
Posts: 169
Quote:
Originally Posted by a5180007 View Post
You should use yusesope tool to mux to single layer dual track. MakeMKV has the annoying habit of not adding -or removing- the Access Unit Delimiter NALs.
if I demux the MakeMKV DV file and rebuild a dual-track dual-layer TS file with tsMuxer, does it fix the Access Unit Delimiter ?

or do I need to start over from the original disc backup?
imhh11 is offline   Reply With Quote
Old 6th September 2021, 18:50   #1087  |  Link
a5180007
Registered User
 
Join Date: Jun 2014
Location: Marrakech, Morocco
Posts: 227
Quote:
Originally Posted by imhh11 View Post
if I demux the MakeMKV DV file and rebuild a dual-track dual-layer TS file with tsMuxer, does it fix the Access Unit Delimiter ?
tsMuxer does not add the missing AUD for hevc yet. It is planned for after v2.7 release.
The best would still be for makemkv or mkvtoolnix to stop removing the AUD nals...
a5180007 is offline   Reply With Quote
Old 14th September 2021, 06:34   #1088  |  Link
oniiz86
Registered User
 
Join Date: Oct 2019
Posts: 10
I was wondering if anyone could confirm if they can mux more than 8 PGS subtitles within the m2ts container? I have this file with 13 PGS subtitles & only the first 8 are present when played via my BDP-105D, my UDP-203/205 players have no such issue & all 13 are present.
oniiz86 is offline   Reply With Quote
Old 14th September 2021, 07:59   #1089  |  Link
Emulgator
Big Bit Savings Now !
 
Emulgator's Avatar
 
Join Date: Feb 2007
Location: close to the wall
Posts: 1,030
For testing you may upload your mux to wetransfer (free below 2GB)
__________________
"To bypass shortcuts and find suffering...is called QUALity" (Die toten Augen von Friedrichshain)
"Data reduction ? Yep, Sir. We're working on that issue. Synce invntoin uf lingöage..."
Emulgator is offline   Reply With Quote
Old 14th September 2021, 16:04   #1090  |  Link
oniiz86
Registered User
 
Join Date: Oct 2019
Posts: 10
Quote:
Originally Posted by Emulgator View Post
For testing you may upload your mux to wetransfer (free below 2GB)
I've compressed it quite a bit, it's just over 2GB, it should be accessible from here https://1drv.ms/u/s!AmgVmKyn3jL-gQlJ...QU9l9?e=R4FoHL

I did try another file & it seems it is a bug with the M2TS container on the earlier OPPOs, strange that it was overlooked by the engineers.
oniiz86 is offline   Reply With Quote
Old 15th September 2021, 23:44   #1091  |  Link
Emulgator
Big Bit Savings Now !
 
Emulgator's Avatar
 
Join Date: Feb 2007
Location: close to the wall
Posts: 1,030
OneDrive wants me to open an account, not willing to do that for that one shot.
Reexport a shorter project just below 2GB and wetransfer ?
What firmware on the BDP-105D ?
Lots of multi-language Blu-rays would have been affected, hard to imagine...
__________________
"To bypass shortcuts and find suffering...is called QUALity" (Die toten Augen von Friedrichshain)
"Data reduction ? Yep, Sir. We're working on that issue. Synce invntoin uf lingöage..."
Emulgator is offline   Reply With Quote
Old 16th September 2021, 09:57   #1092  |  Link
oniiz86
Registered User
 
Join Date: Oct 2019
Posts: 10
Quote:
Originally Posted by Emulgator View Post
OneDrive wants me to open an account, not willing to do that for that one shot.
Reexport a shorter project just below 2GB and wetransfer ?
What firmware on the BDP-105D ?
Lots of multi-language Blu-rays would have been affected, hard to imagine...
I have the mkv file just under 2GB, perhaps you could quickly mux it to m2ts to test, here is the link https://we.tl/t-dIqkY0VBCo

The m2ts came just over 2GB & could not add it to wetransfer, the file is heavily compressed as it is but if a member has an OPPO BDP-103/105 they should be able to see the bug of only 8 subtitles when the file actually has 13, I'm on the final January 2017 83-1226 official firmware.

I understand a lot of Euro Blurays have multiple subs but I guess not many would come across this as they would prefer the mkv container due to chapter support & less overhead in the overall file size but this particular file had an issue with the non-sdh english subtitle that when muxed to m2ts was simply no longer a problem.
oniiz86 is offline   Reply With Quote
Old 16th September 2021, 12:13   #1093  |  Link
SeeMoreDigital
Registered User
 
SeeMoreDigital's Avatar
 
Join Date: Jun 2003
Location: Notts, UK
Posts: 11,916
It's been a 'known issue' for some time that the OPPO BDP-10x players are unable to support more than 8no PGS subtitles within the .m2ts container... So trying to make it happen would be a waste of time!

Indeed, why anyone would even want to create a back-up of a Blu-ray disc movie for their own use with more than eight subtitle languages is beyond me...
__________________
| I've been testing hardware media playback devices and software A/V encoders and decoders since 2001 | My Network Layout & A/V Gear |
SeeMoreDigital is online now   Reply With Quote
Old 16th September 2021, 14:14   #1094  |  Link
oniiz86
Registered User
 
Join Date: Oct 2019
Posts: 10
Oh I didn't know that, I didn't see any reports of this known issue over at the avs forums or uk av forums, I thought the BDP-10X players were fully BDAV compliant & would have no such issues with the .m2ts container, it's funny PGS subtitles were added to the mkv container in a later firmware without this issue, maybe a carry over bug from the BDP-9X players, so it is merely a bug that was never reported to OPPO? Another quirk of the MT8580 SoC chipset I suppose as the UDP-20X players have no problems & even support external IDX/SUB VobSub subtitles unlike the BDP-10X players.

Last edited by oniiz86; 16th September 2021 at 16:03.
oniiz86 is offline   Reply With Quote
Old 16th September 2021, 14:54   #1095  |  Link
oniiz86
Registered User
 
Join Date: Oct 2019
Posts: 10
Is there any particular reason why during the muxing process to the .m2ts container, the PGS subtitle streams are out of order?


Last edited by oniiz86; 16th September 2021 at 15:06.
oniiz86 is offline   Reply With Quote
Old 18th September 2021, 07:59   #1096  |  Link
raudi
Registered User
 
Join Date: May 2002
Location: Germany
Posts: 2
Quote:
Originally Posted by oniiz86 View Post
Is there any particular reason why during the muxing process to the .m2ts container, the PGS subtitle streams are out of order?
I noticed the last days the same with one movie, i think the streams they came later in the log are the forced subtitles and they start at a later place in the movie.

I had a movie which has the forced subtitle at one place in the middle of the movie and the line for that subtitle appears at around 50% in the log.
raudi is offline   Reply With Quote
Old 18th September 2021, 08:15   #1097  |  Link
oniiz86
Registered User
 
Join Date: Oct 2019
Posts: 10
Quote:
Originally Posted by raudi View Post
I noticed the last days the same with one movie, i think the streams they came later in the log are the forced subtitles and they start at a later place in the movie.

I had a movie which has the forced subtitle at one place in the middle of the movie and the line for that subtitle appears at around 50% in the log.
In this particular instance there are no forced subtitles, just 13 foreign subtitles, none are flagged as default, I'm assuming tsMuxeR has always worked this way?
oniiz86 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 16:23.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.