Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > General > Linux, Mac OS X, & Co

Reply
 
Thread Tools Search this Thread Display Modes
Old 10th March 2009, 21:00   #121  |  Link
nm
Registered User
 
Join Date: Mar 2005
Location: Finland
Posts: 2,643
Quote:
Originally Posted by nst6563 View Post
the stuttering is very minor...but once noticed it's very annoying when compared to the original source. I've tried encoding The 5th Element, SpeedRacer, The Hunt for Red October, and 8Below....all with the same result.
If those are NTSC DVDs, your problem is most likely missing IVTC. Are you perhaps deinterlacing instead?
nm is offline   Reply With Quote
Old 15th July 2009, 05:43   #122  |  Link
storm20200
Registered User
 
storm20200's Avatar
 
Join Date: May 2008
Posts: 10
Launching problem

Hi I just tried your program on Ubuntu 9.04 32-bit and can't get it to launch, tried it from terminal and got This =\

I've had this problem with a lot of pre built stuff before, any chance of getting the source? Or should I just take this to the Ubuntu forums?

Last edited by storm20200; 15th July 2009 at 05:54.
storm20200 is offline   Reply With Quote
Old 15th July 2009, 08:29   #123  |  Link
buzzqw
HDConvertToX author
 
Join Date: Nov 2003
Location: Cesena,Italy
Posts: 6,552
why do you launch autox264 from terminal ?

just click on executable.. and remember to install the gtk2 library

BHH
__________________
HDConvertToX: your tool for BD backup
MultiX264: The quick gui for x264
AutoMen: The Mencoder GUI
AutoWebM: supporting WebM/VP8
buzzqw is offline   Reply With Quote
Old 15th July 2009, 09:34   #124  |  Link
storm20200
Registered User
 
storm20200's Avatar
 
Join Date: May 2008
Posts: 10
I launch from terminal because it doesn't give me an error otherwise, instead it tries to load then nothing comes up, no error message and no sign of it in my RAM and yes I have them installed, checked with synaptic and they're installed

EDIT: If I launched via executable you wouldn't be able to see that it gives me an error :P
storm20200 is offline   Reply With Quote
Old 15th July 2009, 12:01   #125  |  Link
nm
Registered User
 
Join Date: Mar 2005
Location: Finland
Posts: 2,643
Quote:
Originally Posted by storm20200 View Post
Hi I just tried your program on Ubuntu 9.04 32-bit and can't get it to launch, tried it from terminal and got This =\
autox264 is a binary executable, so you can't run it with a shell interpreter. Type ./autox264 instead.
nm is offline   Reply With Quote
Old 15th July 2009, 18:02   #126  |  Link
storm20200
Registered User
 
storm20200's Avatar
 
Join Date: May 2008
Posts: 10
Quote:
Originally Posted by nm View Post
autox264 is a binary executable, so you can't run it with a shell interpreter. Type ./autox264 instead.
GOOD GOD MAN IT WORKED! lol, thanks a lot, still don't understand why it doesn't open via clicking on it though
storm20200 is offline   Reply With Quote
Old 24th September 2009, 10:14   #127  |  Link
Schruppinator
Registered User
 
Join Date: Sep 2009
Posts: 8
VC1 under Linux?

Hello,

first I want to say, that your program is very good. Thanks for that

My question is over autox264 on Linux. I get it to run, I load a file (a mkv file) and click "Analyse with mplayer". Now, under linux I get the following output in the console.

Code:
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `GtkTreeView::odd-row-color' of type `GdkColor' from rc file value "((GString*) 0x82a22a0)" of type `GString'
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.
Requested video codec family [wmvvc1dmo] (vfm=dmo) not available.
Enable it at compilation.
[vc1 @ 0xc22de0]Incomplete extradata
Could not open codec.
Unsupported PixelFormat -1
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
Unsupported PixelFormat -1
Unsupported PixelFormat -1
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
Unsupported PixelFormat -1
[vc1_vdpau @ 0xc22de0]decoding to PIX_FMT_NONE is not supported.
Could not open codec.
Cannot find codec matching selected -vo and video format 0x31435657.
I think, because the video is coded in VC1. Right? How I get it to run under Linux, to recode the video from VC1 to x264?

When I use the Windowsversion of autox264 with wine, no errors comes and I can recode the video. (After I put the "wvc1dmod.dll" in the windows/system32 folder I think)

Thanks for your help and sorry for my bad englisch!
Schruppinator is offline   Reply With Quote
Old 24th September 2009, 10:33   #128  |  Link
buzzqw
HDConvertToX author
 
Join Date: Nov 2003
Location: Cesena,Italy
Posts: 6,552
Hi Schruppinator

try updating your mplayer build
you can also install on linux the w32codec package..

BHH
__________________
HDConvertToX: your tool for BD backup
MultiX264: The quick gui for x264
AutoMen: The Mencoder GUI
AutoWebM: supporting WebM/VP8
buzzqw is offline   Reply With Quote
Old 24th September 2009, 11:46   #129  |  Link
Schruppinator
Registered User
 
Join Date: Sep 2009
Posts: 8
Hello again.

Thanks for the fast answer.

I forgot in my first post: I have a OpenSuse system, x86.

Quote:
Originally Posted by buzzqw View Post
try updating your mplayer build
At the moment I have installed the mplayer from the Packman Rep. in the version: "1.0rc2_r29116-2.pm.28.2-x86_64"

I downloaded the source directly from the mplayer page (Source1 and Source2) and try to configure it and I get the following output:
Quote:
Enabled optional drivers:
Input: dvdnav(internal) ftp pvr tv-teletext tv-v4l2 tv-v4l tv cddb cdda libdvdcss(internal) dvdread(internal) vcd dvb network
Codecs: xvid libavcodec(internal) real xanim faad2(internal) faac libdca libmpeg2(internal) liba52(internal) mp3lib(internal) tremor(internal) libmad gif
Audio output: alsa jack esd arts oss v4l2 sdl mpegpes(dvb)
Video output: v4l2 sdl gif89a pnm jpeg png opengl mpegpes(dvb) fbdev xvidix cvidix dga vdpau xv x11 xover yuv4mpeg md5sum tga

Disabled optional drivers:
Input: vstream radio tv-dshow live555 nemesi smb
Codecs: libschroedinger libdirac x264 libdv libopencore_amrwb libopencore_amrnb qtx win32 musepack libtheora speex toolame twolame liblzo
Audio output: sun openal pulse nas ivtv dxr2
Video output: zr zr2 ivtv dxr3 dxr2 vesa svga caca aa ggi xmga mga winvidix 3dfx xvmc dfbmga directfb bl xvr100 tdfx_vid wii s3fb tdfxfb
and a few lines later:
Quote:
NOTE: Win32 codec DLLs are not supported on your CPU (x86_64) or your
operating system (Linux). You may encounter a few files that cannot
be played due to missing open source video/audio codec support.
I think this is the problem, the codecs are not running at a x86 system!?
The problem is, when I want to install the i586 version, I have to update to many other software, which depends on the mplayer.

Quote:
Originally Posted by buzzqw View Post
you can also install on linux the w32codec package..
I have installed this package "w32codec-all" from the Packman Rep. The codecs are installed in "usr/lib/win32". The "wvc1dmod.dll" is also there.

Do you have any ideas, how I can handle that?
Schruppinator is offline   Reply With Quote
Old 24th September 2009, 12:48   #130  |  Link
nm
Registered User
 
Join Date: Mar 2005
Location: Finland
Posts: 2,643
Quote:
Originally Posted by Schruppinator View Post
[vc1_vdpau @ 0xc22de0]decoding to PIX_FMT_NONE is not supported.
Your MPlayer/MEncoder is configured to use VDPAU for VC-1 decoding. That only works with -vo vdpau, so AutoX264 can't use it. Show us your configuration files (/etc/mplayer/mplayer.conf, /etc/mplayer/mencoder.conf, ~/.mplayer/config, ~/.mplayer/mencoder.conf).

Maybe AutoX264 should use "-vc ffh264,ffmpeg12,ffvc1,ffwmv3,ffodivx," to override user/system-wide MPlayer codec setup.

Quote:
I think this is the problem, the codecs are not running at a x86 system!?
No, being unable to use w32codecs is not a problem because libavcodec has a native VC-1 decoder that works fine on x86-64.

Last edited by nm; 24th September 2009 at 12:54.
nm is offline   Reply With Quote
Old 24th September 2009, 13:02   #131  |  Link
Schruppinator
Registered User
 
Join Date: Sep 2009
Posts: 8
Quote:
Originally Posted by nm View Post
Show us your configuration files (/etc/mplayer/mplayer.conf, /etc/mplayer/mencoder.conf, ~/.mplayer/config, ~/.mplayer/mencoder.conf).
This is my mplayer.conf in /etc/mplayer/
Quote:
#
# MPlayer configuration file
#
# Configuration files are read system-wide from /usr/local/etc/mplayer.conf
# and per user from ~/.mplayer/config, where per-user settings override
# system-wide settings, all of which are overrriden by the command line.
#
# The configuration file settings are the same as the command line
# options without the preceding '-'.
#
# See the CONFIGURATION FILES section in the man page
# for a detailed description of the syntax.


##################
# video settings #
##################

# Specify default video driver (see -vo help for a list).
#vo=xv

# Use SDL video with the aalib subdriver by default.
#vo = sdl:aalib

# FBdev driver:
#
# mode to use (read from fb.modes)
#fbmode = 640x480-120
#
# location of the fb.modes file
#fbmodeconfig = /etc/fb.modes

# Specify your monitor timings for the vesa and fbdev video output drivers.
# See /etc/X11/XF86Config for timings. Be careful; if you specify settings
# that exceed the capabilities of your monitor, you may damage it.
#
# horizontal frequency range (k stands for 1000)
#monitor-hfreq = 31.5k-50k,70k
#
# vertical frequency range
#monitor-vfreq = 50-90
#
# dotclock (or pixelclock) range (m stands for 1000000)
#monitor-dotclock = 30M-300M

# Start in fullscreen mode by default.
#fs=yes

# Change to a different videomode when going fullscreen.
#vm=yes

# Override the autodetected color depth, may need 'vm=yes' as well.
#bpp=0

# Enable software scaling (powerful CPU needed) for video output
# drivers that do not support hardware scaling.
#zoom=yes

# standard monitor size, with square pixels
#monitoraspect=4:3

# Use this for a widescreen monitor, non-square pixels.
#monitoraspect=16:9

# Keep the player window on top of all other windows.
#ontop=yes


##################
# audio settings #
##################

# Specify default audio driver (see -ao help for a list).
#ao=oss

# Use SDL audio driver with the esd subdriver by default.
#ao = sdl:esd

# Specify the mixer device.
#mixer = /dev/mixer

# Resample the sound to 44100Hz with the lavcresample audio filter.
#af=lavcresample=44100


##################
# other settings #
##################

# Pretend to be Window Media Player.
# Fixes playback when playlist and media file use the same URL.
#user-agent=NSPlayer/4.1.0.3856

# Drop frames to preserve audio/video sync.
#framedrop = yes

# Specify your preferred skin here (skins are searched for in
# /usr/local/share/mplayer/skins/<name> and ~/.mplayer/skins/<name>).
#skin = Abyss

# Resample the font alphamap.
# 0 plain white fonts
# 0.75 very narrow black outline (default)
# 1 narrow black outline
# 10 bold black outline
#ffactor = 0.75

# cache settings
#
# Use 8MB input cache by default.
#cache = 8192
#
# Prefill 20% of the cache before starting playback.
#cache-min = 20.0
#
# Prefill 50% of the cache before restarting playback after the cache emptied.
#cache-seek-min = 50

# DVD: Display English subtitles if available.
#slang = en

# DVD: Play English audio tracks if available.
#alang = en

###################
# DVDNAV Settings #
###################
#vc=ffmpeg12,

# You can also include other configuration files.
#include = /path/to/the/file/you/want/to/include
fontconfig=yes
The file named in the configfile (/usr/local/etc/mplayer.conf) doesnt exists.

This file: ~/.mplayer/config I have on my system, but its empty (only one comment, that I can override the system-wide config).
Schruppinator is offline   Reply With Quote
Old 24th September 2009, 13:21   #132  |  Link
nm
Registered User
 
Join Date: Mar 2005
Location: Finland
Posts: 2,643
Ok, I reread your first log and looks like MPlayer tries ffvc1 first, like it should:
Quote:
[vc1 @ 0xc22de0]Incomplete extradata
Libavcodec seems to fail on your file. Can you post a sample clip?
nm is offline   Reply With Quote
Old 24th September 2009, 14:05   #133  |  Link
Schruppinator
Registered User
 
Join Date: Sep 2009
Posts: 8
Quote:
Originally Posted by nm View Post
Can you post a sample clip?
Thats not so easy, I have this file from a BluRay and its "a little bit" to huge to upload it.

MediaInfo gives me these infos about the video:
Quote:
Video
ID : 1
Format : VC-1
Format profile : AP@L3
Codec ID : WVC1
Codec ID/Hint : Microsoft
Duration : 2h 23mn
Bit rate : 12.4 Mbps
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16/9
Frame rate : 23.976 fps
Resolution : 24 bits
Colorimetry : 4:2:0
Scan type : Progressive
Bits/(Pixel*Frame) : 0.249
Stream size : 12.4 GiB (89%)
Do you know any short example clips for VC1 (directly from Microsoft or something) that I can download and try it with these files?

Edit:
Here are infos from another file, also to huge for upload :-(
Quote:
Video
ID : 1
Format : VC-1
Format profile : AP@L3
Codec ID : WVC1
Codec ID/Hint : Microsoft
Duration : 1h 34mn
Bit rate : 21.2 Mbps
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16/9
Frame rate : 23.976 fps
Resolution : 24 bits
Colorimetry : 4:2:0
Scan type : Progressive
Bits/(Pixel*Frame) : 0.427
Stream size : 14.0 GiB (86%)

Last edited by Schruppinator; 24th September 2009 at 14:16.
Schruppinator is offline   Reply With Quote
Old 24th September 2009, 14:31   #134  |  Link
nm
Registered User
 
Join Date: Mar 2005
Location: Finland
Posts: 2,643
Use tsMuxeR to cut a small (30-second) piece.

Does the file play in MPlayer if you try it outside AutoX264? Also try mplayer -demuxer lavf file.m2ts
nm is offline   Reply With Quote
Old 24th September 2009, 15:21   #135  |  Link
Schruppinator
Registered User
 
Join Date: Sep 2009
Posts: 8
Quote:
Originally Posted by nm View Post
Use tsMuxeR to cut a small (30-second) piece.

Does the file play in MPlayer if you try it outside AutoX264? Also try mplayer -demuxer lavf file.m2ts
OK, I mux one minute in an m2ts file, mplayer plays the file well. When I open the mkv file, this message come:
Quote:
"Cannot find codec mathing selected -vo and video format 0x..."
I will try to demux the whole movie in m2ts and use this file in autox264.
When this dont work, I upload an little file.

Edit: Now, with the m2ts file I get this output from autox264:
Quote:
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `GtkTreeView:dd-row-color' of type `GdkColor' from rc file value "((GString*) 0x829eda0)" of type `GString'
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.
[mpegts @ 0x1425820]invalid dts/pts combination
Requested video codec family [wmvvc1dmo] (vfm=dmo) not available.
Enable it at compilation.
I can play the file with mplayer.

Here is a 10 second example of the file (13,5MiB), muxed in m2ts with tsmuxer from the original mkv file, which I get from MakeMKV.

Last edited by Schruppinator; 24th September 2009 at 15:49.
Schruppinator is offline   Reply With Quote
Reply

Tags
gui, linux, mencoder, windows, x264

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 22:51.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.