Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > (HD) DVD, Blu-ray & (S)VCD > (HD) DVD & Blu-ray authoring

Reply
 
Thread Tools Search this Thread Display Modes
Old 23rd September 2021, 16:59   #1101  |  Link
von Suppé
Registered User
 
von Suppé's Avatar
 
Join Date: Dec 2013
Posts: 359
Quote:
Originally Posted by r0lZ View Post
Yes, the subtitle order bug has been fixed. Anyway, it was present only when it displayed or demuxed the subtitle streams (and, for a 3DBD, their 3D-planes) of a commercial BD with the order of the PIDs not matching the order of the streams in the MPLS. AFAIK, when tsMuxeR muxes a BD, it creates always a MPLS with the streams in the order of their PIDs. But I don't use tsMuxeR to remux, only to demux. Therefore, I may be wrong.
Clear. Good to know. Thanks, r0lZ
von Suppé is offline   Reply With Quote
Old 23rd September 2021, 19:08   #1102  |  Link
oniiz86
Registered User
 
Join Date: Oct 2019
Posts: 20
Quote:
Originally Posted by r0lZ View Post
According to the screenshot, the problem (if any) is that it shows the streams it demuxes (and possibly also muxes) when it encounters them. Since the subtitle streams can start at different times, the order of the messages is not necessarily identical to the order of the streams in the source or target file.

oniiz86, have you verified the order of the streams with another program, such as MediaInfo ? Is it correct ?
Yes, MediaInfo has them in the correct order, it could be what you are claiming regarding the slightly shorter subtitle stream duration as 8 of them run 2 minutes shorter at 2h 18mins compared to the other 5 at the same duration as the feature at 2hrs 20mins, still it is strange when the file is added to tsMuxeR the tracks are in the correct order as MediaInfo reports, I know it probably doesn't affect anything when muxed to an .m2ts/.ts file but was curious all the same.
Attached Files
File Type: txt Death On The Nile 1978.mkv.txt (20.5 KB, 15 views)
oniiz86 is offline   Reply With Quote
Old 4th October 2021, 12:54   #1103  |  Link
xledentaldj
Registered User
 
Join Date: Apr 2010
Posts: 43
Still waiting for a proper fix and source code/compile build
for MacOS 11.6 arm. I cant compile this correctly
on my Mac Mini M1 2020 along with the dylib dependency
errors I get on any nightly build. And no, that special
build you made still has that same dependency
issue on my Mac. I have some ability to compile,
so, if you want me to help, I can. All my home brew
is up to date, I have the dylibs installed, X-Code
is up to date and Docker installed. justdan96, lets get this fixed for
MacOS Please?
__________________
__________
Oppo-203
xledentaldj is offline   Reply With Quote
Old 8th October 2021, 10:08   #1104  |  Link
oniiz86
Registered User
 
Join Date: Oct 2019
Posts: 20
@justdan96 I was wondering why some muxes successfully complete at 99.8% it seems to be random too, the majority do reach 100%, just found it strange why some stop at 99.8%?
oniiz86 is offline   Reply With Quote
Old 18th October 2021, 16:18   #1105  |  Link
Nico8583
Registered User
 
Join Date: Jan 2010
Location: France
Posts: 827
Hi,
Thanks for this new version
Do you think you could add an option to demux (or remux) AC3/DTS core and keep TrueHD/DTS-HD ? Not only the current option to keep DTS-HD/TrueHD or DTS/AC3 core.
Thanks !
Nico8583 is offline   Reply With Quote
Old 4th November 2021, 10:02   #1106  |  Link
alestew
Registered User
 
Join Date: Oct 2021
Posts: 2
Hello everyone ... let's see if it happens to someone else.
I have the Oppo clone m9201 model and everything is great, except with some m2ts files in dolby vision.
The problem is that it only happens to me with the fulluhd with Dolby Vision that I pass to m2ts without the audios and subtitles that do not interest me and respecting the DV.
I play that movie with Dolby Vision in that m2ts format and great, I stop it and switch to the next movie, the format doesn't matter and I get this image ...



the movie is heard in the background but it looks like this. It is only solved by restarting the player.
I have noticed that my m2ts have the 4k base and the separate Dv, with which they are joined in 1 it does not fail.

Any ideas?
alestew is offline   Reply With Quote
Old 4th November 2021, 12:17   #1107  |  Link
von Suppé
Registered User
 
von Suppé's Avatar
 
Join Date: Dec 2013
Posts: 359
For narrowing things down, first thing I would do is trying to determine whether it's a problem with tsMuxer or other, like firmware.
Using an untouched copy of the original m2ts file and see if the issue remains, might help.
von Suppé is offline   Reply With Quote
Old 5th November 2021, 14:05   #1108  |  Link
a5180007
Registered User
 
Join Date: Jun 2014
Location: Marrakech, Morocco
Posts: 229
Quote:
Originally Posted by alestew View Post
the movie is heard in the background but it looks like this. It is only solved by restarting the player.
I have noticed that my m2ts have the 4k base and the separate Dv, with which they are joined in 1 it does not fail.
Yes it must be the infamous "green screen bug" reported e.g. here. I couldn't solve and cannot carry out trials and errors as I don't have any Bluray player myself.
a5180007 is offline   Reply With Quote
Old 5th November 2021, 14:06   #1109  |  Link
a5180007
Registered User
 
Join Date: Jun 2014
Location: Marrakech, Morocco
Posts: 229
Good news, updated MPEG-TS standard for VVC has been made public yesterday https://www.itu.int/rec/T-REC-H.222.0-202106-I/en
a5180007 is offline   Reply With Quote
Old 5th November 2021, 22:06   #1110  |  Link
FranceBB
Broadcast Encoder
 
FranceBB's Avatar
 
Join Date: Nov 2013
Location: Metropolitan City of Milan, Italy
Posts: 1,846
Quote:
Originally Posted by a5180007 View Post
Good news, updated MPEG-TS standard for VVC has been made public yesterday https://www.itu.int/rec/T-REC-H.222.0-202106-I/en
Nice one. So we'll soon have muxers and decoding in software players
FranceBB is offline   Reply With Quote
Old 9th November 2021, 10:24   #1111  |  Link
alestew
Registered User
 
Join Date: Oct 2021
Posts: 2
Quote:
Originally Posted by a5180007 View Post
Yes it must be the infamous "green screen bug" reported e.g. here. I couldn't solve and cannot carry out trials and errors as I don't have any Bluray player myself.
But the film works perfectly, only when I put another one (m2ts / mkv) I get the layer in front ... Well my solution today is to create an Iso instead of m2ts and zero problems
alestew is offline   Reply With Quote
Old 11th November 2021, 02:23   #1112  |  Link
mattl0
Registered User
 
Join Date: Dec 2020
Posts: 8
Quote:
Originally Posted by a5180007 View Post
Two possible enhancements of tsMuxer for versions after 2.7.0:

1. TrueHD
Mpeg-ts is compatible with interleaved ac3/TrueHD frames. One solution to mux pure TrueHD would be to interleave empty 32kbit ac3 frames. Indeed not as good as transcoding an ac3+thd with eac3to, as the playing of the ac3 would be blank. Is it of any interest ?

2. Dolby Vision
Profile 7 dual tracks is supported by Blu-ray player SoCs only. For non-Blu-ray modes, tsMuxer could transmux those to profile 6 single track dual layer, deprecated but a priori compatible with most STB/TV SoCs. Is it of any interest ?

is profile 6 still happening on tsmuxer? I want to test some p6 to test on ugoos my tv and a bluray player
mattl0 is offline   Reply With Quote
Old 11th November 2021, 21:48   #1113  |  Link
imhh11
Registered User
 
Join Date: Jul 2016
Posts: 170
+1
I would really really like those 2 enhancements to be implemented.
imhh11 is offline   Reply With Quote
Old 11th November 2021, 22:48   #1114  |  Link
xledentaldj
Registered User
 
Join Date: Apr 2010
Posts: 43
Hello folks, I've compiled a MacOS 11.6.1 Arm/M1 build of tsmuxer 2.6.16-dev for anyone on MacOS to try:

https://mega.nz/file/JAI3DSrY#qV8ofw...Pan5WepCVpMq8A

It still has issues making compliant 4K UHD BD ISO for my Oppo-203 (RU JB). It did successfully take my 4K BD trailer that was in an mkv container remuxed back into a BD ISO and was playable on my Oppo-203.
The tsmuxerGUI has some errors while it was compiling. Something about offsets width and qt. But it runs.
Attached Images
 
__________________
__________
Oppo-203
xledentaldj is offline   Reply With Quote
Old 16th November 2021, 18:12   #1115  |  Link
SeeMoreDigital
Registered User
 
SeeMoreDigital's Avatar
 
Join Date: Jun 2003
Location: Notts, UK
Posts: 11,950
Out of interest....

Where are people able to download the newest 'GitHub builds' of TSmuxer GUI?
__________________
| I've been testing hardware media playback devices and software A/V encoders and decoders since 2001 | My Network Layout & A/V Gear |
SeeMoreDigital is offline   Reply With Quote
Old 16th November 2021, 19:52   #1116  |  Link
von Suppé
Registered User
 
von Suppé's Avatar
 
Join Date: Dec 2013
Posts: 359
Here you go: https://github.com/justdan96/tsMuxer/releases
von Suppé is offline   Reply With Quote
Old 16th November 2021, 21:24   #1117  |  Link
SeeMoreDigital
Registered User
 
SeeMoreDigital's Avatar
 
Join Date: Jun 2003
Location: Notts, UK
Posts: 11,950
Many thanks
__________________
| I've been testing hardware media playback devices and software A/V encoders and decoders since 2001 | My Network Layout & A/V Gear |
SeeMoreDigital is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 02:51.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.