Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 AVC / H.264

Reply
 
Thread Tools Search this Thread Display Modes
Old 14th June 2008, 05:11   #1  |  Link
leiny
Registered User
 
Join Date: Jun 2008
Posts: 1
Encode noise and reduce smearing

Hi guys, please forgive me if I have made a mistake posting here.

Over the past month or so, on and off, I've been messing around trying to encode with "noise" (grain or what have you) using x264. At this point, I'm pretty much getting the same result where the "noise" is being smeared over the video affecting its quality. I've messed a bit with the settings a bit, but I'm afraid I might kill compression and/or quality if I do anything insane. I tried using deblock 4,3 and it looks more-than-slightly better, but I think it's a little bit extreme (and insane).

Yes, it is an anime source, but there's another after this with the same situation which isn't anime, I just thought I'd start off with this because its harder. Mainly because it's not all noise

I've already filtered the video into an uncompressed avi and I'm at the final encoding stage. I aim is to try and reduce the smearing as much as possible. Has anyone got any idea?

Here's what my encode settings are:

Code:
 --pass 2 --bitrate 1200 --stats ".stats" --ref 16 --mixed-refs --no-fast-pskip --bframes 16 --b-pyramid --b-rdo --bime --weightb --direct auto --filter 3,2 --subme 7 --trellis 2 --partitions p8x8,b8x8,i4x4,i8x8 --8x8dct --me umh --threads auto --thread-input --progress --no-psnr --no-ssim --output "output" "input"
I'm no expert, so it's not the best thing in the world. I think I took it from somewhere though...

Here's some pics:
DVD Source: http://i28.tinypic.com/24xj294.png
Filtered Uncompressed AVI: http://i27.tinypic.com/blhs2.png
After encode normal settings: http://i32.tinypic.com/noj8l2.png
After encode using deblock 4,3: http://i32.tinypic.com/10f50ci.png

Thanks.
leiny is offline   Reply With Quote
Old 14th June 2008, 05:17   #2  |  Link
Dark Shikari
x264 developer
 
Dark Shikari's Avatar
 
Join Date: Sep 2005
Posts: 8,667
Oh, Fate/Stay Night

Try Psy RDO. I'd definitely reset the deblocking settings to 0 when trying it, and potentially try --deadzone-intra 6 --deadzone-inter 6 instead of trellis 2; that may or may not help also.

Last edited by Dark Shikari; 14th June 2008 at 05:22.
Dark Shikari is offline   Reply With Quote
Old 14th June 2008, 06:15   #3  |  Link
Yoshiyuki Blade
Novice x264 User
 
Yoshiyuki Blade's Avatar
 
Join Date: Dec 2006
Location: California
Posts: 169
Ya the deblock settings are way too high. Start with 0,0 and see if it helps. High deblock values mush up the picture, or so I've heard.
Yoshiyuki Blade is offline   Reply With Quote
Reply

Tags
deblock, noise, smear, x264

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 18:46.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.