Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > (HD) DVD, Blu-ray & (S)VCD > (HD) DVD & Blu-ray authoring

Reply
 
Thread Tools Search this Thread Display Modes
Old 24th January 2020, 19:50   #301  |  Link
a5180007
Registered User
 
Join Date: Jun 2014
Location: Marrakech, Morocco
Posts: 253
Quote:
Originally Posted by maxibon View Post
Could someone check please?, TSMuxer hide subtitles when I try to replace the spa (latin) with spa (spain).
@maxibon my bad. This is a consequence of the 3d-plane patch, I've pushed the fix.
a5180007 is offline   Reply With Quote
Old 25th January 2020, 11:22   #302  |  Link
maxibon
Registered User
 
Join Date: Dec 2019
Posts: 16
Quote:
Originally Posted by a5180007 View Post
@maxibon my bad. This is a consequence of the 3d-plane patch, I've pushed the fix.
Thank you so much @a5180007 please let me know when implemented
maxibon is offline   Reply With Quote
Old 26th January 2020, 15:53   #303  |  Link
a5180007
Registered User
 
Join Date: Jun 2014
Location: Marrakech, Morocco
Posts: 253
Quote:
Originally Posted by maxibon View Post
Thank you so much @a5180007 please let me know when implemented
@maxibon please try latest bintray build nightly-2020-01-26--01-10-07.zip
a5180007 is offline   Reply With Quote
Old 26th January 2020, 19:16   #304  |  Link
maxibon
Registered User
 
Join Date: Dec 2019
Posts: 16
Quote:
Originally Posted by a5180007 View Post
@maxibon please try latest bintray build nightly-2020-01-26--01-10-07.zip
Hi

Ive tried with latest build and doesn't work yet;-(

By the way chapters doesn't work as well, doesn't keep original times

Regards

Last edited by maxibon; 26th January 2020 at 23:52.
maxibon is offline   Reply With Quote
Old 27th January 2020, 16:16   #305  |  Link
Mike-uk
Registered User
 
Join Date: Jun 2018
Location: Dorset
Posts: 164
Hi, Hopefully this is the correct place to ask for tsmuxer help

ive encoded a .m2ts file to a smaller H265 file ( ive tried mp4 and mkv) using handbrake with nvenc, the resulting file plays fine, I can seek to any time of the file quickly and cleanly

the problem is if I use tsmuxer to mux to m2ts, if I try and seek to any time in the file it creats a pixulated image for 2 seconds with mphc then goes back to normal ?? vlc pauses for a few seconds befor resuming, the file just doesn't feel right

any idea why

Thanks

Last edited by Mike-uk; 27th January 2020 at 16:21.
Mike-uk is offline   Reply With Quote
Old 27th January 2020, 21:24   #306  |  Link
a5180007
Registered User
 
Join Date: Jun 2014
Location: Marrakech, Morocco
Posts: 253
@Mike-uk you need to add x265 options --aud --hrd --repeat-header
Edit: --repeat-headers

Last edited by a5180007; 28th January 2020 at 08:57.
a5180007 is offline   Reply With Quote
Old 27th January 2020, 22:51   #307  |  Link
Mike-uk
Registered User
 
Join Date: Jun 2018
Location: Dorset
Posts: 164
Quote:
Originally Posted by a5180007 View Post
@Mike-uk you need to add x265 options --aud --hrd --repeat-header
Hi, adding thouse to handbrake seem to make no difference ?
Mike-uk is offline   Reply With Quote
Old 28th January 2020, 08:58   #308  |  Link
a5180007
Registered User
 
Join Date: Jun 2014
Location: Marrakech, Morocco
Posts: 253
Quote:
Originally Posted by Mike-uk View Post
Hi, adding thouse to handbrake seem to make no difference ?
@Mike-uk Please cut the first 5 MB of the m2ts with an hex editor, and send me the link to download.
a5180007 is offline   Reply With Quote
Old 28th January 2020, 09:08   #309  |  Link
a5180007
Registered User
 
Join Date: Jun 2014
Location: Marrakech, Morocco
Posts: 253
Quote:
Originally Posted by maxibon View Post
Hi

Ive tried with latest build and doesn't work yet;-(

By the way chapters doesn't work as well, doesn't keep original times

Regards
@maxibon please zip and send me your .meta with original and modified .mpls and .clpi.
a5180007 is offline   Reply With Quote
Old 28th January 2020, 14:49   #310  |  Link
Mike-uk
Registered User
 
Join Date: Jun 2018
Location: Dorset
Posts: 164
Quote:
Originally Posted by a5180007 View Post
@Mike-uk Please cut the first 5 MB of the m2ts with an hex editor, and send me the link to download.
hi ive sent you the output of tsmuxer, m2ts file
Mike-uk is offline   Reply With Quote
Old 28th January 2020, 17:57   #311  |  Link
a5180007
Registered User
 
Join Date: Jun 2014
Location: Marrakech, Morocco
Posts: 253
Quote:
Originally Posted by Mike-uk View Post
hi ive sent you the output of tsmuxer, m2ts file
@Mike-uk as suspected there is no AUD nal in your hevc stream. Please encode with x265 options --aud --hrd --repeat-headers.
If handbrake doesn't allow these options, use another frontend, or ffmpeg/x265 cli.
a5180007 is offline   Reply With Quote
Old 28th January 2020, 23:18   #312  |  Link
Mike-uk
Registered User
 
Join Date: Jun 2018
Location: Dorset
Posts: 164
Quote:
Originally Posted by a5180007 View Post
@Mike-uk as suspected there is no AUD nal in your hevc stream. Please encode with x265 options --aud --hrd --repeat-headers.
If handbrake doesn't allow these options, use another frontend, or ffmpeg/x265 cli.
ok thanks for looking

ok handbrake should except commands to the encoder but don't see to work
Mike-uk is offline   Reply With Quote
Old 29th January 2020, 22:37   #313  |  Link
glc650
Registered User
 
Join Date: May 2003
Posts: 77
Just downloaded 2020-01-28--01-08-41 for mac but whenever I try to import a video I get the following error:

https://1drv.ms/u/s!AnsGKXR_EKR0hEP-...G_Upz?e=A0auoI

This is after running ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)" < /dev/null 2> /dev/null brew install freetype brew install in terminal.

Thanks,

->g.
Attached Images
 
glc650 is offline   Reply With Quote
Old 30th January 2020, 00:19   #314  |  Link
glc650
Registered User
 
Join Date: May 2003
Posts: 77
Quote:
Originally Posted by glc650 View Post
Just downloaded 2020-01-28--01-08-41 for mac but whenever I try to import a video I get the following error:

https://1drv.ms/u/s!AnsGKXR_EKR0hEP-...G_Upz?e=A0auoI

This is after running ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)" < /dev/null 2> /dev/null brew install freetype brew install in terminal.

Thanks,

->g.
Never mind, for some reason the command in the readme was truncated on my system (I tried FF and Safari). Once I checked the web page's source I could see the full command.

Any plans to support TrueHD/Atmos?
glc650 is offline   Reply With Quote
Old 30th January 2020, 02:02   #315  |  Link
filler56789
SuperVirus
 
filler56789's Avatar
 
Join Date: Jun 2012
Location: Antarctic Japan
Posts: 1,346
Hummm, the tsMuxeR readme.md says:

Code:
MacOS
This ZIP file for MacOS can just be unzipped and the executables can be used after installing a couple of dependencies.
I know "nothing" about MacOS, except that it is a kind of Unix, so I have to ask:

is it impossible to create static builds of tsMuxeR for the Mac operating system(s)?
filler56789 is offline   Reply With Quote
Old 30th January 2020, 12:20   #316  |  Link
varekai
Registered User
 
varekai's Avatar
 
Join Date: Jul 2006
Posts: 508
adding .sup subtitles out of sync

Hello!

Thanks justdan96 for picking up the torch and continuing the development of this one-of-a-kind software.
Really appreciate it, I use it a lot for my videos and Blu-ray.
As long as I've been using it I've had this problem.
Creating a subtitle .sup file using easySUP by Mr. Dean Kasabow.
--------------------------
Using tsMuxer:
In "Input" -> "add" adding an .mpls or .m2ts (24.000 FPS) video file and adding a .sup (24.000 FPS) subtitle file.
Output to Blu-ray folder.
--------------------------
The output subtitle is out of sync, it starts OK but then gradually goes out of sync.
I can't figure out what I'm doing wrong?
Could it be a bug in tsMuxer?
If I use a mediaplayer like PotPlayer or MPC-HC and load the .sup subtitle sync is perfect.
Any input is highly appreciated.

Best regards,
varekai

Edit: Problem solved, not a tsMuxer bug... sorry...

Last edited by varekai; 4th February 2020 at 10:52. Reason: .
varekai is offline   Reply With Quote
Old 30th January 2020, 14:06   #317  |  Link
koka
Registered User
 
Join Date: Jun 2018
Posts: 14
justdan96, in COMPILING.md add ninja for ## Windows (Msys2):
pacman -Sy --needed $MINGW_PACKAGE_PREFIX-toolchain \
$MINGW_PACKAGE_PREFIX-cmake \
$MINGW_PACKAGE_PREFIX-freetype \
$MINGW_PACKAGE_PREFIX-zlib \
$MINGW_PACKAGE_PREFIX-ninja

and instead of
cmake . --build
use
cmake --build .

Thank you for your efforts!
koka is offline   Reply With Quote
Old 30th January 2020, 17:11   #318  |  Link
a5180007
Registered User
 
Join Date: Jun 2014
Location: Marrakech, Morocco
Posts: 253
Quote:
Originally Posted by maxibon View Post
Ive tried with latest build and doesn't work yet;-(

By the way chapters doesn't work as well, doesn't keep original times
@maxibon Nothing wrong with the files you sent me. The issue is you keep the original mpls with subtitle PIDs 0x12A0, 0x12A1 etc. , whereas tsMuxer creates new mpls/clpi/m2ts with PIDs 0x1200, 0x1201 etc. If you want to keep the original mpls, you have to modify the PIDs in the mpls with e.g. BDEdit or an hex editor.

I don't get how the original chapter times could be modified if you keep the original mpls: could you please expand ?
a5180007 is offline   Reply With Quote
Old 30th January 2020, 17:31   #319  |  Link
filler56789
SuperVirus
 
filler56789's Avatar
 
Join Date: Jun 2012
Location: Antarctic Japan
Posts: 1,346
Quote:
Originally Posted by koka View Post
justdan96, in COMPILING.md add ninja for ## Windows (Msys2):
Why he (thinks he) needs "ninja" for using MSYS2 on Windows or/and for compiling tsMuxeR is beyond me.
filler56789 is offline   Reply With Quote
Old 30th January 2020, 19:18   #320  |  Link
koka
Registered User
 
Join Date: Jun 2018
Posts: 14
filler56789, before use:
cmake ../ -G Ninja
need install it:
pacman -S $MINGW_PACKAGE_PREFIX-ninja
koka is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 13:04.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.