Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > Avisynth Usage

Reply
 
Thread Tools Search this Thread Display Modes
Old 23rd February 2011, 20:43   #1  |  Link
mrmrmrmr
Registered User
 
Join Date: Jan 2009
Posts: 20
Avisynth - FOURCC code not found

Hi,

I am using the "Stereo Movie Maker" software with Avisynth. It's very useful for people like me who has Fujifilm 3d cameras.
To open/import files except MPEG1/2 this software requires Avisynth to be installed.

I am trying to open an MP4 file with AVC video in it.
I have Avisynth installed on my PC (I use a Windows 7 computer with K-Lite codec pack installed)
Stereo Movie Maker says:
"Not available AVI File" , "Your videodoes not have FOURCC code"

The video has "avc1" as FOURCC code and it can be played with default Windows Media Player.

I tried same operation on a Windows XP computer and it is successful.
It also has Avisynth installed and K-Lite Codec Pack. But an older version of the codec pack.
I don't know what is the difference that disables me from opening same movie on my Windows 7 computer.
Do you have any ideas ?

Thanks,
ilker
mrmrmrmr is offline   Reply With Quote
Old 24th February 2011, 22:38   #2  |  Link
mrmrmrmr
Registered User
 
Join Date: Jan 2009
Posts: 20
I'd appreciate any help, any comments...
mrmrmrmr is offline   Reply With Quote
Old 25th February 2011, 09:28   #3  |  Link
kypec
User of free A/V tools
 
kypec's Avatar
 
Join Date: Jul 2006
Location: SK
Posts: 826
Post a MediaInfo dump about your problematic video file here for us to help you further.
kypec is offline   Reply With Quote
Old 25th February 2011, 23:05   #4  |  Link
mrmrmrmr
Registered User
 
Join Date: Jan 2009
Posts: 20
media info output of the file is below:

Code:
General
Complete name                    : C:\Users\sorcerer\Desktop\pirates.mp4
Format                           : MPEG-4
Format profile                   : Base Media / Version 2
Codec ID                         : mp42
File size                        : 83.3 MiB
Duration                         : 2mn 8s
Overall bit rate                 : 5 459 Kbps
Encoded date                     : UTC 2010-12-16 00:45:35
Tagged date                      : UTC 2010-12-16 00:45:35
gsst                             : 0
gstd                             : 128033
gssd                             : BADC205E1HH1297349856444623
gshh                             : v21.lscache7.c.youtube.com

Video
ID                               : 1
Format                           : AVC
Format/Info                      : Advanced Video Codec
Format profile                   : High@L4.0
Format settings, CABAC           : Yes
Format settings, ReFrames        : 1 frame
Codec ID                         : avc1
Codec ID/Info                    : Advanced Video Coding
Duration                         : 2mn 8s
Bit rate mode                    : Variable
Bit rate                         : 5 325 Kbps
Maximum bit rate                 : 13.4 Mbps
Width                            : 1 920 pixels
Height                           : 1 080 pixels
Display aspect ratio             : 16:9
Frame rate mode                  : Variable
Frame rate                       : 29.970 fps
Minimum frame rate               : 29.412 fps
Maximum frame rate               : 200.000 fps
Color space                      : YUV
Chroma subsampling               : 4:2:0
Bit depth                        : 8 bits
Scan type                        : Progressive
Bits/(Pixel*Frame)               : 0.086
Stream size                      : 81.3 MiB (98%)
Tagged date                      : UTC 2010-12-16 00:45:39

Audio
ID                               : 2
Format                           : AAC
Format/Info                      : Advanced Audio Codec
Format profile                   : LC
Codec ID                         : 40
Duration                         : 2mn 7s
Bit rate mode                    : Variable
Bit rate                         : 128 Kbps
Maximum bit rate                 : 163 Kbps
Channel(s)                       : 2 channels
Channel positions                : Front: L R
Sampling rate                    : 44.1 KHz
Compression mode                 : Lossy
Stream size                      : 1.95 MiB (2%)
Title                            : (C) 2007 Google Inc. v08.13.2007.
Encoded date                     : UTC 2010-12-16 00:45:38
Tagged date                      : UTC 2010-12-16 00:45:39
mrmrmrmr is offline   Reply With Quote
Old 26th February 2011, 12:52   #5  |  Link
Emulgator
Big Bit Savings Now !
 
Emulgator's Avatar
 
Join Date: Feb 2007
Location: close to the wall
Posts: 1,177
You might want to use Win7 DirectShowFilterTweaker (now in version 4.0) to get your foot in the door.
http://forum.doom9.org/showthread.php?t=146910
__________________
"To bypass shortcuts and find suffering...is called QUALity" (Die toten Augen von Friedrichshain)
"Data reduction ? Yep, Sir. We're working on that issue. Synce invntoin uf lingöage..."

Last edited by Emulgator; 26th February 2011 at 12:56.
Emulgator is online now   Reply With Quote
Old 26th February 2011, 19:37   #6  |  Link
mrmrmrmr
Registered User
 
Join Date: Jan 2009
Posts: 20
my problem is not about windows 7 or playing the movie.
The movie plays well on windows. However, the "Stereo Movie Maker" software requires Avisynth to import the file.
So I need to figure out the problem with Avisynth.
any ideas ?
mrmrmrmr is offline   Reply With Quote
Old 26th February 2011, 22:58   #7  |  Link
7ekno
Guest
 
Posts: n/a
Then posting your Avisynth script would be an awesome start

7ek
  Reply With Quote
Old 26th February 2011, 23:56   #8  |  Link
mrmrmrmr
Registered User
 
Join Date: Jan 2009
Posts: 20
where is my Avisynth script located ?

Last edited by mrmrmrmr; 27th February 2011 at 09:52.
mrmrmrmr is offline   Reply With Quote
Old 27th February 2011, 21:28   #9  |  Link
osgZach
Registered User
 
Join Date: Feb 2009
Location: USA
Posts: 677
How are you frame serving your video into Stereomovie maker if you don't have an Avisynth script?

Did you read the documentation that comes with the program? Does it say whether or not the program creates the script when you load a file, or if you are supposed to use your own script to load it?


Usually when you use Avisynth, you make your own script and load the script into the program you are working with, instead of trying to load your video file directly... That's how Avisynth works when frame serving into other applications.

Last edited by osgZach; 27th February 2011 at 21:30.
osgZach is offline   Reply With Quote
Old 27th February 2011, 23:02   #10  |  Link
mrmrmrmr
Registered User
 
Join Date: Jan 2009
Posts: 20
The program does not have a detailed documentation. I know that it uses Avisynth from the "file open" dialog.
In the dialog there is an option for "files of type" , it says "Directshow viaAVISynth"
Other than that there is nothing.
In the program folder there is nothing like an Avisynth script.
mrmrmrmr is offline   Reply With Quote
Old 1st March 2011, 22:51   #11  |  Link
mrmrmrmr
Registered User
 
Join Date: Jan 2009
Posts: 20
I'd appreciate any help.
I'm novice about Avisynth...
mrmrmrmr is offline   Reply With Quote
Old 1st March 2011, 23:40   #12  |  Link
poisondeathray
Registered User
 
Join Date: Sep 2007
Posts: 4,979
does directshow work for you ?

render the file in graphstudio, what does it say? is it the microsoft decoder ? if it is, avisynth won't work for you configured like that. Use the win7dsfiltertweaker suggested above to change h264 decoder to ffdshow, then try your program again

if that doesn't work , you can try avisynth virtual file system to mount a "dummy avi"
http://forum.doom9.org/showthread.php?t=133313
poisondeathray is offline   Reply With Quote
Old 3rd March 2011, 00:24   #13  |  Link
mrmrmrmr
Registered User
 
Join Date: Jan 2009
Posts: 20
ok;setting h264 decoder to ffdshow with win7dsfiltertweaker solves the problem of openişng the file on Stereo Movie Edit.

But now I have another problem:

I try to convert the file to another format ( AVI with 2 MJPEG streams). The software first converts audio, using ffmpeg. Right after that it starts processing AVI streams. At that point the software crashes.
On Windows XP, I don't have this problem.

What can I do ? I don't know why it crashes. (maybe ffmpeg , maybe Avisynth ?)
mrmrmrmr is offline   Reply With Quote
Old 5th March 2011, 08:43   #14  |  Link
mrmrmrmr
Registered User
 
Join Date: Jan 2009
Posts: 20
I'd appreciate any help...
mrmrmrmr is offline   Reply With Quote
Old 8th March 2011, 15:31   #15  |  Link
hanfrunz
Registered User
 
hanfrunz's Avatar
 
Join Date: Feb 2002
Location: Germany
Posts: 538
If the software runs perfectly under windows xp you may consider using a virtual xp-install. I like the free virtualbox.

regards
hanfrunz is offline   Reply With Quote
Old 8th March 2011, 21:11   #16  |  Link
mrmrmrmr
Registered User
 
Join Date: Jan 2009
Posts: 20
sure, that's an option but I would like to use the all possible resources of the system while re-encoding to different formats.
if I use a virtual machine, I won't be able to use all CPU power...
mrmrmrmr is offline   Reply With Quote
Old 8th March 2011, 21:31   #17  |  Link
Didée
Registered User
 
Join Date: Apr 2002
Location: Germany
Posts: 5,393
Though I've no need for it, just for the heck I gave a quick shot on Stereo Movie Maker. I'm on Win-7 x64, tried to open MP4 and MKV files with "DirectShow via Avisynth", and guess what? It opened the files without any problem. BTW, I haven't ever used any of the "Tweaker" tools that all-the-Internet tells you to be oh so necessary for Win-7 ...
__________________
- We´re at the beginning of the end of mankind´s childhood -

My little flickr gallery. (Yes indeed, I do have hobbies other than digital video!)
Didée is offline   Reply With Quote
Old 9th March 2011, 19:47   #18  |  Link
mrmrmrmr
Registered User
 
Join Date: Jan 2009
Posts: 20
that's interesting.
What codec pack do you have installed ?

Can you export your ffdshow audio and video settings and attach here ?
mrmrmrmr is offline   Reply With Quote
Old 13th March 2011, 22:59   #19  |  Link
mrmrmrmr
Registered User
 
Join Date: Jan 2009
Posts: 20
can anybody help me ?
I'm stuck...
mrmrmrmr is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 01:07.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.