Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > (HD) DVD, Blu-ray & (S)VCD > IFO/VOB Editors

Reply
 
Thread Tools Search this Thread Display Modes
Old 31st August 2010, 13:54   #1  |  Link
ScorpioTiger
Registered User
 
Join Date: Aug 2010
Posts: 2
Specifying languages for audio streams

Hi folks,

I have an issue that I'm hoping is easy enough to resolve, but extensive googling hasn't found the answer as yet.

I have a DVD that has the various audio streams as "Unspecified". I've used IFOedit to change these to the correct langauges, but when I play the DVD in WinDVD the audio streams still show as "Audio 01", "Audio 02" etc. I see the same thing if I look at the audio streams in CloneDVD2. Strangely, if I set the DVD as the source for DVDRebuilder, if has the audio streams correctly identified.

Is there somewhere else I need to specify the languages for the audio streams? I've browsed through each of the IFOs in turn through IFOEdit and can't see any other attributes that would be applicable.

Thanks in advance.
ScorpioTiger is offline   Reply With Quote
Old 31st August 2010, 15:22   #2  |  Link
Ghitulescu
Registered User
 
Ghitulescu's Avatar
 
Join Date: Mar 2009
Location: Germany
Posts: 5,769
I don't have any video tool nearby, but try to play with the settings and change some "undefined" into "present" or "normal" and then the language will be recognised.
Ghitulescu is offline   Reply With Quote
Old 31st August 2010, 17:10   #3  |  Link
bigotti5
Spielberger
 
bigotti5's Avatar
 
Join Date: Feb 2005
Posts: 838
Changing attributes with Ifoedit requires editing VIDEO_TS.IFO (VMG_VTS_ATRT) and VTS_xx_0.IFO (Video Attributes in VTSM_VOBS).
You should use Pgcedit (Domain - Domain Stream Attributes).
bigotti5 is offline   Reply With Quote
Old 31st August 2010, 20:20   #4  |  Link
Ghitulescu
Registered User
 
Ghitulescu's Avatar
 
Join Date: Mar 2009
Location: Germany
Posts: 5,769
None of my players do care about VIDEO_TS.IFO, including a professional DVD player. But yes you're right, both IFOs should be modified if one has to obey the DVD standards.

I have access to my video PC only in the weekends so I have to imagine mentally how IFOedit looks like, but one needs to change at least 3 fields from undefined into the actual language, normal/present/etc.
Ghitulescu is offline   Reply With Quote
Old 1st September 2010, 09:06   #5  |  Link
ScorpioTiger
Registered User
 
Join Date: Aug 2010
Posts: 2
Thanks for the responses guys. I shall have another attempt. I suspect that it's an issue of whether the stream is specified as normal/present etc as I've set the language in all the appropriate IFOs and it does show correctly to DVDRebuilder, but not with WinDVD. I suspect that both applications are applying the standard differently.

EDIT: Ok, tried setting the language type to "Present" in the VIDEO_TS.IFO and VTS_02_0.IFO files. I did this for the subtitles also and now audio languages and subtitles show correctly in all applications. Thanks again for steering me in the right direction.

Last edited by ScorpioTiger; 1st September 2010 at 10:57. Reason: Update with result after trying proposed solution
ScorpioTiger is offline   Reply With Quote
Reply

Tags
audio streams, ifoedit, languages

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 04:36.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.