Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > VapourSynth

Reply
 
Thread Tools Search this Thread Display Modes
Old 10th May 2020, 04:10   #61  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 415
I apologize for the delay on getting the R50 installer out, working on rebuilding the base libraries and upgrading Python to 3.8. Should have it out Monday or Tuesday due to my schedule.
l33tmeatwad is offline   Reply With Quote
Old 12th May 2020, 01:42   #62  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 415
VapourSynth R50 Installer is up, lots of things were updated, which includes Cython (0.29.17), FreeType (2.10.2), Fribidi (1.0.9), LibWEBP (1.1.0), Python (3.8.2), and VapourSynth (R50). As with the last update, since it's moving from 3.7 to 3.8 (should be the last shift for a while) you will need to backup site-packages (the scripts shortcut on the desktop) before installing.
l33tmeatwad is offline   Reply With Quote
Old 13th May 2020, 15:10   #63  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 415
Forgot I had not added it, but D2V Witch v3 is now available.
l33tmeatwad is offline   Reply With Quote
Old 14th May 2020, 03:41   #64  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 415
Updated & recompiled the plugins D2VSource, FFMS2, LSMASHSource with static libs for the dependancies so that they won't need to be downloaded separately.
l33tmeatwad is offline   Reply With Quote
Old 17th May 2020, 00:52   #65  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 415
While everyone should be using R50, I went ahead and updated the R49 installer to have Python 3.8 as well. In addition to that, I started the move away from shared dependancies for most things so it's a bit less complicated. I will be looking into updating some plugins that can be compiled with the dependencies build in to reduce some complications for less experienced users.
l33tmeatwad is offline   Reply With Quote
Old 17th May 2020, 01:33   #66  |  Link
shph
Registered User
 
Join Date: Mar 2020
Posts: 134
Thanks for release again! Hope VapourSynth 50 on macOS will work in Hybrid same as 49 worked.
I see you upload a folder with scripts "havsfunc-200414" Are those scripts required for VapourSynth-R50? Should i put them to python "site-packages" folder?

Last edited by shph; 17th May 2020 at 02:06.
shph is offline   Reply With Quote
Old 17th May 2020, 02:04   #67  |  Link
shph
Registered User
 
Join Date: Mar 2020
Posts: 134
Quote:
Originally Posted by l33tmeatwad View Post
Updated & recompiled the plugins D2VSource, FFMS2, LSMASHSource with static libs for the dependancies so that they won't need to be downloaded separately.
So VapourSynth 50 Installer installs old versions of those plug-ins?
Should i just download new versions from MediaFilre folder and replace them?

This makes things even more complicated for new users...
shph is offline   Reply With Quote
Old 17th May 2020, 02:06   #68  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 415
Quote:
Originally Posted by shph View Post
So VapourSynth 50 Installer installs old versions of those plug-ins?
Should i just download new versions from MediaFilre folder and replace them?

This makes things even more complicated for new users...
No, R50 should have the latest version, however with those I chose to use the shared libs as it would have bloated the installer. The downloadable versions are just there so if someone compiles VapourSynth or uses brew to install it they can just snag those plugins without the need for also snagging dependancies.
l33tmeatwad is offline   Reply With Quote
Old 17th May 2020, 02:09   #69  |  Link
shph
Registered User
 
Join Date: Mar 2020
Posts: 134
Ok. Got it.
By the way it seems some mistake in naming:
VapourSynth R50: libffms2.dylib
Downloaded from Mediafire: libffms2.4.dylib
shph is offline   Reply With Quote
Old 17th May 2020, 02:16   #70  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 415
Quote:
Originally Posted by shph View Post
Ok. Got it.
By the way it seems some mistake in naming:
VapourSynth R50: libffms2.dylib
Downloaded from Mediafire: libffms2.4.dylib
Just fixed that. I try to keep things the same across the board, but I messed that one up as it should just be libffms2.dylib.
Quote:
Originally Posted by shph View Post
Thanks for release again! Hope VapourSynth 50 on macOS will work in Hybrid same as 49 worked.
I see you upload a folder with scripts "havsfunc-200414" Are those scripts required for VapourSynth-R50? Should i put them to python "site-packages" folder?
I just uploaded that with the date I put the package together because someone on Twitter was having a hard time getting hasvfunc to work and I was trying to help them make sure they had everything.
l33tmeatwad is offline   Reply With Quote
Old 11th June 2020, 03:16   #71  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 415
Added D2V Witch v4.
l33tmeatwad is offline   Reply With Quote
Old 12th June 2020, 21:55   #72  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 415
BM3D, DCTFilter, DFTTest, EEDI3m, FFT3DFilter, MVTools, and NNEDI3CL were all just updated or recompiled using static libs for the dependancies so that the dependancies will not need to be downloaded separately. I have removed the previous versions and the dependancies to avoid confusion and issues.

Last edited by l33tmeatwad; 12th June 2020 at 22:14.
l33tmeatwad is offline   Reply With Quote
Old 13th June 2020, 01:07   #73  |  Link
shph
Registered User
 
Join Date: Mar 2020
Posts: 134
Thanks for update! Can you please explain further how to deal with your new "recompiled using static libs" updates? I just usually install all your plug-ins from MediaFire folder.
Is it enough just replace old versions with new versions of BM3D, DCTFilter, DFTTest, EEDI3m, FFT3DFilter, MVTools, and NNEDI3CL in vapoursynth folder?
Could it be a conflict if i didn't delete old dependencies? I'm not sure which exact dependencies use each of these plug-ins. What if some same dependencies used by other plug-ins?
shph is offline   Reply With Quote
Old 13th June 2020, 01:09   #74  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 415
They just don't need the dependencies anymore, they are built in. This makes the files slightly larger, but prevents the need to download additional stuff. Replacing the old ones will work fine.
l33tmeatwad is offline   Reply With Quote
Old 13th June 2020, 02:20   #75  |  Link
shph
Registered User
 
Join Date: Mar 2020
Posts: 134
Ok, seems works. I updated VapourSynth + Plugins + Scripts + Hybrid package here as usual: https://forum.doom9.org/showthread.php?t=181299
shph is offline   Reply With Quote
Old 15th June 2020, 19:30   #76  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 415
Wobbly updated.
l33tmeatwad is offline   Reply With Quote
Old 16th June 2020, 15:59   #77  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 415
Added or Updated the following plugins:
AddGrain
Descale
Fix Telecined Fades
HQDN3D
MinSharp
QRCodeSource
RemapFrames
Retinex
SangNom
SCrawl
SmoothUV
TCanny
ToneMap
VideoScope
W3FDIF
l33tmeatwad is offline   Reply With Quote
Old 17th June 2020, 04:36   #78  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 415
Noticed the FFMS2 included in the installer was the old copy that links to Libz even though I had removed it in favor of using the static lib. While it still works without it is possible it may have some issues with random stuff so I updated the R49 & R50 installers with a new copy and also updated LSMASHSource to the latest release. There is also a new copy of LSMASHSource in the plugin downloads location with the static libs as well and that copy uses FFmpeg 4.3.
l33tmeatwad is offline   Reply With Quote
Old 17th June 2020, 19:49   #79  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 415
Added the following plugins:
MiniDeen
SceneChange
SurfaceBlur
TimeCube
tc2cfr
TNLMeans

Last edited by l33tmeatwad; 18th June 2020 at 01:12. Reason: Updated Information.
l33tmeatwad is offline   Reply With Quote
Old 18th June 2020, 01:45   #80  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 415
Small update, I've been working on a backlog of requests for a while and I'm close to finishing that, however there are a few that were requested that will not be added for following reasons:

depan: Depreciated
bilateralgpu: Depreciated
IT: Crashes
RemoveGrainSP: Crashes
DGMVSource: Windows Only
vcfreq: Windows Only
vcmod: Windows Only
vcmove: Windows Only
vctrans: Windows Only
VSFilterMod: Windows Only

This does not mean these will never be compiled and added, however I do not have the time right now to troubleshoot and submit pull requests or fixes for ones that are broken and some are just optimized for Windows so much that they might need to be entirely reworked.

Last edited by l33tmeatwad; 18th June 2020 at 04:21. Reason: Updated Information.
l33tmeatwad is offline   Reply With Quote
Reply

Tags
meatwadismagical, meatwadthegreat

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 22:02.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.