Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old 7th February 2021, 19:41   #61261  |  Link
zveroboy
Registered User
 
Join Date: Apr 2012
Posts: 10
Quote:
Originally Posted by VBB View Post
No issues with this build.
LAV-Video-Filter ---> 1920x1080 (No issue)
MPC-BE (Internal Filter) ---> 1920x2160

Quote:
Originally Posted by VBB View Post
For new builds, use the same link and simply change the number. For example, the next one will be called "madVRhdrMeasure124.zip".
Thanks alot!
zveroboy is offline   Reply With Quote
Old 11th February 2021, 02:58   #61262  |  Link
stmhlm
Registered User
 
Join Date: Jan 2021
Posts: 1
I'm unable to load a custom arve curve for tone mapping in madVR.


I understand that madVR's own tone mapping is better since it's dynamic, but figured I could try loading arve curves into madVR to see how they would perform in my projector.

Once I select 'arve custom curve' in 'tone mapping curve' an explorer window opens where it lets me select the .conf file, once selected/loaded by pressing 'Open', madVR instead selects 'BT.2390'.

If I select 'BT.2390' from the list, I cannot 'Apply' it, because it has already been applied by trying to load the custom arve curve.


Support for arve curves was implemented in v0.92.13, I've tried that build, and all builds up to the most recent build, no luck at all.

You cannot load arve curves with the latest HDR build installed/patched, so obviously those builds are not installed.


I've tried two different curves, one with 'eo' set to 'eotf_pq' and one set to 'eotf_gamma_2_4' but none seem to bite.

Can anyone of you replicate the issue?


I'm using Javs V3 curve, from AVSforum, specifically the '1200nitv3' curve, you'll find it below.

https://www.dropbox.com/s/xbwz9fyt62...%20v3.zip?dl=1


Thanks!
stmhlm is offline   Reply With Quote
Old 17th February 2021, 15:57   #61263  |  Link
slappy
Registered User
 
Join Date: Feb 2021
Posts: 1
Can someone confirm that new AMD cards like the 6800xt are supporting 3D mvc mkv. I need to upgrade my system and nvidia dropped the 3D support on their drivers.
slappy is offline   Reply With Quote
Old 17th February 2021, 16:36   #61264  |  Link
mclingo
Registered User
 
Join Date: Aug 2016
Posts: 1,243
the 5700 series does so it should do, there has been no announcement about pulling this, all current drivers still work on my card
__________________
LG OLED EF950-YAM RX-V685-RYZEN 3600 - 16GBRAM - WIN10 RX 5700
mclingo is offline   Reply With Quote
Old 17th February 2021, 18:22   #61265  |  Link
HillieSan
Registered User
 
Join Date: Sep 2016
Posts: 167
Quote:
Originally Posted by ang3l View Post
how is the situation on hdr switching for amd rx6000 and nvidia rtx3000? right now I have a rx480 and it works without problems

also the 23.976hz for the nvida rtx has improved? in the past I had a 9600gt and it was a disaster compared to amd

sorry guys but it's hard to get this fresh new information
Hi, I had a similar question regarding the AMD RX480 not long ago. I went to the nvidia rtx 3060 Ti because the newest AMD cards were not available and the prices were high sky. Also madvr is fast on nvidia.

NVidia runs correct and stable out of the box with madvr. No cru required. Only Windows doesn't switch to HDR automatically. It's known to be a driver issue.
HillieSan is offline   Reply With Quote
Old 18th February 2021, 22:25   #61266  |  Link
menac1ty
Registered User
 
Join Date: Mar 2020
Posts: 6
I have a GTX 980Ti and a Ryzen 2600x
1080p
When playing a video file with madVr, the whole system restarts within 10 seconds. I've tried 32bit and 64bit, different settings, updated LAV filters, nothing.
I have no issue in games or any type of stress testing the GPU.
What's the problem?
menac1ty is offline   Reply With Quote
Old 18th February 2021, 22:42   #61267  |  Link
KrazyLurt
Registered User
 
Join Date: Nov 2018
Posts: 21
Nvidia 461.40 Vsync workaround

Updating to 461.40 indeed changes how vsync acts and for me it introduces small stutters ( no drops in the OSD).

The solution for me is to again check fullscreen exclusive mode in the MadVR settings. This works with mpc-hc.
Sadly not with PotPlayer, let me know why or how to solve it.

- Sidenote for mpv users -
Same issue , solved with using opengl, I use these flags:
# no vsync issues
gpu-api=opengl
opengl-swapinterval=1
fbo-format=rgba16f # required for fsrcnnx with opengl

I usually use d3d11 or vulkan so a solution to this as well is welcomed.
KrazyLurt is offline   Reply With Quote
Old 19th February 2021, 00:46   #61268  |  Link
Warlock
Registered User
 
Join Date: Mar 2012
Posts: 37
I was having a lot of stutterings with the rtx 2060, no drop frames, driver v460,79. Presentation glitches were many, just open the video on the mpc-hc and it was already 4 ~ 5 and it kept increasing. It only solved the problem when the vsync was turned off on the nvidia control panel for the mpc-hc and the madvr executable, then it solved the problem of stutterings, it's over, now everything flows perfectly. In short, vsync active at least for me only causes problems with madvr, if you don't want to turn it off for the whole system, do the test only with the video player and madvr, at least it's working very well for me.
Warlock is offline   Reply With Quote
Old 19th February 2021, 01:04   #61269  |  Link
Asmodian
Registered User
 
Join Date: Feb 2002
Location: San Jose, California
Posts: 4,196
Did you try "application controlled" instead of on or off?
__________________
madVR options explained
Asmodian is offline   Reply With Quote
Old 19th February 2021, 01:05   #61270  |  Link
KrazyLurt
Registered User
 
Join Date: Nov 2018
Posts: 21
Quote:
Originally Posted by Warlock View Post
I was having a lot of stutterings with the rtx 2060, no drop frames, driver v460,79. Presentation glitches were many, just open the video on the mpc-hc and it was already 4 ~ 5 and it kept increasing. It only solved the problem when the vsync was turned off on the nvidia control panel for the mpc-hc and the madvr executable, then it solved the problem of stutterings, it's over, now everything flows perfectly. In short, vsync active at least for me only causes problems with madvr, if you don't want to turn it off for the whole system, do the test only with the video player and madvr, at least it's working very well for me.
Yeah tried that, no vsync removes the stutters but introduces tearing.

Quote:
Originally Posted by Asmodian View Post
Did you try "application controlled" instead of on or off?
Yeah I have tried all three, all combinations with above applications+madvr. Application controlled is the recommended by Nvidia going forward but it's a shame that the vsync is acting up. I've tried a bunch of different things like turning on HAGS to nu avail.

Last edited by KrazyLurt; 19th February 2021 at 01:10.
KrazyLurt is offline   Reply With Quote
Old 19th February 2021, 02:12   #61271  |  Link
KrazyLurt
Registered User
 
Join Date: Nov 2018
Posts: 21
SOLVED the Vsync in Mpc-HC, and PotPlayer w MadVR

Well I solved my issue, I hope this post will be useful.
As mentioned earlier, had vsync issues, solved in mpc-hc with fullscreen exclusive but it didnt work with PotPlayer.

Well this is solved in MadVR settings:

EDIT: Asmodian corrected my error of reasoning, so this is my solution after adjusting as Asmodian explained below

Lower the vaule "present several frames in advanced" to "1", this work under "window mode" and "exclusive mode"

I previously had it 8 frames in advanced. The only value working for me is "1".



Only thing left now is getting d3d11 and vulkan APIs working in MPV, I havent found any flag for editing how many frames presented in advance, maybe its somewhere in the io manual or it doesnt work the same. Anyway, input is welcomed as usual.

Last edited by KrazyLurt; 19th February 2021 at 03:11. Reason: Correction after explanatinon in Asmodian's post below
KrazyLurt is offline   Reply With Quote
Old 19th February 2021, 02:41   #61272  |  Link
Asmodian
Registered User
 
Join Date: Feb 2002
Location: San Jose, California
Posts: 4,196
Quote:
Originally Posted by KrazyLurt View Post
I previously had it checked and 8 frames in advanced. The only value working is 1 or (of course, same thing) toggle it off.
This is not the same thing at all!

If you turn it off it uses a very old method to present the frames. Notice how it changes to "how many backbuffers shall be used:" instead of "how many video frames shall be presented in advance:"?

I have been recommending <=3 frames presented in advance for a long time now. I definitely had stuttering with values >3 well before this driver update. Many users report best results with it set to 1.

Using backbuffers instead is not recommended, though I am not sure exactly why. Slower?
__________________
madVR options explained
Asmodian is offline   Reply With Quote
Old 19th February 2021, 02:59   #61273  |  Link
KrazyLurt
Registered User
 
Join Date: Nov 2018
Posts: 21
Okay, sorry about writing it as the same thing, to the not too experienced eye it looked like it would behave the same way.

Thanks for the heads-up , I will adjust my settings accordingly.
KrazyLurt is offline   Reply With Quote
Old 19th February 2021, 10:25   #61274  |  Link
Siso
Registered User
 
Siso's Avatar
 
Join Date: Sep 2013
Location: Bulgaria
Posts: 512
Quote:
Originally Posted by Asmodian View Post
This is not the same thing at all!

If you turn it off it uses a very old method to present the frames. Notice how it changes to "how many backbuffers shall be used:" instead of "how many video frames shall be presented in advance:"?

I have been recommending <=3 frames presented in advance for a long time now. I definitely had stuttering with values >3 well before this driver update. Many users report best results with it set to 1.

Using backbuffers instead is not recommended, though I am not sure exactly why. Slower?
Is the recommended 3 frames in advance or less for turing and ampere cards only? What about pascal cards?
Siso is offline   Reply With Quote
Old 19th February 2021, 11:24   #61275  |  Link
Asmodian
Registered User
 
Join Date: Feb 2002
Location: San Jose, California
Posts: 4,196
It seems to be everything with more recent drivers but I only have personal experiance with Turing and Ampere.
__________________
madVR options explained
Asmodian is offline   Reply With Quote
Old 19th February 2021, 12:47   #61276  |  Link
Siso
Registered User
 
Siso's Avatar
 
Join Date: Sep 2013
Location: Bulgaria
Posts: 512
Quote:
Originally Posted by Asmodian View Post
It seems to be everything with more recent drivers but I only have personal experiance with Turing and Ampere.
I see, maybe it is a new driver thing. I'm with 456.71 drivers.
Siso is offline   Reply With Quote
Old 19th February 2021, 13:16   #61277  |  Link
Warlock
Registered User
 
Join Date: Mar 2012
Posts: 37
Quote:
Originally Posted by KrazyLurt View Post
Well I solved my issue, I hope this post will be useful.
As mentioned earlier, had vsync issues, solved in mpc-hc with fullscreen exclusive but it didnt work with PotPlayer.

Well this is solved in MadVR settings:

EDIT: Asmodian corrected my error of reasoning, so this is my solution after adjusting as Asmodian explained below

Lower the vaule "present several frames in advanced" to "1", this work under "window mode" and "exclusive mode"

I previously had it 8 frames in advanced. The only value working for me is "1".



Only thing left now is getting d3d11 and vulkan APIs working in MPV, I havent found any flag for editing how many frames presented in advance, maybe its somewhere in the io manual or it doesnt work the same. Anyway, input is welcomed as usual.
I did what the Asmodian said, I went back to the default settings for vsync and power on the nvidia control panel. I will follow your tips for mpc-hc, in case just activate the automatic full exclusive mode option in general setttings, and then set the value "1" in present several frames in advanced, both in windowed and exclusive mode?
Warlock is offline   Reply With Quote
Old 19th February 2021, 15:53   #61278  |  Link
KrazyLurt
Registered User
 
Join Date: Nov 2018
Posts: 21
Quote:
Originally Posted by Warlock View Post
I will follow your tips for mpc-hc, in case just activate the automatic full exclusive mode option in general setttings, and then set the value "1" in present several frames in advanced, both in windowed and exclusive mode?
I did adjust the value in both windowed and exclusive, not because it mattered, but I saw no reason to have a value beyond that now when vsync, going forwards, is implemented the way it is, unless Nvidia see it as a bug and make some adjustments.
KrazyLurt is offline   Reply With Quote
Old 19th February 2021, 17:06   #61279  |  Link
Greenhorn
Registered User
 
Join Date: Apr 2018
Posts: 51
Quote:
Originally Posted by KrazyLurt View Post
Well I solved my issue, I hope this post will be useful.
As mentioned earlier, had vsync issues, solved in mpc-hc with fullscreen exclusive but it didnt work with PotPlayer.

Well this is solved in MadVR settings:

EDIT: Asmodian corrected my error of reasoning, so this is my solution after adjusting as Asmodian explained below

Lower the vaule "present several frames in advanced" to "1", this work under "window mode" and "exclusive mode"

I previously had it 8 frames in advanced. The only value working for me is "1".



Only thing left now is getting d3d11 and vulkan APIs working in MPV, I havent found any flag for editing how many frames presented in advance, maybe its somewhere in the io manual or it doesnt work the same. Anyway, input is welcomed as usual.
so it's kinda offtopic for madVR, but MPV uses backbuffers like madVR's old DX9 and DX9 Windowed Overlay modes. set it with swapchain-depth in your mpv config.

Since it's not presentation in advance I'm not sure if the same logic applies. I know the old Windowed Overlay mode in madVR is actually stutter-free for me with 3 backbuffers on a Turing card. (And this stuttering nonsense started for most people when Turing came out.)
Greenhorn is offline   Reply With Quote
Old 19th February 2021, 18:05   #61280  |  Link
ang3l
Registered User
 
Join Date: Apr 2003
Posts: 19
is there anyone with an amd rx6000 series (6800/6900) ? before I had an rx480 and the hdr switching was working perfectly now there is no way to make it work

letest amd driver Adrenalin 2020 Edition 21.2.2 Optional

tried with both madvr 92.17 and latest beta madVRhdrMeasure123b, outputting full rgb or ycbcr 4:4:4



EDIT

ok it seems related to the latest madvr beta, with normal 92.17 it works now, my old gpu didn't have enough strength to do tone mapping with madvr so I had never installed a beta versions of madvr before

anyone had problem with newer beta and amd?

Last edited by ang3l; 19th February 2021 at 18:49.
ang3l is offline   Reply With Quote
Reply

Tags
direct compute, dithering, error diffusion, madvr, ngu, nnedi3, quality, renderer, scaling, uhd upscaling, upsampling

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 19:02.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.