Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old 6th May 2009, 09:43   #1  |  Link
FlimsyFeet
Registered User
 
Join Date: Feb 2003
Posts: 362
Blurred DVD playback with MPC-HC

Ultimately my aim is to be able to watch DVDs off my PC, upscaled to 1080p (either 25 or 23.976 progressive fps) through a DVI to HDMI cable to my plasma display.

So I was trying to set up and calibrate the display last night using the PAL version of Digital Video Essentials. Here is a screenshot of a resoltuion test:


And here is what it looks like in MPC-HC v1.2.908.0:


Looks like there is some kind of deinterlacing destroying the picture, but I've tried altering the settings in the MPEG-2 decoder, and in the video card drivers (ATI Catalyst Control Center) but cannot retrieve the lost detail.
FlimsyFeet is offline   Reply With Quote
Old 6th May 2009, 09:50   #2  |  Link
mark0077
Registered User
 
Join Date: Apr 2008
Posts: 1,088
Quote:
Originally Posted by FlimsyFeet View Post
Ultimately my aim is to be able to watch DVDs off my PC, upscaled to 1080p (either 25 or 23.976 progressive fps) through a DVI to HDMI cable to my plasma display.

So I was trying to set up and calibrate the display last night using the PAL version of Digital Video Essentials. Here is a screenshot of a resoltuion test:


And here is what it looks like in MPC-HC v1.2.908.0:


Looks like there is some kind of deinterlacing destroying the picture, but I've tried altering the settings in the MPEG-2 decoder, and in the video card drivers (ATI Catalyst Control Center) but cannot retrieve the lost detail.
Yes, mpc-hc is not very good out of the box for dvd playback because it assumes the DVD's interlaced flags are set correctly (when they hardly ever are). You need to go into the internal filters and double click the mpeg2 filter. You need to force de-interlacing to "weave" and this will double your DVD quality.

I hope to convince the mpc-hc developers to change the behaviour of this option in an upcoming release to make mpc-hc better out of the box.
mark0077 is offline   Reply With Quote
Old 6th May 2009, 11:59   #3  |  Link
FlimsyFeet
Registered User
 
Join Date: Feb 2003
Posts: 362
I already tried forcing "weave" but it made no difference to the output.
FlimsyFeet is offline   Reply With Quote
Old 6th May 2009, 12:11   #4  |  Link
mark0077
Registered User
 
Join Date: Apr 2008
Posts: 1,088
Quote:
Originally Posted by FlimsyFeet View Post
I already tried forcing "weave" but it made no difference to the output.
Have you tried changing the scaling options in the "Output" tab of mpc-hc. When using evr-custom presentation, you can select various resizing algorithms to use. The bottom most is the sharpest I believe. That might make the image sharper when scaled... worth a shot if you havn't tried it.
mark0077 is offline   Reply With Quote
Old 6th May 2009, 14:03   #5  |  Link
Jong
Registered User
 
Join Date: Mar 2007
Location: London, UK
Posts: 576
Quote:
Originally Posted by FlimsyFeet View Post
I already tried forcing "weave" but it made no difference to the output.
Did you go back a chapter and then forward again to that frame, after making the change?

DVE displays still frame images not moving video for these tests. the screen is not redrawn until you manually refresh it.

I have just done exactly this test here. I can confirm that using "auto" deinterlacing you get "bob" and half resolution - just what you see. "weave" correctly displays full resolution after you refresh the image.

By the way, Cyberlink MPEG2 decoder displays full resolution in "auto" mode and uses DVXA. Generally I would recommend uisng an alternate MPEG2 decoder if you have one, if it can use DXVA and hardware de-interlacing.

Last edited by Jong; 6th May 2009 at 15:09.
Jong is offline   Reply With Quote
Old 6th May 2009, 16:15   #6  |  Link
clsid
*****
 
Join Date: Feb 2005
Posts: 5,232
Does the blurring also occur when playing in windowed mode? Resizing before deinterlacing is a possible cause of blurring.
clsid is offline   Reply With Quote
Old 6th May 2009, 18:05   #7  |  Link
Jong
Registered User
 
Join Date: Mar 2007
Location: London, UK
Posts: 576
The screenshot clearly looks like bobbing to me, not blurring.
Jong is offline   Reply With Quote
Old 7th May 2009, 08:05   #8  |  Link
FlimsyFeet
Registered User
 
Join Date: Feb 2003
Posts: 362
Quote:
Originally Posted by Jong View Post
Did you go back a chapter and then forward again to that frame, after making the change?

DVE displays still frame images not moving video for these tests. the screen is not redrawn until you manually refresh it.

I have just done exactly this test here. I can confirm that using "auto" deinterlacing you get "bob" and half resolution - just what you see. "weave" correctly displays full resolution after you refresh the image.

By the way, Cyberlink MPEG2 decoder displays full resolution in "auto" mode and uses DVXA. Generally I would recommend uisng an alternate MPEG2 decoder if you have one, if it can use DXVA and hardware de-interlacing.
I tried going back then forward agian, and got the same half-resolution result.

Also tried using the Cyberlink video decoder within MPC-HC, and that gave the same results as well.

However, if I play the disc with PowerDVD, then I get the full resolution.

Last edited by FlimsyFeet; 7th May 2009 at 08:05. Reason: correct typo
FlimsyFeet is offline   Reply With Quote
Old 7th May 2009, 09:31   #9  |  Link
Jong
Registered User
 
Join Date: Mar 2007
Location: London, UK
Posts: 576
Quote:
Originally Posted by FlimsyFeet View Post
I tried going back then forward agian, and got the same half-resolution result.

Also tried using the Cyberlink video decoder within MPC-HC, and that gave the same results as well.

However, if I play the disc with PowerDVD, then I get the full resolution.
Hmm. That is odd. Did you try the different deinterlacing options for the Cyberlink decoder? Right-click on MPC-HC then select "filters", then Cyberlink decoder, then properties.

And it might help to list all the filters you see when you right click. Have you got ffdshow video decoder doing any post-processing?
Jong is offline   Reply With Quote
Old 7th May 2009, 10:17   #10  |  Link
Jong
Registered User
 
Join Date: Mar 2007
Location: London, UK
Posts: 576
Quote:
Originally Posted by Jong View Post
The screenshot clearly looks like bobbing to me, not blurring.
I don't know what I was thinking! The screenshot is clearly NOT bobbing (if it were the top right box would be all black and the bottom left all white). It is blending. Still changing to weave should fix it, as should using the Cyberlink decoder. That filter list will help.
Jong is offline   Reply With Quote
Old 7th May 2009, 18:14   #11  |  Link
FlimsyFeet
Registered User
 
Join Date: Feb 2003
Posts: 362
Filters in use:
default directsound device
video renderer
audio switcher
mpeg2 video decoder
ac3 audio decoder
dvd navigator

I think it is something to do with the display scaling; if I take a screenshot now with alt+i it shows the full resolution. (Also, if I press F11 for full screen). It was probaby forcing "weave" that fixed it, but that didn't reflect in the winodwed display I was viewing.

Edit: It appears to be caused by enabling View -> Video frame -> Keep aspect ratio

Last edited by FlimsyFeet; 7th May 2009 at 22:14. Reason: more info
FlimsyFeet is offline   Reply With Quote
Reply

Tags
mpc-hc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 06:53.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.