Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > VirtualDub, VDubMod & AviDemux

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 28th December 2010, 16:21   #1  |  Link
yetanotherid
Banned
 
Join Date: Apr 2008
Posts: 723
Getiing the VirtualDubMod Frame Server to work

Could someone tell me if I'm doing something wrong or if I'm just expecting too much of the VirtualDubMod frameserver (or VirtualDub, I've tried both and get the same results) or whether it's not working as it should? Sorry if the explanation is a bit long winded....

I'm pretty sure I've got everything set up correctly (been over it a dozen times) but basically when frameserving to a .vdr file it works in a very limited way. Using the VFAPI Converter I can't get any audio when it tries to frameserve the .vdr file to an AVI, nor can I get video unless I tell it to save the video in an uncompressed format. Seems even though the VFAPICodec is installed (the VFAPI Converter won't even open a vdr file until it is) the VFAPICodec isn't working properly.
When using VirtualDubMod -> vdr -> VFAPICodec -> AVI.... if I try to open the AVI with MPC-HC I get a black screen with no audio, but it appears to be playing it. The only way to get MPC-HC to open it in some way is via a simple AVISynth, AVISource script. That way I get video but still no audio. Would that be because the VFAPICodec is a vfw codec MPC-HC can't use? (does MPC-HC use vfw codecs?)

Moving on from there I tried using VirtualDubMod to frameserve to an avi (same result with or without the AVI proxy on). If I try opening the frameserved AVI directly, MPC-HC says it can't render the file. However if I open it via an AVISynth script (AVISource) using MPC-HC then finally I've got both audio and video.

Is someone able to tell me if all of the above is normal or if not, what I may have missed?
My only reason for doing all this is because occasionally I have some video I want to edit a little before converting, but I'd prefer to convert with AutoGK. So far the only way I can make it happen is....
VirtualDub -> *.vdr.avi -> AVISource script -> MakeAVIS -> AVI -> AutoGK.
It'd much nicer if I could work out how to get AutoGK to directly open the AVI being served by VirtualDubMod. And there'd probably be more chance of everything displaying properly by the time it gets there.

Thanks.

Last edited by yetanotherid; 28th December 2010 at 16:38.
yetanotherid is offline   Reply With Quote
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 02:47.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.