Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > New and alternative a/v containers

Reply
 
Thread Tools Search this Thread Display Modes
Old 20th May 2018, 19:32   #22841  |  Link
huhn
Registered User
 
Join Date: Oct 2012
Posts: 7,998
the file doesn't have range information and hardware decoding is used so what ever is done to it in term of range is done by the renderer.
huhn is offline   Reply With Quote
Old 30th May 2018, 16:52   #22842  |  Link
isidroco
Registered User
 
Join Date: Nov 2008
Posts: 34
No matter what I do, LAV pickup subtitle in alphabetical order. (Running MPC-HC from last xp version of kliteMegaCodecPack for winxp, LAV splitter v0.70.2.17-git). I'm trying to have SPA subtitles, but even putting spa alone, or in advanced "*:spa", it always chooses first alphabetical (renaming subtitle to xxxxxx.ara.srt will make that the first picked up subtitle). Is there a way to pickup desired subtitle instead?
isidroco is offline   Reply With Quote
Old 30th May 2018, 17:22   #22843  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 10,360
External subtitles in .srt files are not controlled by LAV, you would have to convince MPC-HC to honor a language preference.
__________________
LAV Filters - open source ffmpeg based media splitter and decoders
nevcairiel is offline   Reply With Quote
Old 30th May 2018, 17:43   #22844  |  Link
mclingo
Registered User
 
Join Date: Aug 2016
Posts: 1,354
ok, so i'm going to ask a question I feel I should know the answer too but I dont, please forgive my ignorance.

I've recently purchased some wireless headphones to watch movies late night with, I have two sets, I have some RF Sony Platinums which I can also use for gaming but I also have a pair of bluetooth.

Neither will play any sound when i'm set to bitstream, with these being digital headphones I would have thought this would have worked, clearly my understanding of bitstreaming is massively lacking.

Am I doing something wrong, completely misunderstanding bitstreaming in LAV or both, or am I just a massive numpt-o-noob or all three?
mclingo is offline   Reply With Quote
Old 30th May 2018, 17:57   #22845  |  Link
nussman
Registered User
 
Join Date: Nov 2010
Posts: 238
You need a decoder (ac3, dts etc.) somewhere. Seems like your headphones dont have decoders onboard => no sound with bitstream output.
nussman is offline   Reply With Quote
Old 30th May 2018, 17:59   #22846  |  Link
mclingo
Registered User
 
Join Date: Aug 2016
Posts: 1,354
Quote:
Originally Posted by nussman View Post
You need a decoder (ac3, dts etc.) somewhere. Seems like your headphones dont have decoders onboard => no sound with bitstream output.
thats obvious now you've said that, my brain just needed a nudge in the right direction.

Thanks.
mclingo is offline   Reply With Quote
Old 30th May 2018, 18:03   #22847  |  Link
nussman
Registered User
 
Join Date: Nov 2010
Posts: 238
Would be greate if LAV could fallback to PCM if the renderer doesnt support bitstreaming, but I think we have discussed this issue in the past and there was no solution to do this properly.
nussman is offline   Reply With Quote
Old 30th May 2018, 19:55   #22848  |  Link
mclingo
Registered User
 
Join Date: Aug 2016
Posts: 1,354
yeah that would be really nice, must be possible but i'm sure Nev has lots of other priorities. For now i've just setup a seperate player for phones.

cheers.
mclingo is offline   Reply With Quote
Old 31st May 2018, 00:22   #22849  |  Link
isidroco
Registered User
 
Join Date: Nov 2008
Posts: 34
No matter what I do, LAV pickup subtitle in alphabetical order. (Running MPC-HC from last xp version of kliteMegaCodecPack for winxp, LAV splitter v0.70.2.17-git). I'm trying to have SPA subtitles, but even putting spa alone, or in advanced "*:spa", it always chooses first alphabetical (renaming subtitle to xxxxxx.ara.srt will make that the first picked up subtitle).
PS: As an exception, if: "Two and a Half Men - 5x01 - Large Birds Spiders and Mom.avi"
With an extra space "Birds Spiders" will show .spa instead.
isidroco is offline   Reply With Quote
Old 31st May 2018, 13:04   #22850  |  Link
clsid
*****
 
Join Date: Feb 2005
Posts: 5,664
The settings in LAV Splitter are only for embedded subtitles, not for external subtitle files.

You can configure it here for external ones:
MPC-HC options > Playback > Default Track Preference

The K-Lite installer even has options to select your preferred language(s), which configures everything automatically.
clsid is offline   Reply With Quote
Old 2nd June 2018, 16:31   #22851  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 10,360
I've been working on improving TrueHD bitstreaming, and posted a test version on GitHub:

https://github.com/Nevcairiel/LAVFilters/issues/208

If you've been encountering issues with TrueHD bitstreaming, primarily drop-outs on high bitrate TrueHD+Atmos streams from UHD Blu-rays, give this version a try and leave feedback on GitHub.
__________________
LAV Filters - open source ffmpeg based media splitter and decoders
nevcairiel is offline   Reply With Quote
Old 3rd June 2018, 02:45   #22852  |  Link
jmone
Registered User
 
Join Date: Dec 2007
Posts: 652
Changes look good and seemed to have solved the high bit rate dropouts - FYI, the changes are also in the latest LAV Nightlies - https://files.1f0.de/lavf/nightly/
jmone is offline   Reply With Quote
Old 3rd June 2018, 12:42   #22853  |  Link
fireattack
Registered User
 
Join Date: Nov 2017
Posts: 16
Hi everyone, I have a small question about decoding video that is hybrid (film and NTSC interlaced).
The video is remuxed using MakeMKV from a DVD. The first part of the video is film, and the second part is NTSC interlaced.

I play the video in MPC-HC (tried other players, some result) and open MadVR OSD to show stats.

It initially shows "deinterlacing off (says upstream)" when playing first film part, and automatically changes to "deinterlacing on (says upstream)" when it enters part 2.
You can even drag the progress bar to part 2 and it will immediately change to "deinterlacing on (says upstream)" as well.

However, the problem is: once it start to show "deinterlacing on (says upstream)", drag the progress bar back to part 1 will NOT change it back to "deinterlacing off (says upstream)".

So, my question is:

1. is it just an OSD problem (even could be MadVR's problem)?
2. If not, will it affect actual playback? Like, it may cause unnecessary deinterlacing downstream on the film (progressive) part.

Thanks.
fireattack is offline   Reply With Quote
Old 3rd June 2018, 14:19   #22854  |  Link
Orf
YAP author
 
Join Date: Jul 2014
Location: Russian Federation
Posts: 111
Hi nevcairiel,
I'm experimenting a bit with BDA live source graphs and encounter an issue where LAV Video decoder deadlocks with MS MPEG-2 Demultiplexer. Deadlock only happens when graph is running and when Demux performs a dynamic media type change on LAV Video decoder.

Here's stack trace:
Code:
77e0ef34 +044 ntdll.dll                               RtlEnterCriticalSection
62d54173 +093 LAVVideo.ax  dshowutil.cpp      393 +16 FindPinIntefaceInGraph
62cd9378 +118 LAVVideo.ax  lavvideo.cpp       629 +31 CLAVVideo.CreateDecoder
62cd9a0f +00f LAVVideo.ax  lavvideo.cpp       781  +4 CLAVVideo.SetMediaType
62d571dc +02c LAVVideo.ax  decssinputpin.cpp  381  +2 CDeCSSTransformInputPin.SetMediaType
62cdbd07 +117 LAVVideo.ax  lavvideo.cpp      1461 +16 CLAVVideo.Receive
62d57180 +060 LAVVideo.ax  decssinputpin.cpp  375  +2 CDeCSSTransformInputPin.Receive
62d51098 +038 LAVVideo.ax  amfilter.cpp      3041  +7 CBaseInputPin.ReceiveMultiple
75258482 +022 KERNEL32.DLL                            BaseThreadInitThunk
Is there anything I can do to avoid this behavior instead of stopping the entire graph?
Orf is offline   Reply With Quote
Old 3rd June 2018, 15:35   #22855  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 10,360
The interesting question would be what is holding the other side of that lock, that its apparently hanging on?
__________________
LAV Filters - open source ffmpeg based media splitter and decoders
nevcairiel is offline   Reply With Quote
Old 3rd June 2018, 15:44   #22856  |  Link
Manni
Registered User
 
Join Date: Jul 2014
Posts: 958
Quote:
Originally Posted by nevcairiel View Post
I've been working on improving TrueHD bitstreaming, and posted a test version on GitHub:

https://github.com/Nevcairiel/LAVFilters/issues/208

If you've been encountering issues with TrueHD bitstreaming, primarily drop-outs on high bitrate TrueHD+Atmos streams from UHD Blu-rays, give this version a try and leave feedback on GitHub.
Hi Nev, I posted on Github as well, but it's solved here (testing with GotG Vol2 in Atmos), thanks! 1080Ti to Denon X8500H. Same results with the lastest nightly (42).
__________________
Win11 Pro x64 b23H2
Ryzen 5950X@4.5Ghz 32Gb@3600 Zotac 3090 24Gb 546.65
JRVR/LAV/jRiver/MyMovies/CMC
Denon X8500HA>HD Fury VRRoom>Samsung 77S90C

Last edited by Manni; 3rd June 2018 at 15:47.
Manni is offline   Reply With Quote
Old 3rd June 2018, 16:11   #22857  |  Link
Orf
YAP author
 
Join Date: Jul 2014
Location: Russian Federation
Posts: 111
Quote:
Originally Posted by nevcairiel View Post
The interesting question would be what is holding the other side of that lock, that its apparently hanging on?
Ah, sorry not to mention that. "MS MPEG-2 Demultiplexer" does. It's stuck inside the IMPEG2PIDMap::MapPID call. And I suppose that's the place from where it calls Receive on LAV Video decoder input pin
Orf is offline   Reply With Quote
Old 3rd June 2018, 17:22   #22858  |  Link
KoD
Registered User
 
Join Date: Mar 2006
Posts: 567
@nevcariel

I've been using LAVFilters-0.70.2-83 for a long time now. I just updated to LAVFilters-0.71.0-30, but started noticing right away random audio pops and cracks. They're not loud, but they're there. Very easy to notice on dtshd-ma 24 bit integer 48KHz BluRay soundtracks which decode to 24bit integer 48Khz, but it's there on AC3 that decodes to 32 bit float too. Tried LAVFilters-0.71.0-35, and it's the same. Tried playing on both an external audio receiver (digital optical out), as well as over HDMI, and it's the same. Went back to LAVFilters-0.70.2-83 again and the sound is free of these cracks and pops. I have not tried any intermediate versions.

Later edit: well, I just noticed the cracks are there with LAVFilters-0.70.2-83 too.

Even later edit: yes, they're in LAVFilters-0.70.2-83 too, but not as often than in LAVFilters-0.71.0-35; with the latest version of the filters it's so often it's impossible not to notice it and is very distracting.

Later later edit: forgot to say that the cracks and pops are not there when playing the same m2ts or mkv file with PowerDVD and letting it decode the audio.

Last edited by KoD; 3rd June 2018 at 19:00.
KoD is offline   Reply With Quote
Old 3rd June 2018, 19:03   #22859  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 10,360
This sounds more like an issue on how the audio gets output then how it gets decoded, because decoding has been bitexact for several versions, and if there was a fundamental problem across all audio formats, I'm sure someone would've reported it before as well.
Thats something always to keep in mind, decoding is independent of the setup of your system. It gets audio data in and gives you decoded data back. So any fundamental decoding problem would easily manifest for a lot of people.

The output to the hardware however is entirely dependent on the hardware. And your particular issue sounds like using bigger output buffers might help, but thats not something LAV controls - thats the Audio Renderer (a part that would also be different in something like PDVD).
__________________
LAV Filters - open source ffmpeg based media splitter and decoders

Last edited by nevcairiel; 3rd June 2018 at 20:48.
nevcairiel is offline   Reply With Quote
Old 3rd June 2018, 19:05   #22860  |  Link
pikaczu
Guest
 
Posts: n/a
when new wersion?
  Reply With Quote
Reply

Tags
decoders, directshow, filters, splitter

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 20:22.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.