Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > General > Newbies

Reply
 
Thread Tools Search this Thread Display Modes
Old 14th September 2010, 01:44   #1  |  Link
fi3ryfalc0nZ
Registered User
 
Join Date: Apr 2009
Posts: 2
Encoding Subtitles Into Video

Hi,
I'm using MeGUI and I've been encoding hard subs into the video. But now, I encountered a problem. It seems that my subtitles is out of sync (timed correctly with Aegisub) with the video when I create the AVS script. I thought it was just a problem on the AVS script creator side, but when I encoded the video, my subtitles is still out of the sync (probably 1 or 2 frame off?). May I know why is that?

Thanks
fi3ryfalc0nZ is offline   Reply With Quote
Old 14th September 2010, 02:11   #2  |  Link
Inspector.Gadget
Registered User
 
Join Date: May 2008
Posts: 1,618
Post your Avisynth script. If you're using DirectShowSource - which is known not to be frame-accurate in some cases - try a different source filter in Avisynth.
Inspector.Gadget is offline   Reply With Quote
Old 14th September 2010, 09:12   #3  |  Link
Ghitulescu
Registered User
 
Ghitulescu's Avatar
 
Join Date: Mar 2009
Location: Germany
Posts: 5,770
Most people do not sense 1 frame delay (PAL 40ms, NTSC ~33ms) even for audio, which is the most striking asynch issue.
Ghitulescu is offline   Reply With Quote
Old 14th September 2010, 12:17   #4  |  Link
fi3ryfalc0nZ
Registered User
 
Join Date: Apr 2009
Posts: 2
hi,
i've solved that problem by fixing a framerate to it. However, there's one problem to it. Whenever I cut them, there's an extra picture/frame that i do not want that's inside. And I firmly believe that I cut it correctly.

Quote:
DirectShowSource("C:\Users\Sean\Desktop\[Dm258.Raws] Naruto Shippuuden - 176 RAW (TX 1280x720 H264 AAC).mkv", fps=23.976, audio=false, convertfps=true)
#deinterlace
#crop
#resize
#denoise

LoadPlugin("C:\Program Files (x86)\MeGUI\tools\avisynth_plugin\VSFilter.dll")
TextSub("C:\Users\Sean\Desktop\Naruto Shippuuden Opening 7 - Toumei Datta Sekai.ass", 1)

Trim(5729, 7885)


ConvertToYV12()
fi3ryfalc0nZ is offline   Reply With Quote
Reply

Tags
subtitle, sync, time

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 06:03.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.