Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > New and alternative a/v containers

Reply
 
Thread Tools Search this Thread Display Modes
Old 31st January 2022, 12:00   #461  |  Link
oniiz86
Registered User
 
Join Date: Oct 2019
Posts: 31
Quote:
Originally Posted by fireattack View Post
Hi, I want to report a bug/inconsistency in the GUI.

When loading an input file, it shows two "delays" for any track.

According to https://sourceforge.net/p/gmkvextrac...read/ee13f7e1/ the first delay is relative to 0 timestamp and the second one is relative to the video.

The original comment only mentions audio track, so what about the video track?
Is the second delay still relative to the video (itself), or to the audio?

Either way, it doesn't seem to match with the behavior.

I made two videos to test: one with audio delayed for 2sec, one with video delayed for 2sec.

The first one (audio delay):



The video's second delay says "0ms", so it means it's NOT delay relative to audio, because otherwise it would be "-1978ms".

The second one (video delay):



Now, here video's second delay says "2000 ms", which means it's indeed relative to the audio. This is inconsistent with example 1.

Summary:

In both cases, the first delay of video track is consistently shows the delay relative to 0 timestamp.
In both cases, the first delay of audio track is consistently shows the delay relative to 0 timestamp.
In both cases, the second delay of audio track is consistently shows the delay relative to the video track.

However, the second delay of video track is inconsistent, it shows the delay relative to the audio in one, but not in another (it is not consistently relative to the video, either.)
@gpower2 I was just wondering if this bug was fixed in the latest v2.6.0?
oniiz86 is offline   Reply With Quote
Old 2nd February 2022, 08:42   #462  |  Link
gpower2
gMKVExtractGUI author
 
gpower2's Avatar
 
Join Date: Aug 2003
Location: Greece / Thessaloniki
Posts: 239
Quote:
Originally Posted by oniiz86 View Post
@gpower2 I was just wondering if this bug was fixed in the latest v2.6.0?
@oniiz86 This is not a "bug" it's how MKVToolnix works.

The second delay shown in the video track, will always be the same as the first one, I think the only case that it will be different, is if there are multiple video tracks muxed in the same mkv, with different delays. It is not the relative delay to the audio in any case.

So the examples you have posted are by design and not a bug.
gpower2 is offline   Reply With Quote
Old 2nd February 2022, 08:53   #463  |  Link
oniiz86
Registered User
 
Join Date: Oct 2019
Posts: 31
Quote:
Originally Posted by gpower2 View Post
@fireattack
So sorry for the late reply, too much work IRL!
Actually the second delay in the video track will always be the same with the first one, you are right and I should refrain from showing 2 delays for the video tracks.
There is no video delay relative to the audio, since that is not the way MKVToolnix works, at least AFAIK.
I'll check if I can make this fix.
Thanks for your feedback!
Quote:
Originally Posted by gpower2 View Post
@oniiz86 This is not a "bug" it's how MKVToolnix works.

The second delay shown in the video track, will always be the same as the first one, I think the only case that it will be different, is if there are multiple video tracks muxed in the same mkv, with different delays. It is not the relative delay to the audio in any case.

So the examples you have posted are by design and not a bug.
@gpower2 Thanks for that I wasn't aware it was by design, it was just your comment you had made back then to @fireattack "I'll check if I can make this fix.", I assumed it was an inconsistent visual bug with gMKVExtractGUI v2.5.2, nevermind all is good
oniiz86 is offline   Reply With Quote
Old 26th February 2022, 18:51   #464  |  Link
Shou
Registered User
 
Join Date: Jan 2022
Posts: 2
Hi,
There is a problem when there is a slash character in the track name, e.g. "name/subname" and you have {TrackName} in the output file name.

test.mka



Result:
File "subname].ass" in "/test_02_[und][name/" folder.
File "subname2].ass" in "/test_03_[und][name2/" folder.

-
Attached Files
File Type: zip test.zip (46.5 KB, 11 views)
__________________
"I'm just a man." 🐦

Last edited by Shou; 27th February 2022 at 16:07.
Shou is offline   Reply With Quote
Old 1st March 2022, 08:21   #465  |  Link
gpower2
gMKVExtractGUI author
 
gpower2's Avatar
 
Join Date: Aug 2003
Location: Greece / Thessaloniki
Posts: 239
@Shou

That's a really nice edge case, I guess this bug existed since forever.

I will replace illegal filename character with space, I think that would be the best approach here, any objections?
gpower2 is offline   Reply With Quote
Old 1st March 2022, 12:41   #466  |  Link
Shou
Registered User
 
Join Date: Jan 2022
Posts: 2
Yeah, replace with a space (or underscore) should be OK.
__________________
"I'm just a man." 🐦
Shou is offline   Reply With Quote
Old 5th March 2022, 16:49   #467  |  Link
gpower2
gMKVExtractGUI author
 
gpower2's Avatar
 
Join Date: Aug 2003
Location: Greece / Thessaloniki
Posts: 239
gMKVExtractGUI v2.6.1

Hey people!
Thank to @Shou's feedback, I just released a minor version to address the issue with invalid file characters in the output filename.

As always, enjoy!

Download link:
https://sourceforge.net/projects/gmk....1.7z/download

Changelog

v2.6.1
  • Replace invalid file characters with underscore character ('_') from output filename

Last edited by gpower2; 5th March 2022 at 16:54.
gpower2 is offline   Reply With Quote
Old 6th March 2022, 11:25   #468  |  Link
SeeMoreDigital
Life's clearer in 4K UHD
 
SeeMoreDigital's Avatar
 
Join Date: Jun 2003
Location: Notts, UK
Posts: 12,076
Many thanks
__________________
| I've been testing hardware media playback devices and software A/V encoders and decoders since 2001 | My Network Layout & A/V Gear |
SeeMoreDigital is offline   Reply With Quote
Old 6th March 2022, 11:28   #469  |  Link
tormento
Acid fr0g
 
tormento's Avatar
 
Join Date: May 2002
Location: Italy
Posts: 2,176
Quote:
Originally Posted by gpower2 View Post
Thank to @Shou's feedback, I just released a minor version to address the issue with invalid file characters in the output filename.
Thank you!

Please consider to switch to GitHub as Sourceforge is giving lot of connection problems lately.
__________________
@turment on Telegram
tormento is offline   Reply With Quote
Old 7th March 2022, 11:43   #470  |  Link
gpower2
gMKVExtractGUI author
 
gpower2's Avatar
 
Join Date: Aug 2003
Location: Greece / Thessaloniki
Posts: 239
Quote:
Originally Posted by tormento View Post
Please consider to switch to GitHub as Sourceforge is giving lot of connection problems lately.
It's been on my TODO list like 3 years now

I just didn't have the time (or the determination) to change my local repo setup, though it's the next thing to actually tackle.
gpower2 is offline   Reply With Quote
Old 8th April 2022, 20:06   #471  |  Link
mastrboy
Registered User
 
Join Date: Sep 2008
Posts: 343
Is there a known bug with extracting attachments and using a different template for the name than default?

I tried to change the template to '{FilenameNoExt}_{AttachmentFilename}' and the attachments are extracted as '_{AttachmentFilename}'

For example, I expected episode001_arial.ttf, but got _arial.ttf
__________________
(i have a tendency to drunk post)

Last edited by mastrboy; 8th April 2022 at 20:23.
mastrboy is offline   Reply With Quote
Old 9th April 2022, 11:43   #472  |  Link
gpower2
gMKVExtractGUI author
 
gpower2's Avatar
 
Join Date: Aug 2003
Location: Greece / Thessaloniki
Posts: 239
Thanks for reporting this mastrboy, I'll check it.

EDIT: Found the bug, uploading a new version shortly along with another fix

Last edited by gpower2; 9th April 2022 at 12:35.
gpower2 is offline   Reply With Quote
Old 9th April 2022, 12:39   #473  |  Link
gpower2
gMKVExtractGUI author
 
gpower2's Avatar
 
Join Date: Aug 2003
Location: Greece / Thessaloniki
Posts: 239
gMKVExtractGUI v2.6.2

Hey guys!
Thank to @mastrboy's feedback, I just released a minor version to address the issue with attachment extraction filename resolving not working correctly in all cases.
As an added bonus, I fixed another bug in track selection when filtering with empty values (eg. empty track names) and optimized the track selection a bit (should not make a difference in small lists).

As always, enjoy!

Download link:
https://sourceforge.net/projects/gmk....2.7z/download

Changelog

v2.6.2
  • Fix attachment filename for all cases. (Thanks mastrboy!)
  • Improve track selection when filter value is an empty string
  • Optimize algo to avoid unnecessary comparisons
gpower2 is offline   Reply With Quote
Old 9th April 2022, 12:43   #474  |  Link
gpower2
gMKVExtractGUI author
 
gpower2's Avatar
 
Join Date: Aug 2003
Location: Greece / Thessaloniki
Posts: 239
Small note, for some reason, the thread name no longer changes when editing the title of the first post.

If anyone knows how to change the thread title, please pm me or post here, thanks.
gpower2 is offline   Reply With Quote
Old 9th April 2022, 13:23   #475  |  Link
SeeMoreDigital
Life's clearer in 4K UHD
 
SeeMoreDigital's Avatar
 
Join Date: Jun 2003
Location: Notts, UK
Posts: 12,076
Quote:
Originally Posted by gpower2 View Post
Small note, for some reason, the thread name no longer changes when editing the title of the first post.

If anyone knows how to change the thread title, please pm me or post here, thanks.
Yep, this happens after so many years. Often one of the moderating team members can sort this out for you
__________________
| I've been testing hardware media playback devices and software A/V encoders and decoders since 2001 | My Network Layout & A/V Gear |
SeeMoreDigital is offline   Reply With Quote
Old 9th April 2022, 14:22   #476  |  Link
hubblec4
Matroska find' ich toll
 
Join Date: Apr 2008
Posts: 1,263
Quote:
Originally Posted by gpower2 View Post
Small note, for some reason, the thread name no longer changes when editing the title of the first post.
Yeah Mosu has also start a new thread.
One solution: never use a version number in the thread title
__________________
chapterEditor || Matroska-Playback || hSplit || DiscShare
hubblec4 is offline   Reply With Quote
Old 9th April 2022, 15:48   #477  |  Link
tebasuna51
Moderator
 
tebasuna51's Avatar
 
Join Date: Feb 2005
Location: Spain
Posts: 6,467
Yep, only moderators can Edit Thread
Attached Images
 
__________________
BeHappy, AviSynth audio transcoder.
tebasuna51 is offline   Reply With Quote
Old 9th April 2022, 16:52   #478  |  Link
SeeMoreDigital
Life's clearer in 4K UHD
 
SeeMoreDigital's Avatar
 
Join Date: Jun 2003
Location: Notts, UK
Posts: 12,076
Where's that 'thanks' button when you need it
__________________
| I've been testing hardware media playback devices and software A/V encoders and decoders since 2001 | My Network Layout & A/V Gear |
SeeMoreDigital is offline   Reply With Quote
Old 9th April 2022, 16:57   #479  |  Link
gpower2
gMKVExtractGUI author
 
gpower2's Avatar
 
Join Date: Aug 2003
Location: Greece / Thessaloniki
Posts: 239
Thank you everyone for this!
gpower2 is offline   Reply With Quote
Old 9th April 2022, 22:01   #480  |  Link
Bigmango
Registered User
 
Join Date: Nov 2006
Posts: 414
Could you please add the FORCED tag to the extracted track name? (edit: only if the tag exists on that track, of course)

(and (if possible with mkvtoolnix) name it so that mkvtoolnix will automatically add the "forced" tag like it does with the "delay" when adding the tracks to a new mux)?

(-> currently it's a lot of work when remuxing a lot/often, load mediainfo to check for forced tags, etc... This would remove all of this work)


Many thanks !

Last edited by Bigmango; 9th April 2022 at 22:10.
Bigmango is offline   Reply With Quote
Reply

Tags
extractor, gmkvextractgui, matroska, mkv, mkv extract, mkvextract, mkvextractgui

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 07:01.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.